What files will Synfig STudio accept?

Trying to get started but cannot even start because I cannot load any files. Every type has caused the software to collapse. Bitmap. Photoshop TIFF. I have had no trouble loading bmp in Flash.

Please be so kind as to tell me what type of file must I use and what converter to make it?

Thank you so very much.

Alan Gorg

Synfig OPENS (Toolbox Menu>File>Open, or Caret Menu>File>Open) just sif or sifz files and IMPORTS (Caret Menu>Import) the rest of files (png, jpeg, bmp, tiff, xcf, svg,…).
On the other hand Synfig Studio should not crash when you try to open a non sif(z) file but should give a warning message instead. If you get it crashing please update to the 0.62.00 version.


Thank you for your reply. Sorry I missed the IMPORT option. I have tried it and possibly imported files but no images appear on the stage. So I tried OPEN again after the importing and the software did freeze again but at least this time did not collapse until I pressed the OKAY
on the error sign.

So I followed your advice and uninstalled all of Synfig and uploaded again with the version on the Synfig site now, but now when I try to open Synfig Studio I get an error sign with the message “The procedure entry point_ZN6synfig11open_canvasERKSsRSsS2_could not be located in the dynamic link library libsynfig-0.dll.”

I know little about computer technology and do not know what this is all about. Now I cannot even open Synfig Studio, much less open a file. Synfig is beginning to seem hopeless unless you are a computer expert.

Please advise.

Thank you.

Alan Gorg

Okay, I re-installed and got the new Synfig open, but still any image file I import does not appear in the stage. I thought maybe it is there in Synfig somewhere, because when I close out Synfig and then re-open, there is a message inquiring if I want the file back? So I try OPEN but again I get an error message, though the software does not abort until I press OK.

Maybe the file is imported but I do not know how to access it?

Please be so kind as to advise.

Thank you.

Alan Gorg

After importing a file, take a look in the “Layers” panel. A new layer should appear there when the file imports.

The most probable reason you don’t see the file is that it was accidentally placed outside the visible area or set to transparent/wrong blend mode. For example, another user (see here) accidentally had the default blend mode set to “hue”, causing the image to not be displayed.

In general, we can help the best if we actually see what you did, and what Synfigstudio is showing as a result, for instance, with a screendump or screencast.

Do you know how to make a screendump on your system?


Hi alan, by your comments on the posts it seems that you’re using windows.
If so, please:

  1. Provide windows version and number of cores of your cpu.
  2. Confirm that you’ve downloaded the right 0.62.00 windows version from [size=150]here[/size]
  3. Confirm that you have unistalled all the previous synfig versions before re-install synfig
  4. Be sure that you have set the affinity of synfig to only one core using one of the applications listed here.

Once done try to create a png image using other application. Then run synfigstudio and File>Import that png image. Show us a screenshot of the result allowing to see the layer panel and the parameter panel.

Good luck.

Not a computer guy, just a guy who likes to draw and wants to turn his few simple cartoons into a short video, I am trying to answer your requests but do not even know what a core is. But my Dell is an economy model about as basic and simple as ;any consumer computer.

Here is info from my computer notes for my 2002 Dell Dimension 6000:

Microsoft Windows XP
Version 2002
Service Pack 3

LG Computers
X86 Amd or Intel Processor
Intel ®
Pentium ® 4 CPU 2 80GHz
2.80 GHz 0.99 GB of RAM

If this is not enough, please guide me.

I did uninstall Synfig Studio and install the latest version as you directed, but it does not make any difference.

However, importing the png file type produced a result none of the other file types have.
When the png file is imported, the canvas goes black. With any of the other file types, a file is apparently imported into a layer but the canvas is totally unaffected. Every file type seems able to get into a layer.but only the png file affects the canvas at all.

I have no idea how to get a screen shot. Please advise.

One suggestion I have gotten is to use something called ffmpeg, but from the download sites, I cannot even figure out what it is or figure how to decide which of the multiple forms of ffmpeg to choose for my computer and am very unsure about ffmpeg being an answer, as I do not know what it is supposed to do.

Thank you for your help.

Alan Gorg

You can get a screenshot by doing the following:

  1. Press “PrintScreen” key on your keyboard.
  2. Open up Microsoft Paint
  3. Paste (Ctrl+v) , and save the image

Thanks for the direction. I did the screenshot, but your Synfig uploader says it is too large.


Alan, it is weird. We have set a maximun of 3MB of size for the uploaded files in the forum. Please try to reduce file size (save as jpeg) or find other host to place the image… but more than 3MB… it has to be mediafire or similar.

It is very hard to help you if we don’t have a visual feed back on what’s happening. Some times it is just a silly thing easy to solve.
Also it would be interesting to see the image file that you’re triying to import to Synfig. Maybe the result you see is correct.
Good luck!


The Heavens smiled down on me and helped me convert the screenshot to jpg, and I think and hope that it has been attached to this message. I do not see it, but the upload window appeared and seemed to upload it.

Thank you for your patience and your help. I am 78 and not familiar with computers and have slowed down a lot these days, so I appreciate your sticking with me.

Please let me know if you get the screenshot and if so, is it okau?



Hi Alan,
Don’t worry, I’m sure we’ll find an aswer to this.
Look the image:

I’ve named in red the things I want you to arrange.

  1. Please go to the Toolbox File Menu and select Panels>Reset Windows to Original Layoout.
  2. After that you’ll see all the windows properly arranged.
  3. Repeat the same import operation with your image file.
  4. Select the Imported image layer.
  5. Press the zoom out button several times until you see the two corners of the imported image.
  6. Take a screenshot.
  7. Then raise the Console Window and take a screenshot too.
    8 ) Paste here the sample image file to allow us to see its content and to compare the import results.


Trying your first step, sorry, but I cannot locate any PANELS button, much less the reset.
I clicked on all the tool icons on the tool window but did not find any PANELS button.
I opened TOOLS on the canvas menu but none of the tools there is a PANELS tool.

You can see this might be difficult for both of us.

Please advise. Thanks again so much.


Try this:


Thanks once more for your patient guidance.

I did the panel reset, imported the file, took the screenshot.
Then I tried to move the console to take the second screenshot, but the console would not move and seemed frozen.

I closed down Synfig, reopened without the file, imported the file again, and was now able to move the console up and take the second screenshot.

Had to make them jpgs.

I could not seem to paste the image here(?), so it is attached also. The png file would not attach and would not convert to jpg, so I made it a gif and it attached okay.

Please let me know if what I have done is enough.

Thank you.


Sorry, but I forgot to zoom out, so I did the two screenshots again. Again after screenshot 3, I could not move the frozen console and had to shut down, reopen, and start over, and was then able to move the console and complete the fourth screenshot.

This is getting harder hehe…
Do this:

  1. Start synfigstudio
  2. In the toolbox, press a button with a white page and a wrench on it (just below the save button)
  3. Then a dialog would appear. In the dialog, select “Misc.” button and then look for a text with “Scale New Imported Images to Fit Canvas”. Be sure that it is checked on. Close the dialog. This step is important.
  4. Import the image again and it should work.

The original image you have imported seems to be bigger even than gif you provided. It is extremly huge and its boundaries are out of the scope of the canvas visible area. Fiting the image into the canvas should solve the problem.



Hate to tell you, but it still appears as all black.

But I think you are onto the right tack. I started to learn Flash, and similarly the whole stage went black. But in Flash, I was able to zoom out enough to catch the very large image of which the black was only the hair. (I gave up on Flash when I learned the output files could only be used on the internet and cannot be converted to anything else.)

My guess is that the black is in the hair, but how to draw back?

Thanks again for your patience,


Add a zoom layer above your imported picture - right click on the png name in the layer dialog and select “new layer”, “transform”, “zoom”. Then change the zoom Amount parameter to be say -2.0 (or -10.0 if you really want to zoom out).