Unable to load file , can't find linked file

Hi guys I have seen other similar posts to this problem like this (Can't find linked file) and this (Suddenly unable to load file, "can't find linked file")
the error I’m getting

I tried the steps but i could not really resolve it on my own. I tried editing the file on a file editor up to this point, i also tried changing it to characters.sif in the file editor but it came up with a different error.

So you have the uncompressed project file? Awesome, we’ll go from there.

First, create a simple new Synfig project. Just draw a circle in there and save it in the same folder where your main project is (the file that doesn’t load) as ‘1.sif’. Now open the problem file in your text editor, perform a search for “characters.sif” and replace all occurrences with “1.sif”. Save the file and try to open it in Synfig.

If everything’s fine, your work will have circles instead of characters and from there you just delete them and re-import you characters back.

Hi, sorry what do you mean by reimport the characters back? Also how does this error usually occur? I would like to avoid it in the future. Thanks !

sorry if im being a bit spammy erm after i edited the path in a file editor I’m getting a new error

Ah, don’t worry, I was being too cryptic, should have elaborated more.
OK, in a text editor after you perform find you’ll get a structure like this:

      <param name="transformation">
        <composite type="transformation">
            <angle value="0.000000"/>
            <angle value="0.000000"/>
      <param name="canvas" use="D:\Animations\hundredyearwar\characters\characters.sif#"/>
      <param name="time_dilation">
        <real value="1.0000000000"/>
      <param name="time_offset">
        <time value="0s"/>

Pay attention to this line <param name="canvas" use="D:\Animations\hundredyearwar\characters\characters.sif#"/>.

You must replace it to <param name="canvas" use="1.sif#"/>. Don’t omit any “</>” characters! In a text editor it should look like so:
For editing, I recommend Notepad++, it’s free. Other editors may or may not end up messing up the file’s structure.

Now, if file does open after this, to re-import characters hit Menu->File->Import.
If still no luck, send me the problematic file in a private message, I’ll fix it for you.

It occurs when your imported characters were located on a different drive that’s now gone. Maybe your project in C:\Animation\hundredyearwar but you characters were imported from a flash drive or a network resource that’s now resides on a different letter. It’s just a guess though.