Can't find linked file

I am getting the following error when I try to open my file and the file is where it has always been. It started when I tried to open the animation on another computer with a syncd dropbox folder but now I get the same error on my original file on my original computer. I am using .sif files from Inkscape in my animation.

Any ideas?

I don’t really mind starting over if necessary but I don’t want it to happen again. Should I embed all my .sif files as I import them?


You can save in uncompressed format (.sif) or just unpack .sifz and correct the paths with text editor (just using search&replace) or script. Look either for the path or ‘<param name=“canvas” use="’ line.

Synfig uses relative paths, so you should be fine as long as you keep directory structure the same and don’t separate linked files.

From your description i have no idea what happened to file(s) that you can no longer open original.

Thank you so much! It is fixed. I guess I started this animation file in the default synfig directory and then later moved it to the project directory because the first .sif files I added had that long path to the project directory. All the others were correct with just the filename since they are in the same directory. Anyway removing the path and just leaving the filename eg. “Earth.sif#” in the use= place fixed it.