Tom's Hardware guide Taskassign goes missing....

Anyone installing Synfig under windows recently might have noticed some problems downloading Tom’s Hardware Guide “TaskAssign” utility. This is highly recommended for dual and multi-core systems (unless you really enjoy watching programs crash repeatedly/unexpectedly)

I’ve posted on THG forum, and emailed THG to see if they can fix their link. I’m reluctant to post a copy of my download as I don’t own copyright on it. (although it’s freeware, it’s not open source).

In the meantime, I haven’t tried these, but it looks like they’re designed to do the same thing. … trol.shtml (dual core/dual CPU only) (seems targeted at XP)

Hope this helps.


Another alternative for Vista users - You can edit the shortcut in the start menu so that it says -

C:\Windows\system32\cmd.exe /C start /affinity 1 “Synfig” “C:\Program Files (x86)\synfig\bin\synfigstudio.exe”

This will help you as long as you start Synfig from the start menu (i.e. not if you open a sif or sifz file from the file manager or web link). The /affinity option is not available in WinXP.

Acceptable numbers after the affinity would be 1 or 2 (for dual CPU/dual core/single cpu w/ hyperthreading),
1, 2, 4 or 8 (for dual CPU or dual core with Hyperthreading, or Quad core without hyperthreading), 1, 2, 4, 8, 10, 20, 40, 80 (for Quad-core with hyperthreading).

Thanks for this software list Pix’!
I’ve installed SMP Seesaw, and ISOLATED synfig to 1 processor, and it seems to crash less than with THG, just assigning it to 1 processor.

I do not understand if this program is sooo important why does Synfig have it to download on their site. I have been trying to sort this problem out for hours and getting nowwhere.

Hi blackhawk,
The problem with redistributing the tool that was originally used is that we don’t own it. We didn’t write it, and it vanished from the web. The owners of it have been unresponsive to email.

Fortunately, one of the developers of Synfig put some configuration options in place to achieve the same result. In the later versions of Synfig, (0.62.0) the single threading option is exposed, but not default. In the next release it will be enabled by default. Apologies for the thrash.

See this thread also - viewtopic.php?f=15&t=1044&p=5225&hilit=single+thread#p5225


If you guys could help, I keep getting this error even though I re-install it over and over and over again. I’m a computer person, but the stuff you say is really complicated, and the tutorial video is a pretty horrible quality and I can’t see (Sorry Video Creator). Now the this Tom’s hardware thingy is gone, I’m hopeless. Please help.

The error Says:
This application has failed to start becuase libgilmm-2.4-1.dll was not found. Re-Installing the application may fix this problem.

Hi mykoolpants,
If you’re using the latest version of Synfig, you don’t need Tom’s hardware tool anymore. In fact you don’t need anything apart from the Synfig installer. Uninstall all the GTK & GTKmm programs and start over. If there’s still problems, it’s probably 1 of two things going on -
a) you’re installing in a non-standard location
b) you’re not installing with administrator privileges

Hope this helps,

Thanks that helped alot. You guys are the best.

Hi pixelgeek. Many people who works with Windows ask me about how to install Synfig in spanish on their computers. My answer is that it’s not possible at the moment. Am I right? or, is there a possibility?

You are correct. I haven’t found a way to get translations to work under windows. It wasn’t supported when Synfig was GPL’ed and the Windows build process does not enable it. In fact I’m not even convinced the Windows build environment is even reproducible right now. :frowning: I’m hoping that when we get CMake working, we can use MS Visual C and get translations working.