Synfig Studio 1.0 - Release Candidate #1


#1

[i]We are happy to announce that the first release candidate of Synfig Studio 1.0 is available for download and testing!

The upcoming version is the most significant update for the whole history of Synfig, summarizing the results of past 18 months of development. This release introduces many major features and dozens of improvements and fixes.

[size=150]The most notable highlights:[/size]

Totally reworked interface with Single-Window mode and powered by modern Gtk3 library.
New SFG file format with the possibility to embed all linked media.
Improved Groups with the support for all basic transformations and special controls for layer visibility range.
Full-featured bone system with the tools for cut-out animation, automatic shape deformation and image distortions.
Reworked vector infrastructure with the better control for tangents (split angle/split radius).
Basic sound support, featuring the Sound Layer and JACK integration.
Bitmap image painting engine with the support for MyPaint brushes.
Preliminary support for bitmap frame-by-frame animation (via Switch Layer).
Dynamics converter for automatic friction effects.
Ability to modify animated parameters when Animation Mode is off.

Get Synfig Studio 1.0-RC1

Within the next few weeks we are looking for your feedback - please report all problems/issues to our bugtracker. We also ask translators to update interface translations. Community members are welcome to update the documentation pages.

Thank you![/i]

Original post by K’


#2

Love the new features, especially group transformations and the single-window UI. Thanks for your hard work!

I like the darker color scheme too. On Windows the text is difficult to read, though. Does anyone else have that problem?

It’s not really a big deal, though. I run Ubuntu in a virtual machine, and even virtualized the deb version of Synfig is beautiful, fast and stable.


#3

d_g_> We have report about speed/lag problem under windows os,is it your case also ?


#4

IT’S BEAUTIFUL! I’m lovin’ it! Thank you so much, team! :smiley:

Just one thing: The menu bar seems to be always visible, and doesn’t appear in Unity’s global menu thing.

EDIT: Also, I unchecked “Show Menubar” somewhere, and now the menubar is gone. Sweet, but… now I can’t get it back! :blush:


#5

i want to say “normal” it’s not implemented !

hidden Menubar how to ??? :wink: … héhé … You can reactivate it by carret menu > display > show menu bar

done some little work in the doc /// wiki.synfig.org/wiki/Doc:Interfa … e_Menu_Bar


#6

Sheeit, I didn’t notice the carret menu. :blush: Thank you! :mrgreen:


#7

Sorry for the double post, but thought I’d put this here: Is it just me, or is the Brush tool function quite slow? Trying to draw stuff and it seems pretty laggy. On just one frame.

EDIT: Also, the “Make New Frame” button doesn’t seem to work for me…


#8

In general it seems more responsive than 0.63. The brush tool does feel sluggish though, as mentioned by tushantin.

As always, the speed depends quite a bit on whether you have multithreading turned on. I usually tell the Windows version to use a single thread, because it tends to be less stable.

One more note – I tried the RC1 on a Windows 8.1 box, and the text looks fine. So I’m not sure what was wrong on my other computer (Windows 7).


#9

I’m using Ubuntu, and there doesn’t seem to be an option to set the number of cores (unlike its Windows counterpart), presumably because it’s pretty stable under Linux. But it’s still pretty sluggish. I’m unable to draw anything well enough with this…


#10

Could you report it to the synfig buggtracker over Enhancement please ?


#11

Sure thing - done.


#12

Hello,
Now I see a lot a features that need some fix.
I copy&paste my critic of the other topic
1.

  1. Is there a way to change this black theme? Some icons doesn’t combine well with this dark color. The icons of the Tool panels doesn’t show well if they are activated or not because of that.

  2. I found a problem with the parameters panel. For example, suppose you draw a star, and then you want to move the origin from 0,0 to other coordinate, using th parameter panel. Double Click in the origin parameter… Only the x coordinate is visible. I change it and press enter. Now i can change the y coordinate but I can’t see what i’m doing in the parameter interface.

  3. I draw an object layer… and go to the layer dialog, select that layer, to erase it it says “Ctrl + del”, so i do it but a dialog appears talking about a previous layer that i allready erased. Result: I can’t erase the object layer (or any layer).

  4. In Ubuntu 14.10 in an old machine (Pentium4 3.20x2ghz, 1 gb ram), the brush tool is very slow, as others mention

Hope I’m … “understandable” ?


#13

Hi!
Great work with this release!
Overal text of menus and such on windows 7 is very pixelated and unreadable. Any way to change the font?
Still have to do more elaborate tests whether to see that using multithread under windows is more stable then used to be.
Greetz!


#14

Hi, can you report an issue in synfig tracker ? (checked if not already reported… )


#15

synfig1rc1-ui-handle.jpg is that part is missing ? … did you test in fullscreen ? did you have an icon with an down arrow [V] to access to more entries ? os please (ubuntu 10.4 ?)


#16

Hello,

I’m in Ubuntu 14.10 Utopic Unicorn

Am I the only one with these problems? :blush:

As you mention, it appears a down arrow [ v ]

a_2015-02-13.png

In the following, I reduced the size of the lateral panels, and now I can see too kind of handles but the others remain hidden
b_2015-02-14.png

In the next, at the bottom left, you will see the parameters panel, specially a coordinates parameter, when editing. In order to see all the values, I had to expand that column, but still it’s not entirely visible.
c_2015-02-14.png


#17

I won’t say anything about the interface, because I already stated what I don’t like in previous news, but please, guys, fix at least this bug: synfig.org/issues/thebuggeni … issues/749 before 1.0 release.

Currently, Synfig is not able to render a file that contain spaces in path and keeping in mind the fact, that a standard name for a project is “Synfig Animation1”… Well, you know, forum post with “Halp! I can’t render my first animation!” subject is guaranteed.


#18

hi svarov, i suggest you to “vote” for the issues you found important, this can help the dev team to be accurate with the users needs


#19

I also found a bug (by accident) as well.

The bug occured after i created a spline while a group is still highlighted.
First it shows up these error texts for several times, then Synfig Studio crashed.
Is it actually a bug…? :confused:

BeforeCreateSpline.jpeg

AfterCreateSpline1.jpeg

AfterCreateSpline2.jpeg

My OS is Windows 7 64-bit.


#20

Hi Fadhilkwan thank’s for taking time to report.

Can you please, respond by writing a step by step way of reproduce this bug ?