Synfig Studio 1.0 - Release Candidate #1


#21

hulf2012 > Yep defintivly a lot of ui elements take too much space… they are too big! The fact you have in crunchy ui is maybe due to a low screen resolution. Do you know what resolution are you running ? … i think your issue have a place in the tracker in enchancement. could be report with your actual screen resolution, operating system … , … , …

thank’s!


#22

Of course. It was pretty simple though,

  1. I created a group layer, it doesn’t matter what layers are inside. Then i clicked the group layer and keep it selected
  2. Next, i clicked the spline tool from the toolbox and designed a spline (any spline)
  3. Lastly, i clicked “Make Spline” and the error showed up as i mentioned on the last post.

P.S. : I just tried to reproduce the bug few minutes ago. And it seems the error will only show up if you add a layer directly from the toolbox.
Any geometry tools, gradient tool and text tool will also reproduce the same error but not for the rest.
I already tried to add any layer from the caret menu and right click menu and it’s working just fine.


#23

, Fadhilkwan can you now report this to the synfig bug tracker mentioning your Operation System, and others things you think relevant. Thank’s for the time.


#24

… building your own is a solution, “easier” i’m not sure it’s possible. You can post a feature request on the tracker !

A few weeks ago, i had turn around a few hours codingly speaking trying to fix it, but without result !!! Can you post an enhancement request ?


#25

Yep, done that :slight_smile: .
Hopefully it’s good enough.


#26

Hi!
To change the dark theme look and the pixelated text of the rc1 of Synfig under windows 7 you can change the gtk3 ini file. Go to synfig/share/gtk-3.0/settings.ini and change gtk-application-prefer-dark-theme=1 in gtk-application-prefer-dark-theme=0. At the end add gtk-xft-antialias=1 That will get you a grey theme with softer text.
Greetz!

Edit: Keep in mind that with the light grey theme it is very hard to see if certain buttons are checked or not. Would be better if all boxes had green check marks in it instead of just pressed in and pressed out states.


#27

Does anybody know where the settings file is located in OS X (Yosemite)?
I’ve shown all the hidden files looking for .synfig folder and it doesn’t seem to exists. Also, settings filename doesn’t give me good results in spotlight.
-G


#28

~/Library/Synfig ?


#29

I encountered a huge bug with the deformation bone system that renders it useless.

On 64 bit manjaro linux, open source ATI video card driver:
i.imgur.com/low1iUF.png

this is how it shows my deformed bone image.
The deformation bone layer is clipping the target deformation image for some reason. It does it on a png file, svg and internally drawn square shape. I tried everything - synfig clips it like that when I add a deformation bone layer to it. :unamused:


#30

Do you have Cairo render turned off?


#31

Whenever the “One Moment, Please” thing appears it shifts the focus away from the window. This is a problem when dragging something, because then it doesn’t stop dragging even if I let go of the mouse button. Presumably because then the “mouse up” event gets lost somehow when the focus shifts from the main window to the “One Moment, Please” window (which shouldn’t really be a window in the first place but maybe a tiny progress bar at the bottom of the window or somesuch, imho).
On Ubuntu, using compiz/unity.


#32

One such problem with the dark interface is causing some icons to merged into the background. One such instance is the render dialogue. The lock aspect ratio button can’t be seen easily.
render.png


#33

oh f**k the only one icon i have designed :wink: … i will commit an update with a contrasted border … at least this will do part of the job :slight_smile: