Synfig Studio 0.64.2 - Release Candidate


#1

Release candidate for next stable version of Synfig is available for download now! Help us to test the new version! - http://www.synfig.org/cms/en/news/synfig-studio-0642-release-candidate/

UPDATE 2014-10-12: Second release candidate is released - synfig.org/cms/en/news/synfi … ndidate-2/


#2
  • Play do not work ! (from menu / button / or shortcut)
  • Render to ffmpeg (avconv in my case) display a message box “Binary not found”
$ locate avconv
/usr/bin/avconv
/usr/share/avconv
/usr/share/avconv/libvpx-1080p.avpreset
/usr/share/avconv/libvpx-1080p50_60.avpreset
....

debian wheezy


#3

Following the link I get stable released 0.64.1 (windows 32 bits)
-G


#4

I cannot reproduce it here, on Fedora 20… Have you used prebuilt binaries or buid from source tarballs?
[/quote]

  • Render to ffmpeg (avconv in my case) display a message box “Binary not found”
    [/quote]
    Can you please post full console output?

#5

No, this is 0.64.2-rc1. Please check the About dialog.

[attachment=0]synfig-0.64.2-RC1.png[/attachment]

Please don’t confuse 0.64.2 with 0.65.x/1.0. The 0.64.2 is a bugfix release.


#6

Grrr … now I cannot reproduce … maybe something with the project i was on … some special state… i will have another look

From 386 deb.

No console ouput. Only message box.

First Message box with :

[code]
file : synfig/synfig-core/src/modules/mod_ffmpeg/trgt_ffmpeg.cpp
line : 221
Error: No FFmpeg binary found.

Please install “ffmpeg” or “avconv” (libav-tools package).[/code]
second with :

Target initialization failure

#7

Ok, let’s keep digging. :slight_smile:
My guess is that something is wrong with your PATH variable.

Please open console and type following commands:

$ echo $PATH $ which ffmpeg $ which avconv $ synfigstudio
After Synfig starts, try to export with ffmpeg. After that, please post full console output here.


#8

Ffmpeg render output through new H264 profile (H264/AVC/MPEG-4 AVC Lossless or H264/AVC/MPEG-4 AVC) produces a file but it doesn’t show anything (black) when played with VLC. Windows XP 32 bits

Codecs Windows Media Video 8, MPEG-4 Part 2 (XVid/DivX), Flash Video (FLV) / Sorenson Spark / Sorenson H.263 works.

Console output during rendering:

ffmpeg version N-53724-g716dbc7 Copyright (c) 2000-2013 the FFmpeg developers built on May 31 2013 23:33:02 with gcc 4.8.0 (GCC) configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab le-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetyp e --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --ena ble-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-l ibopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libsp eex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo- amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs -- enable-libxvid --enable-zlib libavutil 52. 34.100 / 52. 34.100 libavcodec 55. 12.102 / 55. 12.102 libavformat 55. 8.102 / 55. 8.102 libavdevice 55. 2.100 / 55. 2.100 libavfilter 3. 73.100 / 3. 73.100 libswscale 2. 3.100 / 2. 3.100 libswresample 0. 17.102 / 0. 17.102 libpostproc 52. 3.100 / 52. 3.100 Input #0, image2pipe, from 'pipe:': Duration: N/A, bitrate: N/A Stream #0:0: Video: ppm, rgb24, 480x272, 24 fps, 24 tbr, 24 tbn, 24 tbc [libx264 @ 023970e0] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.1 Cache64 [libx264 @ 023970e0] profile High 4:4:4 Predictive, level 2.1, 4:2:0 8-bit [mpeg @ 023957c0] VBV buffer size not set, muxing may fail Output #0, mpeg, to 'D:\Mis_Documentos_Local\Descargas\test-ffmpeg.mpg': Metadata: title : Synfig Animation 1 encoder : Lavf55.8.102 Stream #0:0: Video: h264 (libx264), yuv420p, 480x272, q=-1--1, 2000 kb/s, 90 k tbn, 24 tbc Stream mapping: Stream #0:0 -> #0:0 (ppm -> libx264) frame= 28 fps=0.0 q=0.0 size= 10kB time=00:00:00.87 bitrate= 93.6kbits/s frame= 47 fps=0.0 q=0.0 size= 18kB time=00:00:01.66 bitrate= 88.5kbits/s frame= 65 fps= 43 q=0.0 size= 26kB time=00:00:02.41 bitrate= 88.1kbits/s frame= 85 fps= 42 q=0.0 size= 36kB time=00:00:03.25 bitrate= 90.7kbits/s frame= 105 fps= 41 q=0.0 size= 44kB time=00:00:04.08 bitrate= 88.3kbits/s pipe:: Input/output error frame= 121 fps= 30 q=0.0 size= 44kB time=00:00:04.75 bitrate= 75.9kbits/s frame= 121 fps= 30 q=-1.0 Lsize= 46kB time=00:00:05.04 bitrate= 74.7kbits /s video:45kB audio:0kB subtitle:0 global headers:0kB muxing overhead 1.683792% [libx264 @ 023970e0] frame I:1 Avg QP: 0.00 size: 2004 [libx264 @ 023970e0] frame P:120 Avg QP: 0.00 size: 369 [libx264 @ 023970e0] mb I I16..4: 98.8% 0.2% 1.0% [libx264 @ 023970e0] mb P I16..4: 0.2% 0.0% 0.0% P16..4: 2.5% 0.3% 0.1% 0.0% 0.0% skip:96.9% [libx264 @ 023970e0] 8x8 transform intra:0.5% inter:59.1% [libx264 @ 023970e0] coded y,uvDC,uvAC intra: 2.4% 5.7% 5.7% inter: 0.8% 1.9% 1. 9% [libx264 @ 023970e0] i16 v,h,dc,p: 94% 1% 5% 0% [libx264 @ 023970e0] i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 17% 17% 67% 0% 0% 0% 0% 0% 0% [libx264 @ 023970e0] i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 18% 15% 51% 2% 6% 4% 3% 1% 0% [libx264 @ 023970e0] i8c dc,h,v,p: 91% 6% 2% 0% [libx264 @ 023970e0] ref P L0: 58.8% 34.8% 6.4% [libx264 @ 023970e0] kb/s:73.51


#9
  1. Please use “.avi” as file extension.
  2. Make sure that you have H264 codec installed in your system. Alternatively, you can try VLC Portable (it have all codecs bundled already).

I have tested export/playback of H264 - it works perfectly here on XP with VLC Portable. :slight_smile:


#10

Working now :slight_smile: I had to uninstall VLC to make VLC Portable to work properly.
-G


#11
wheezy@debian:~$echo $PATH
/home/wheezy/.script:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
wheezy@debian:~$ which ffmpeg
/usr/bin/ffmpeg
wheezy@debian:~$ which avconv
/usr/bin/avconv
wheezy@debian:~$ synfigstudio 

   Synfig Studio -- démarrage de l'application...


(synfigstudio:4435): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »
synfig(4435) [09:54:51] info: Chargement des modules depuis /opt/synfig/etc/synfig_modules.cfg
synfig(4435) [09:54:51] info: Loading plugins from /opt/synfig//share/synfig/plugins
synfig(4435) [09:54:51] info:    Loading plugin: view-unhide-all-layers
synfig(4435) [09:54:51] info:    Loading plugin: add-skeleton-simple
synfig(4435) [09:54:51] info: Loading plugins from /home/haricot/.synfig/plugins
synfig(4435) [09:54:51] info:    Loading plugin: freeform
synfig(4435) [09:54:51] info:    Loading plugin: view-toggle-show-hide-layers

(synfigstudio:4435): GLib-GObject-WARNING **: attempting to add an interface (GtkTreeModel) to class (gtkmm__CustomObject_KeyframeTreeStore) after class_init

(synfigstudio:4435): GLib-GObject-WARNING **: attempting to add an interface (GtkTreeDragSource) to class (gtkmm__CustomObject_KeyframeTreeStore) after class_init

(synfigstudio:4435): GLib-GObject-WARNING **: attempting to add an interface (GtkTreeDragDest) to class (gtkmm__CustomObject_KeyframeTreeStore) after class_init

(synfigstudio:4435): GLib-GObject-WARNING **: attempting to add an interface (GtkCellEditable) to class (gtkmm__CustomObject_N6studio15ValueBase_EntryE) after class_init

(synfigstudio:4435): GLib-GObject-CRITICAL **: Object class gtkmm__CustomObject_N6studio15ValueBase_EntryE doesn't implement property 'editing-canceled' from interface 'GtkCellEditable'

and … dialog boxes …

i will give a look debuging … (in fact i have the same behavior with 0.65.dev version)


#12

Would you mind if I ask you to record a screencast of your actions? The situation looks really weird…


#13

found !

from trgt_ffmpeg.cpp:140

	// Output is like: "ffmpeg version ..."
	if (result.substr(0,6) != "ffmpeg" && result.substr(0,6) != "avconv"){
		return false;
	}

from console :

xxx@yyyy:~$ ffmpeg -version 2>&1
WARNING: gnome-keyring:: couldn't connect to: /home/xxx/.cache/keyring-9ZnfSU/pkcs11: No such file or directory
ffmpeg version 0.8.16-6:0.8.16-1, Copyright (c) 2000-2014 the Libav developers
  built on Sep 17 2014 13:32:57 with gcc 4.7.2
The ffmpeg program is only provided for script compatibility and will be removed
in a future release. It has been deprecated in the Libav project to allow for
incompatible command line syntax improvements in its replacement called avconv
(see Changelog for details). Please use avconv instead.
ffmpeg 0.8.16-6:0.8.16-1
libavutil    51. 22. 2 / 51. 22. 2
libavcodec   53. 35. 0 / 53. 35. 0
libavformat  53. 21. 1 / 53. 21. 1
libavdevice  53.  2. 0 / 53.  2. 0
libavfilter   2. 15. 0 /  2. 15. 0
libswscale    2.  1. 0 /  2.  1. 0
libpostproc  52.  0. 0 / 52.  0. 0

before ffmpeg version i have a warning about gnome-keyring , example of bug report of that…i’m trying to manually fix my system … but, i think we must fix the code !

EDIT : fixing it manually like explained here (adding my windows manager into “/etc/xdg/autostart/gnome-keyring-pkcs11.desktop” , at OnlyShowIn=GNOME;XFCE;Unity ) fix locally the problem.


#14

Aha! You right, the mechanism for detection presence of avconv/ffmpeg is weak. I have an idea how to fix it easy. Thank you!


#15

I can’t install… I’m getting this error.

Preparing to unpack .../synfigstudio_0.64.2-20141006.rc1.8_amd64.deb ... Unpacking synfigstudio (0.64.2-20141006.rc1.8) ... dpkg: error processing archive /home/cyan/Downloads/synfigstudio_0.64.2-20141006.rc1.8_amd64.deb (--install): trying to overwrite '/usr/bin/synfig', which is also in package synfig 0.64.1-2 dpkg-deb (subprocess): decompressing archive member: internal gzip write error: Broken pipe dpkg-deb: error: subprocess <decompress> returned error exit status 2


#16

Djay:

Here’s the fix: github.com/synfig/synfig/commit … 77c2f4e47b

The fix is also commited to “gtk3” branch, so you can test it by building from source. But you probably need to revert your fix made to “/etc/xdg/autostart/gnome-keyring-pkcs11.desktop” in order to get the real testing for this solution. :slight_smile:

Please uninstall native “synfig” package, provided by Ubuntu/Debian repositories.


#17

ffmpeg / avconv rendering “when non usual console output” Fixed !!!(patch tested over 0.65dev-gtk3)


#18

Second release candidate is released - synfig.org/cms/en/news/synfi … ndidate-2/


#19

Translated into Chinese :slight_smile:


#20

“ugly” waypoints icons… i mean … is it normal that two waypoints style are included ?
synfig-0642rc2-waypoint.png