Synfig 0.61.09 Release Available!!

We are proud to announce the latest version of Synfig: 0.61.09.

Synfig is a popular, multi-platform 2D animation software for your computer. Synfig is Free and Open Source Software and provides powerful tools to let your imagination fly. This new version has a lot of improvements. The most important features and changes are:

* Increased stability
* Brand new Link to BLine feature
* Several new tools (Text, Star and Width tool was enabled)
* Several tools allow creating different layer types
* Several new value conversion types
* A new and beautiful splash screen
* Several other new features and usability improvements... 

We hope you enjoy this new version and we always welcome new contributions.



It’s great to see what has been improved, although I’m still not sure if I’ll install the software again (I’ve installed the factory settings because of that stupid Vista…and I still get an error!). Why haven’t the four programs which are needed (for Windows) been merged? Or is that so much harder than I think (I don’t know a thing about this stuff)?

It’s a mixture of indolence & incompetence on the part of the Windows packager, combined with a slight philosophical debate about the structure of the source files.

We need to fire his sorry ass - he’s certainly not worth the money we’re paying him!

Then he’s probably not worth a penny. :laughing:

But I’ve got a little problem: the Windows build is 0.61.08 and that’s not exactly what I had in mind. :wink:

So, the tutorials from the last version can still be applicable to this version or will there gonna be new ones just for this version?
Or maybe:
If this version still has a lots of bugs and “misfunctionality”, I will wait for more improvements.
For now, I want my question to be answered. The one about the tutorials.

All the existing tutorials are valid for this version. In fact some of them are only valid for this version.

There are much less bugs, much more stability and usability and still being some missing features. It is up to you to wait or use it right now.

I don’t get an answer? I would like to have one, 'cause I could get the program again if I knew why I downloaded .08 instead of .09

We have just released the source code. If you wait some days (as the top yellow banner in the download page says) the packagers would fill the download links with the binaries of the last version.

This is a collaborative project. There is not any founds or company behind, so the packages or binaries are provided by volunteers. Do you want to help on that? We would thank it a lot.


Quick question because my brain is vary small and still new to linux. Do I just click the Hardy at the Ubuntu package page or is it not up yet?

Devilly and other Windows users,
The Windows binaries are now available from .

MD5 Checksums -
Synfig = AF1FDD993470493766A52D8462557311
Synfig Studio = A4BF2BF46E1A18A9EFB14DC6D9AF1EC4

Both .exe files have been tested for virii … 50d75b8b60 … ff8311bf3a

As always, let us know in the forums or IRC if you have any problems with them.


In short, it will probably take quite a while for 0.61.09 to become available in Ubuntu hardy backports.

The path of 0.61.09 to Ubuntu hardy is this: Debian synfig packagers upload to Debian experimental (since Debian is frozen for lenny), Ubuntu users request sync from Debian experimental, Ubuntu syncs synfig from Debian experimental to Ubuntu intrepid (or whatever their upcoming release is), Ubuntu users request backport to hardy from intrepid, Ubuntu MOTU/backporters rebuild synfig under hardy and fix any issues and finally Ubuntu hardy users can use synfig in hardy. No idea how long that will take though, for now you might want to attempt building from source.

All of this reminds me I need to update the Debian packages :slight_smile:

@ Genete: I’m sorry, I hadn’t seen the banner. And yes, I would like to help. The problem is just that I don’t know how. I’ll take a look at the documentation and look what I can do.

@ pixelgeek: thank you!

*** Edit ***
It doesn’t work for me. The command prompt shows itself for a little flash and then it’s gone again. Is it something I’m doing wrong or what? Last time I installed the previous version it worked great.

I just installed it on another machine at work, and it worked fine. Can you check a couple of things first?

  1. When you downloaded synfig & synfigstudio, did you try and run them directly? Or save them to your hard drive first? We’ve had reports of strange behaviour when people tried to just run them from the sourceforge URL links. Make sure you save them to your Hard Drive first. Which browser do you use?

  2. Check that the checksums are OK. Google for an MD5 checksum calculator and use it on the two synfig files. The results you get should match the numbers posted in my last post in this thread. If not, please re-download the files.

Now we’ve got the release out of the way, I can go back to trying to incorporate the 4 installs into 1, but work’s pretty busy right now, and I don’t have a lot of time to play on the fun stuff :frowning:

Let me know how it goes.


I will wait a while longer. Might get the new Ubuntu for the desktop as well but the laptop is going to stay Hardy for a while longer.

Now I get a nice little error when installing the Gtk+ Runtime Environment:

I already had that last time, but then I installed everything and skipped the files that gave the problem. After that I deïnstalled and then I could install normally. But this time I’ll just ask: what’s wrong?

Haven’t seen that error before, but my guess would be that it already exists and Windows can’t overwrite it. Maybe???

I usually accept the defaults and install GTK into c:\GTK.

This is the default place it gives to install the program. :unamused:

Dose this new update have dockable windows yet?

Devilly - Are you trying to use a later version of GTK than 2.10.11? Your mileage may vary …

Superanimator - No. Not yet.

I’m using the GTK from the link on the download page, which is gtk-2.10.11-win32-1.exe.