Mise à jour wiki - (anciennement : "Avancement dans le tuto (je suis bloqué)")


#21

depuis synfig 1.0.2 (certainnement 1.0.1 / 1.0 également) direct dessus “straight onto” ne fonctionne plus correctement (regression de fonctionnalité ) StraightOnto-Bug-1.0.2.pnglegende : capture ecran tuto “revealing_mask_1.sifz” avec bug en rouge

Chez toi cela fonctionne car je pense que la limite supérieur de la “Boîte Englobante” de ton perso bleu et la meme que celle du masque.

oui … mais car j’ai declaré forfait pour la resolution de ce bug et passé la patate chaude a Ivan qui a la tete et les mains de ce genres de partie du code (rendu)…


#22

Je pense qu’il s’agit d’un problème au niveau du format/version du fichier du tuto.
Je viens de vérifier les positions de mes boîtes englobantes, ça fonctionne toujours aussi bien.
As-tu remarqué que dans les fichiers que j’ai produit pour l’occasion (1.0.2), la profondeur Z apparaît dans l’arborescence des calques alors qu’elle ne l’est pas dans celle des fichiers du tuto ? :wink:


#23

J’ai faillit ne pas en croire mes yeux … mais ca marche … et puis … pourquoi tu et pas me? … alors j’ai fait et refait … et … j’ai identifié un peu plus le probleme.

Les groupes !

voici une version de ton exemple… qui ne marche plus.
Bob-Reveler-Methode1-DirectDessus-group-bug.png
Bob-Reveler-Methode1-DirectDessus-group&bug.sifz (2.47 KB)

J’ai “uniquement” placé ton bonzomme bleu dans un groupe et ajusté de maniere adhoc les methodes de fusion.

A bien non … j’avais pas regardé de ce coté la … En revanche, as tu remarqué que dans l’exemple ya que le blender est dans un groupe, et ya que ton amis bleu non ? … 8)


#24

Je te dirais bien que c’est normal :slight_smile:
Comme indiqué dans le wiki pour Révéler - Méthode 1:

La composition ne peut se faire que dans un même “domaine” de composition, c’est donc dans le groupe englobant ces calques.
C’est pour cela que dans le tuto, le robot est au dessus avec “Direct Dessus” et le masque (NewBLine127) en dessous.
Mais ils sont bien tous les deux englobés dans Masking_Layer.

J’ai remis ici les Modes de Fusion dans la liste des calques de ton fichier.
On voit que le masque est en dehors du “domaine”, donc c’est “normal”, le mode de composition du groupe ne s’applique pas au groupe (sinon, à quelle profondeur devrait-il se limiter ?).
Donc ce n’est pas un bug et c’est bien indiqué dans le tuto.

Bob-Reveler-Methode2-Bis.pngDans le cas de Révéler - Méthode 2, ce qui est indiqué dans le tuto est correct également.
J’ai ajouté le groupe pour le robot dans cette version.

Conclusion: On devrait se limiter uniquement à la méthode 2 :smiley:
Bob-Masquage2.zip (635 KB)


#25

You can only use this method on one layer at a time so if you have several objects you need to group those into one group layer.

J’insiste, mais pour moi c’est un bug.

Cela devrait fonctionner avec un calque groupe (la traduction en francais n’est pas vraiment explicite cependant …) et cela fonctionnait “avant”.

Cela s’applique au resultat de la composition du groupe.


#26

Suite du tuto sur cette page: wiki.synfig.org/Doc:Creating_Shapes/fr

les appellations utilisées entre “guillemets” sont fausses
principalement ici:

je ne vais pas toutes les cités mais par exemple:
“supprimer le vertex” n’existe pas c’est: “supprimer l’élément intelligent”
“Fermer la Spline” n’existe pas c’est: “boucler”

Voilà


#27

Bon j’ai également fini celui-ci:
wiki.synfig.org/Doc:Getting_Started/fr

bon le gros problème c’est que l’ordre des tutoriels est à l’envers

moi je les ai faits comme ça:
Tutoriels basiques

    Ajouter des Calques
    Bases de l'Animation
    Bases de l'Animation par Ossatures
    Masquage basique
    Créer des formes
    Commençons par le commencement
    Interface

alors qu’apparemment c’est en sens inverse:

Interface
Commençons par le commencement
etc…

ils ne sont donc pas dans le bonne ordre ici:
wiki.synfig.org/Category:Tutorials/fr

et je parie que c’est pareil sur Tutoriels Intermédiaires


#28

Visiblement ils sont placés dans l’ordre alphabétique tout comme ceux de la version anglaise d’origine…
N’oublie pas que le Wiki, tout comme le logiciel est maintenu, traduit et développé par des volontaires.
Toi aussi tu peux y apporter ta contribution :slight_smile:


#29

Bon pour la page: wiki.synfig.org/Doc:Slideshow_Tutorial/fr :frowning:

la moitié de la page est traduite, mais ça ce n’est pas le pire, le truc c’est qu’il n’y a aucun exemple à quoi ressemblera
le truc qu’on manipule

on a les explications littéraires mais on ne voit pas à quoi cela servira au final :neutral_face: , c’est dommage
dans le principe j’ai compris, avoir un gif animé avec un affichage de X secondes et aussi utiliser la fonction opacité

faudrait aussi mettre à jour les images car sur la version anglaise elle sont plus récentes.


#30

J’ai déjà fait des tutoriels ailleurs complet pour moi et ensuite je l’ai ai publiés pour les autres
car l’ayant tellement bien fait et expliqué au final je l’ai mis à disposition de tous

je compte bien faire des modifs au wiki, sur l’aspect changement de mot pour qu’un FR comprenne, et qu’aussi je puisse le réutiliser au besoin
mais par contre faudra me dire si j’ai le droit de changer le sens d’une phrase si l’anglais d’origine ne l’est pas
en gros rajouter 2 ou 3 mots “inexistant” sur la version FR pour que le sens de la phrase prenne un sens.


#31

Super !!! … “toute” les infos sont ici : wiki.synfig.org/Writer_Documentation


#32

tuto pas complet wiki.synfig.org/Doc:Slideshow_Tutorial/fr
au final j’ai réussi ça


#33

Sur la page: wiki.synfig.org/Doc:Flower_Animation/fr
on a les copies d’écrans des vieilles versions de synfig

celle de la version anglaise est plus récente si vous pouviez UP les images
autrement la moitié n’est pas traduite. :cry:

Et aussi les textes ne sont pas à jour sur la version anglaise ya un lien qui pointe sur le résultat final
en Fr rien.


#34

Sur la page: wiki.synfig.org/Doc:Flower_Animation/fr
bon j’ai finalement réussi je ne sais pas comment j’ai fait :laughing:

hormis que je ne n’ai pas tout fait au pied de la lettre comme le lier tige pétale
la constante ou il faut ouvrir la fenêtre pour le in out

j’ai finalement fait bêtement un import depuis inkscape pour faire les pétales, (pour la tige non je l’ai dessiné direct suivant le tuto)
ensuite les pétales je les ai réduits au minimum pour qu’il soit invisible et ensuite je l’ai fait grossir

voilà


#35

… pas totalement traduit tu voulais dire :wink: … le résultat attendu est plus proche de cela :

J’ai doucement progressé sur la traduction… et je publierai un fichier projet finalisé (avec une image de fond) Slideshow_tutorial.sifz (1.66 KB)

Bonne progression…


#36

Bon je suis bloquer sur la page tuto: wiki.synfig.org/Doc:Building_a_m … g_glass/fr

ligne: Sélectionnez le calque encapsulé Loupe, puis dans le panneau de paramètres du calque, clic-droit sur zoom et choisissez Exporter/Export.

je ne trouve pas la ligne zoom dans l’onglet paramètres


#37

Tu n’es pas le seul, je viens de vérifier, cela existait bien sous 0.64.3, il s’agit sans doute d’une régression :confused:

Edit:
Bon, j’ai pensé à toi, j’ai lutté :stuck_out_tongue:
Laisse bien tout en position 0,0 et fais un “Lock Selection” sur le calque Groupe “Loupe”

Effectivement la propriété Zoom a disparu, mais ce n’est pas le seul problème.
Le calque Groupe “Loupe” possède maintenant un paramètre Transformation - Ouvre-le
On va affecter 2 propriétés.
“Décalage” : Clic Droit/Exporter la Valeur -> “PositionLoupe” (pour lier les centres, sinon ça plante :/)
“Echelle” : Clic Droit/Exporter la Valeur -> “Zoom” (un vecteur de 60,60 en fait)

On va maintenant lier le tout
Active l’onglet Bibliothèque pour voir les valeurs

Sélectionne le calque “Rendre Sphérique”
La propriété “Quantité” contient la puissance de la loupe, mets une valeur pas trop forte (j’ai mis 2)

Dans la Bibliothèque sélectionne “PositionLoupe”
Dans le calque “Rendre Sphérique”, Position/Clic-Droit/Connecter
Cela a pour but de connecter les 2 centres, la connexion manuelle décrite dans l’ancien tuto plante

Maintenant le “Rayon”, et là c’est coton
Dans la Bibliothèque sélectionne “Zoom” (le vecteur de 60,60)
Dans le calque “Rendre Sphérique” : Rayon/Clic-Droit/Convertir/X du vecteur (ou Y du vecteur, peu importe)
On obtient “Vecteur”
Ce vecteur on va le convertir en échelle “Vecteur”/Clic-Droit/Convertir/Echelle
On obtient 2 valeurs, “Lien” que l’on va connecter à “Zoom”, ainsi que “Scalaire”
On va attribuer à “Scalaire” le rapport des diamètres 51/60 = 0.85 (les tailles dans le tuto)
Et là c’est bon, si on sélectionne le Groupe Loupe, on peut déplacer et redimensionner la loupe et le grossissement avec les contrôles.

On aurait pu aussi utiliser la conversion du Rayon en "Longueur du vecteur, mais cette fois le rapport de l’échelle aurait dû être divisé par racine de 2 (51/60/1.414 = 0.6010…) mais ça devient encore plus lourdingue :smiling_imp:

Si une façon de faire plus simple existe, on est preneur :stuck_out_tongue:
LoupeAvecLongueurduVecteur.sif (12.9 KB)
LoupeAvecXduVecteur.sif (12.9 KB)


#38

Merci, dit donc il y a pas mal d’étape là-dessus
ce n’est pas facile à gérer ce branchement sans avoir le guide sous le nez.


#39

Fallait bien que je m’occupe cette nuit pendant que je n’arrivais pas à dormir :smiley:
Comme quoi on n’est plus trop à jour dans la documentation :confused:


#40

Bonjour j’aimerais comprendre un truc car je ne l’ai vu nulle part dans les tutos
basiques et intermédiaires

comment fait-on apparaitre ou disparaitre un objet une fois qu’on en a plus besoin
en image c’est plus facile:


la 1ère étoile apparait avec un “quantité”, à 0s la quantité est a 0 à 1s elle est a 1
la 2eme étoile va jusqu’a droite
la 3ème étoile va jusqu’a droite

enfaites le résultat que je voulais ce n’est pas du tout ça je voulais que l’étoile 1 ailles de gauche a droite et disparaisse après
que l’étoile 2 apparaisse ailles sur la droite et disparaisse
que l’étoile 3 apparaisse ailles sur la droite et disparaisse

comment on fait cela de façon simple?