Install Synfig on Mac using macport


#1

Hi!
I have managed to build synfig (x11 version) using macport, however I am unable to import image files (png) I have libpng installed but when I run configure for synfigcore the png option is not enabled, anybody know why?
I am also unable to choose .png as an option when rendering.

Another issue is about the gui, when I try to rearrange the different windows it alway crashes with the message:
Segmentation fault.

Has this something to do with this message that I always get in terminal when I launch synfigstudio?
: (synfigstudio:73443): GLib-GObject-CRITICAL **: Object class gtkmm__CustomObject_N6studio15ValueBase_EntryE doesn’t implement property ‘editing-canceled’ from interface ‘GtkCellEditable’

This is how I install Synfig using macport:
I run this in terminal:
export PATH="/opt/local/bin:$PATH"
export ACLOCAL_FLAGS="-I /opt/local/share/aclocal"
export PKG_CONFIG_PATH="/opt/local/lib/pkgconfig"

then I install cairo, cairomm
pango, pangomm
gtk2 and gtkmm (all this libraries for x11)
and libxmlxx2

I also install libpng, imagemagick, ffmpeg

after fetching the source code for ETl, Synfigcore and Synfigstudio

I follow this instructions to compile and build all:

cd synfig/ETL
export PKG_CONFIG_PATH=/opt/local/lib/pkgconfig
export PATH=/opt/local/bin:$PATH
autoreconf --install --force
./configure --prefix=/opt/local
sudo make install

cd synfig/synfig-core
glibtoolize --ltdl --copy --force
export PKG_CONFIG_PATH=/opt/local/lib/pkgconfig
export PATH=/opt/local/bin:$PATH
autoreconf --install --force
./configure --prefix=/opt/local
make
sudo make install

cd synfig/synfig-studio
export PKG_CONFIG_PATH=/opt/local/lib/pkgconfig
export PATH=/opt/local/bin:$PATH
autoreconf --install --force
./configure --prefix=/opt/local
make
sudo make install

It all installs nicely but something must be wrong because of the issues I mentioned in the beginning.

cheers Ulrik


#2

Hi ulrik,
I see the same message when running on linux so I don’t think it is related to the crash.
Anyway, is there any specific window that makes it crash when rearrange it? Do you have icons in the application? If you don’t have png export enabled you won’t be able to see the icons and so the install isn’t so “nicely” done :wink:
Remember to completely clean any previous installation when having those strange issues. You can alternatively build and install in other place to do it freshly and check that libpng is linked properly.
-G


#3

Hi Genete!

Ok, so the message doesn’t have to mean anything, that’s fine.
Yes I have all the icons and can see them, I just had a thought, if I render and use the auto function and choose .png as the extension it works fine what library is used then? ffmpeg, imagemagick? or do theese libs use libpng as well?

about the gui, it doesn’t matter what window I try to rearrange it crash anyway :frowning:

I will do as you suggest, I will make a clean installation again, thanks for help!

cheers


#4

If as you say, png is not enabled for synfig core, it is not possible to render the icons. If you can export to png you should be able to import from png becuase both Synfig’s libraries are in the same module, and both uses libpng.
Something extra would be there.
-G


#5

Hi Genete!
I have found that there is a maintainer for a Synfig portfile in Macport (unfortunately not the latest version though), and I noticed there is a patch file for that version, that would patch the “mptr_png.cpp” file inside the Synfigcore src package, so I changed the “mptr_png.cpp” in the latest version and now Synfig is able to use the libpng as input and output :smiley:

For Synfig to find libpng I also had to use:
export CPPFLAGS=-I/opt/local/include
export LDFLAGS=-L/opt/local/lib

So now I am finally able to use Synfig again… :laughing:

However the gui issues still remains :frowning:

/Ulrik


#6

Hey Ulrik, can you give a help to the guys of this thread?
lostmarble.com/forum/viewtopic.php?t=19019
I don’t know exactly what are they talking about…
-G


#7

I just did, the tricky part is the modified “mptr_png.cpp” file I made.

line 312 in “mptr_png.cpp”
original: a = (float)(unsigned char)png_ptr->trans[row_pointers[y][x]](1.0/255.0);
modified: a = (float)(unsigned char)png_ptr->trans_alpha[row_pointers[y][x]]
(1.0/255.0);

it has something to do with libpng 1.4…don’t ask me… :unamused:


#8

btw, is it possible to make changes to the Macport portfile so it will install latest version of Synfig?
This is the portfile:
trac.macports.org/browser/trunk … g/Portfile
as you can see it uses 2 checksums, so I guess I have to change thoose to make it work with v. 0.63.00?

at the top of the site you can also see the patch for “fix build failure with libpng 1.4”


#9

I have not idea on how to adapt this macport to the new version. I’m sorry but I don’t know the insights of how does it work.
Maybe you can contact to the current maintainer of it and ask for a update.
-G


#10

I have filed a ticket for the Synfig ports in Macports for a upgrade to version 0.63.00, and have contact with the maintainer, he’s wondering where to find a source tarball for 0.63.00.
Where can I find a source tarball for 0.63.00?


#11

Here:
synfig.git.sourceforge.net/git/g … 5b7;sf=tgz
-G


#12

Great, thanks! :smiley:

/Ulrik


#13

Genete! The maintainer of the Synfig port in Macports wrote this for me:

“Why is the 0.63.00 source not listed at
synfig.org/cms/en/download/stable? Get the developers to put it
there, then we can update the port. I’m not comfortable updating the port
with a distfile from a “snapshot” URL”

Is it possible to do that?

Ulrik


#14

Absolutely true. That’s my fault because I didn’t follow the instructions to create the tarball form the git repo and upload it to sourceforge.
I’ll do it as soon as I can find some free time.
-G


#15

Great, thanks!


#16

Any updates on this? As I’d like to try macports to build Synfig on Mac.


#17

Hi there,
I’ve updated the tarballs for ETL, synfig and synfigstudio. Please checkout them here:
ETL: sourceforge.net/projects/synfig/ … z/download
synfig: sourceforge.net/projects/synfig/ … z/download
synfigstudio: sourceforge.net/projects/synfig/ … z/download

That would allow to update the installers.
I’m sorry for the late upload.
Release Notes will be updated as soon as possible.
-G


#18

Thank you Genete!

It is now possible to install Synfig latest stable version via macports, thanks to Genete and Synfigport maintainer "ryandesign@macports.org" :smiley:


#19

Release Notes Updated too.
Thanks to you for pushing the update!
-G


#20

I’ve installed Synfig 0.62.02 on my MacBook. Now I’m trying to install the new version, but I have this:
instalar Synfig 0.63.png
Synfig 0.62.02 remains installed. How can I install 0.63?
Thanks.