Install Synfig on Mac using macport


#21

Run:
“sudo port upgrade synfigstudio” in terminal

it will upgrade etl, synfig and synfigstudio to v.0.63.00_0


#22

I forgot to ask you, do you have synfig installed via macport or fink?
cause this is using macport


#23

macport.

I’ve tryed, but I’ve the same result:
actualizando.png
What is wrong?
Thanks.


#24

perhaps I must upgrade macports? I don’t know (in fact, I know nothing about) :frowning:


#25

Try this in terminal:

  1. sudo port -v selfupdate
    it will take a while, when it’s ready then:
  2. sudo port upgrade synfigstudio

#26

Thanks. I just found this: http://guide.macports.org/chunked/using.html

It’s the same as you say. I’m just updating Synfig now. I’ll tell you when it is finished.


#27

Good luck! :smiley:


#28

Uaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaau!
IT’S DONE: I’VE SYNFIG 0.63.00 :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley:
Thanks a lot, ulrik, Genete and all the Synfig team.


#29

Congratulationsl!
Now that you have Synfig Studio 0.63.00 at Mac. can you make me a favour?
Please import this file (SVG) and tell me what do you obtain. I’m curious to know if the svg import problem we have with Ubuntu is repeatable in Mac. I expect to obtain a red circle but when I import the SVG on Ubuntu I get a deformed blob.
dibujo.svg

Thanks!
-G


#30

After import it looks like this:
musikboden.se/synfigfiles/dibujo.png


#31

I’ve the same as ulrik:

But I’ve a question: I’ve installed Synfig 0.62.00 (iMac), and I can’t see anything when I import the svg file. I don’t know if it’s normal. (anyway, I’m going to update to 0.63)


#32

Thank you both. That’s what I obtain in Ubuntu too. Weirdly in Fedora I obtain a perfect circle (what’s supposed to be).

In 0.62.00 or 0.62.02 just repeat the import opertaion and it should work fine.

I can understand that we might have broken the SVG import library for all the cases but what I can’t understand is why in Fedora it works fine and not in the rest. I swear that there is something extra apart of the code of Synfig.
-G


#33

if you need more proof, tell me.

I have upgraded to the latest version on my two machines.Thanks anyway. :smiley:


#34

Hi, I am unable to install the latest synfig release with macport, I know macport is updated with the latest synfig port but I get this error when trying to install Synfig 0.63.02:
—> Verifying checksum(s) for synfig
Error: Checksum (rmd160) mismatch for synfig-0.63.02.tar.gz
Error: Checksum (sha256) mismatch for synfig-0.63.02.tar.gz
Error: Target org.macports.checksum returned: Unable to verify file checksums

Anybodu know why this happens?

cheers / Ulrik


#35

It is possible that there has been an error uploading the tarballs. I’ll check them.
-G


#36

Thanks Genete! :smiley:


#37

I’ve downloaded the files from the website links (sourceforge automatic links), placed the uncompressed files in a separated folder and have run this script to make and install in a local place. I didn’t want to install it wide system but I’m sure that replacing ‘make install’ with ‘sudo make install’, will work.

I don’t know what else to test. Looks like the tar balls are fine.

-G

[code]#!/bin/sh
CPUS=4
prefix=$(pwd)/install
export PKG_CONFIG_PATH="$prefix/lib/pkgconfig"
export PATH=$(pwd)/synfig-core/src/tool/.libs:$PATH
export CXX="/usr/bin/ccache /usr/bin/g++"

cd ETL-0.04.14 &&
./configure --prefix $prefix &&
make install &&

cd …/synfig-0.63.02 &&
./configure --prefix $prefix &&
make -j $CPUS install &&

cd …/synfigstudio-0.63.02 &&
./configure --prefix $prefix &&
make -j $CPUS install[/code]


#38

hmm…still not working, I get the same checksum error and macport will not install!
I will try to manually build it via git, thanks for the help!

cheers!


#39

Well I managed to build it on my own, and today I tried to build it with macport and it worked as well!!! I guess the port file is updated.
Conclusion, it is possible to build the latest stable release of Synfig , 0.63.02 with macport. :smiley:


#40

So it was a wrongly ‘mackported’ tarballs right?

-G