Import vector graphics from Inkscape

Hi guys,

I would like to import a vector graphic from Inkscape into Synfig. I just created a simple drawing with Inkscape and saved it as both a svg file and a synfig animation (I followed the instructions of this video https://www.youtube.com/watch?v=ytYHqIHow8I). However, when I import it into Synfig via File–>Import nothing is shown on the canvas (it is just empty). Do you have any clue what the problem might be? I’d appreciate every comment and I am looking forward to your help.

Hi and welcome here :slight_smile:

This a a common request, please use the search function :wink:
(for example https://forums.synfig.org/search?q=svg%20import%20after%3A2018-01-01)

The last answer was:

Thanks BobSynfig for your comment,

I had a look into the discussion but it does not solve my problem. As stated in my original post, I followed the steps of a youtube tutorial (you can see the link in the original post). I indeed saved the drawing in Inkscape as a SIF file (synfig animation) but still nothing is display in Synfig when I import it.

It could be different things like Alpha/Transparency, Blend Mode, gradients, some SVG elements not exported, the fact you are in preview/draft mode…
Which version and OS do you use?

Thanks BobSynfig for your comment,

my OS is Windows 10 and I use Synfig 1.2.2


I uploaded a figure with two screenshots. One from Inkscape (right hand side) and one from Synfig (left hand sinde). Maybe this helps.

It seems your draw is outside the visible part of Synfig workarea (and it’s outside Inkscape drawing area)

Thanks rodolforg for your answer. Yes, indeed that was the problem. Thanks a lot for your help :grinning: