How to remove rotation from link-to-spline animation

Hi folks
I’m very much a newbie at Synfig and animation in general, but otherwise quite IT savvy

I’m trying to illustrate to users how to draw on a touch screen …

This is what it looks like currently:

This is the synfig file:

As you can guess, I’d like to keep the hand and finger pointing in the same direction through out the animation. I’ve tried changing the angle at keypoints in the timeline – that doesn’t really work well at all. What I need is to completely remove the tweening of rotation…

Any help will be much appreciated …


Hello @soren_dk .

Please, try this suggestion: Follow a path but no angle change - #4 by caryoscelus

Hi @rodolforg
thanks for your speedy reply – when googling for a solution over the past couple of days, I came across the page you linked to. The attachment they provide is an older version of synfig and can not load, and the explanation left me more confused than anything :slight_smile:

I’m not very familiar with the animation/synfig jargon yet, so to illustrate what I’m doing and how it is not working as expected – I’ve posted a short (1:41) video:


When you linked to Spline, it affected two transformation parameters: offset and angle.
You can now unlink (disconnect) the angle stuff, as it is undesired.
For that purpose:

  1. Select the group
  2. Click the rotate handle (the blue one)
  3. Right-click on it and select “Disconnect”
    As alternative to step 3, you could do it in Parameters Panel, by right-clicking on the Angle subparameter of Transformation parameter.

Ahh @rodolforg – now I get it and it works – thanks!

1 Like

Just to wrap this up … this is what it looks like now:

…theres a little glitch right at the end, but I can fix that and I’m quite happy with the result.

Again @rodolforg thanks for helping out

Glad it worked for you. Could you please mark this topic as solved?
You can do it marking the answer message as Solution.
Discourse Solved - plugin - Discourse Meta (section “How does it work?”)