How to Build Synfig Studio in Ubuntu Karmic Koala 9.10


#1

Those instructions would allow you install Synfig Studio in your system using the latest development version.
The default installation path is in your home directory but it can be changed to any place just modifying the script.
As development version it is not recommended to install using sudo unless you know what you’re doing.
The following instructions would allow you install it in a folder in your home directory and can be easily deleted.

  1. Prepare to dowload the source code.
    Install git
$ sudo apt-get install git

Clone the source code. This will create a folder called ‘synfig’.

$ git clone git://synfig.git.sourceforge.net/gitroot/synfig/synfig
  1. Create the building script:
$ nano build.sh

Then copy and paste this text into the editor:

[code]#!/bin/sh
cd synfig
CPUS=4
prefix=$(pwd)/install
export PKG_CONFIG_PATH="$prefix/lib/pkgconfig"
export PATH=$(pwd)/synfig-core/src/tool/.libs:$PATH
export CXX="/usr/bin/ccache /usr/bin/g++"

cd ETL &&
autoreconf --install --force &&
./configure --prefix $prefix &&
make install &&

cd …/synfig-core &&
libtoolize --ltdl --copy --force &&
autoreconf --install --force &&
./configure --prefix $prefix &&
make -j $CPUS install &&

cd …/synfig-studio &&
autoreconf --install --force &&
./configure --prefix $prefix &&
make -j $CPUS install[/code]
Then press CTRL+O (ENTER) and CTRL+X. This will save the script in the folder where you created the cloned repository. Alernatively download this file build.txt (635 Bytes) and save it as build.sh.

  1. Install the needed libraries. Copy the entire line and hit ENTER. Accept all the suggestions.
$ sudo apt-get install build-essential autoconf automake libtool

$ sudo apt-get install libxml++2.6-dev libsigc++-2.0-dev libltdl3-dev libtool gettext cvs libpng12-dev libmng-dev libjpeg62-dev libfreetype6-dev libfontconfig1-dev libopenexr-dev libavcodec-dev libavformat-dev libmagick++9-dev libdv-bin ffmpeg imagemagick

$ sudo apt-get install libgtkmm-2.4-dev libgtk2.0-dev libglibmm-2.4-dev libsigc++-2.0-dev libltdl3-dev libtool gettext cvs ttf-freefont ttf-dejavu ttf-dustin
$ sudo apt-get install ccache
  1. Run the script to build the binaries:

$ sh build.sh Depending on your computer speed you may want to go to prepare some cofee :wink:. Verify that there are not error messages when the script ends.

  1. Run synfigstudio and enjoy:

$ cd synfig/install/bin &./synfigstudio

KNOWN ISSUES:
a) For some reason the default configuration of the input devices produces bad coordinates when input with the mouse. To solve this go to ToolBox->Device Settings and disable all the devices (for a non tablet computer they are usually USB Optical Mouse and Macintosh mouse button emulation). <<< SOLVED IN THE CURRENT GIT VERSION
b) To properly use the new Transform Tool (Rotate, Translate and Scale all in one) you have to modify the default window settings in Gnome. In Ubuntu, go to System>Preferences>Windows and change the “ALT” key by “Super (or Windows Logo)” for the key to move a window. This would allow to use the ALT key to Scale the ducks in Synfig Studio.

Enjoy! :slight_smile:


SOLVED error: Could not link against boost_program_options !
Debian Wheezy : Install / Build / Debug ---> OK !
How to Build Synfig Studio in Ubuntu 9.10 [debug script]
[Success] 1 April Merge / 0.64pre on ubuntu12.04 like
[Succesfull] - ubuntu 12.04 build -xubuntu-
[Succesfull] - ubuntu 12.04 build -xubuntu-
Synfig Dev
#2

It built in a smidge under 15 minutes on my machine :slight_smile:


#3

Hi Genete,

I’ve a “virtual” Kubuntu 9.10 under a VirtualBox machine and when i try the step 3 I get an error :

I can’t find the build-essential pack

reading packs Done generating tree of depend.... reading info status done I can't find the build-essential pack

Where I’m falling…?!
Maybe a network error?
Maybe because I try to launch it from a terminal in the path of a desktop subfolder?

Thanx

BottyE


#4

It is weird because this package is in all debian derived distributions:
packages.ubuntu.com/karmic/build-essential
are you sure that you have all the repositories enabled?
You should enable the proper repositories entries in your Sources Manager.
Maybe this thread can help: ubuntuforums.org/archive/index.php/t-867794.html
-G


#5

Clean install of Ubuntu 10.04 LTS (w/ netbook packages).

Followed instructions. It builds a working copy of synfig, although there is a problem:

Somewhere synfig-studio is compiled with absolute resource linking, rather than relative. This means that I cannot move the compiled program, even if I move the entire git folder.

Example error:

...

(synfigstudio:12784): Gtk-WARNING **: Error loading icon: Failed to open file '/home/<UserName>/synfig/install/share/pixmaps/synfigstudio/string_icon.png': No such file or directory

...

Segmentation fault

This is after moving /home/<UserName>/synfig/* to /home/<UserName>/GIT/synfig/*
Likewise, renaming the folder to /home/<UserName>/synfigtest/* fails.
Any ideas?

(Note: I see a loading bar show as synfig-studio cycles through its checks. Then the toolbox shows up for a fraction of a second. Finally it crashes.)


#6

It is normal. The icons locations are hardcoded with full path. Maybe it is possible to change the code to use relative path for the icon search. Only quick solution is to configure and make install again. The other solution is to change the code and make the icon search relative to … relative to what?, the

prefix=$(pwd)/install

is set to absolute… hmmm.
-G


#7

Just did install from git on Ubuntu 10.04 LTS

The package “git” seems to have been renamed “git-core” in step number one.

Other than that all steps worked correctly. Built in <13 minutes.

I like the Advanced Outlines. Thanks!


#8

fyi I had to add package autopoint, as per Gettext requisite; simply run the following line after installing ccache (end of 3)

sudo apt-get install autopoint

(compiled in ~10 minutes on lenovo T500 laptop: IntelCore2Duo 2.5Ghz with 3G Ram, ubuntu 11.04)
B.


#9

Genete : Seems you put libtoolooz in wrong place editing original post
I meen by that, is it normal you say me to change it in studio, but you have done change in core ?

see(ya;


#10

AFAIK original post is not edited since 2010.
-G


#11

I have tried to build synfig on Ubuntu 12.04 but i got an error with libxmlrpc-light-ocaml-dev depending on libxml-light-ocaml-dev-pwvb9 (i think while installing libxml++). libxml-light-ocaml-dev-pwvb9 seems to be a virtual packet and the console means some packets must be broken or restrained or something. Do you guys have any ideas how to fix that?


#12

Humm, rare, i do not have libxmlrpc-light-ocaml-dev installed in my debian7 case (present in repository but)

  • are you sure you need it ?, does libxml++ & dev (not) well installed?

libxml++ dependencies

libc6 (>= 2.14) [amd64] Embedded GNU C Library: Shared libraries un paquet virtuel est également fourni par libc6-udeb libc6 (>= 2.4) [i386] libgcc1 (>= 1:4.1.1) GCC support library libglibmm-2.4-1c2a (>= 2.30.0) C++ wrapper for the GLib toolkit (shared libraries) libstdc++6 (>= 4.6) GNU Standard C++ Library v3 libxml2 (>= 2.7.4) GNOME XML library
packages.ubuntu.com/precise/libxml++2.6-2

did you take a look to “[Success] 1 April Merge / 0.64pre on ubuntu12.04 like”


do not contains two much exiting things… but maybe…

see(:ya!


#13

i think i installed the libxml++ dev package and it worked somehow, but now i got the next problem with a cairo package. I reinstalled cairo with the right version (1.12 or something) but the console always says that cairo isn’t available.
I will install a newer version of ubuntu and then try it again (i wanted to do than anyway in the next days).
Thanks for your help, cya


#14

in [Success] 1 April Merge / 0.64pre on ubuntu12.04 like :
First : How to upgrade libcairo2 and libcairo2-dev up to 1.12 if not present in my repository ?
Adding “quantal main” (ubuntu 12.10) repository can be a solution.Take care to select manually only the .deb needed - libcairo2 and dependencies (or this will be the road to full system migration) - after this little update ,7 .deb or something like, don’t forget to disabled or suppress “quantal main” repository to preserve your system!
.
Did you try that (no maintainable) way ?


#15

I have installed Ubuntu 13.04 and i got no problem with cairo on a fresh installation.
The build was also successful after i did this:

sudo apt-get install autopoint
sudo apt-get install libxml++2.6-dev libxml++2.6-doc
sudo apt-get install libboost-all-dev
sudo apt-get install intltool

and i followed your instructions (adding 1 line in build.sh [url][Success] 1 April Merge / 0.64pre on ubuntu12.04 like]).

Note: libboost is very big and i think it is not necessary to install all of these packages but i was too lazy at this moment
Thanks for your help


#16

what is the official code repository for synfig, sourceforge or github? i wanted to play a little bit around with the code. So i cloned the files from sourceforge and the build was successfuly but i did the same with github (i forked it before cloning) and i got an error (make: *** [install-recursive] error 1)


#17

github, github.com/synfig/synfig