How to build Synfig in Ubuntu Intrepid 8.10


#41

Hi there,

I stuck at this point:

[code]marcel@christine% cd ~/Desktop/synfig-0.61.09
marcel@christine% sudo checkinstall make install
[sudo] password for marcel:

checkinstall 1.6.1, Copyright 2002 Felipe Eduardo Sanchez Diaz Duran
Diese Software wurde unter der GNU GPL veröffentlicht


**** Debian package creation selected ***


Das Paket wird entsprechend dieser Vorgaben erstellt:

0 - Maintainer: [ root@christine ]
1 - Summary: [ Package created with checkinstall 1.6.1 ]
2 - Name: [ synfig ]
3 - Version: [ 0.61.09 ]
4 - Release: [ 1 ]
5 - License: [ GPL ]
6 - Group: [ checkinstall ]
7 - Architecture: [ amd64 ]
8 - Source location: [ synfig-0.61.09 ]
9 - Alternate source location: [ ]
10 - Requires: [ ]
11 - Provides: [ synfig ]

Geben Sie die betreffende Nummer ein, um die Vorgaben zu ändern:

Installing with make install…

====================== Installations-Ergebnisse ==========================
Making install in libltdl
make[1]: Betrete Verzeichnis ‘/home/marcel/Desktop/synfig-0.61.09/libltdl’
make[2]: Betrete Verzeichnis ‘/home/marcel/Desktop/synfig-0.61.09/libltdl’
test -z “/usr/local/lib” || mkdir -p – “/usr/local/lib”
test -z “/usr/local/include” || mkdir -p – “/usr/local/include”
make[2]: Verlasse Verzeichnis ‘/home/marcel/Desktop/synfig-0.61.09/libltdl’
make[1]: Verlasse Verzeichnis ‘/home/marcel/Desktop/synfig-0.61.09/libltdl’
Making install in src
make[1]: Betrete Verzeichnis ‘/home/marcel/Desktop/synfig-0.61.09/src’
Making install in synfig
make[2]: Betrete Verzeichnis ‘/home/marcel/Desktop/synfig-0.61.09/src/synfig’
make[3]: Betrete Verzeichnis ‘/home/marcel/Desktop/synfig-0.61.09/src/synfig’
test -z “/usr/local/lib” || mkdir -p – “/usr/local/lib”
/bin/bash …/…/libtool --mode=install /usr/bin/install -c ‘libsynfig.la’ ‘/usr/local/lib/libsynfig.la’
/usr/bin/install -c .libs/libsynfig.so.0.0.0 /usr/local/lib/libsynfig.so.0.0.0
(cd /usr/local/lib && { ln -s -f libsynfig.so.0.0.0 libsynfig.so.0 || { rm -f libsynfig.so.0 && ln -s libsynfig.so.0.0.0 libsynfig.so.0; }; })
(cd /usr/local/lib && { ln -s -f libsynfig.so.0.0.0 libsynfig.so || { rm -f libsynfig.so && ln -s libsynfig.so.0.0.0 libsynfig.so; }; })
/usr/bin/install -c .libs/libsynfig.lai /usr/local/lib/libsynfig.la
PATH="$PATH:/sbin" ldconfig -n /usr/local/lib

Libraries have been installed in:
/usr/local/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR’
flag during linking and do at least one of the following:

  • add LIBDIR to the `LD_LIBRARY_PATH’ environment variable
    during execution
  • add LIBDIR to the `LD_RUN_PATH’ environment variable
    during linking
  • use the `-Wl,–rpath -Wl,LIBDIR’ linker flag
  • have your system administrator add LIBDIR to `/etc/ld.so.conf’

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.

test -z “/usr/local/include/synfig-0.0/synfig” || mkdir -p – “/usr/local/include/synfig-0.0/synfig”
mkdir: kann Verzeichnis „/usr/local/include/synfig-0.0“ nicht anlegen: No such file or directory
make[3]: *** [install-include_synfigHEADERS] Fehler 1
make[3]: Verlasse Verzeichnis ‘/home/marcel/Desktop/synfig-0.61.09/src/synfig’
make[2]: *** [install-am] Fehler 2
make[2]: Verlasse Verzeichnis ‘/home/marcel/Desktop/synfig-0.61.09/src/synfig’
make[1]: *** [install-recursive] Fehler 1
make[1]: Verlasse Verzeichnis ‘/home/marcel/Desktop/synfig-0.61.09/src’
make: *** [install-recursive] Fehler 1

**** Installation fehlgeschlagen. Breche Paket-Erzeugung ab.

Räume auf…OK

Auf Wiedersehe[/code]

ETL worked fine :wink: and I have installed everthig you said … i think :wink:

I would love to get some help…

Thanks a lot.
Marcel


#42

Hi Marcel,
to properly help you you should run all the commands under a English environment language. Please type: LANG=C before any command you want us to help on debugging.

Reading the commands you have typed:

marcel@christine% sudo checkinstall make install

it seems that you’re not following the exact instructions I gave in the first post.
So at this point I cannot help you because I cannot reproduce what you’re trying to do and they don’t follow the general build instructions from the wiki either.

I’m not sure what does checkinstall do. Anyway, did you successfully make synfig?

The exact code is:

$ cd synfig-0.61.09 $./configure $make $sudo make install

So after enter in the 0.61.09 folder you have to configure and make. Did you do it?

-G


#43

Yes…
./configure and make worked propper.

Checkinstall normaly just makes a debfile, so I could update and deinstall things. In other cases it worked fine.

Could the problem be, that I am using a 64bit distribution?

I was brave and tried it without checkinstall:

make install ~/Desktop/synfig-0.61.09 Making install in libltdl /home/marcel/Desktop/synfig-0.61.09/libltdl make[1]: Betrete Verzeichnis '/home/marcel/Desktop/synfig-0.61.09/libltdl' make[2]: Betrete Verzeichnis '/home/marcel/Desktop/synfig-0.61.09/libltdl' test -z "/usr/local/lib" || mkdir -p -- "/usr/local/lib" test -z "/usr/local/include" || mkdir -p -- "/usr/local/include" make[2]: Verlasse Verzeichnis '/home/marcel/Desktop/synfig-0.61.09/libltdl' make[1]: Verlasse Verzeichnis '/home/marcel/Desktop/synfig-0.61.09/libltdl' Making install in src /home/marcel/Desktop/synfig-0.61.09/src make[1]: Betrete Verzeichnis '/home/marcel/Desktop/synfig-0.61.09/src' Making install in synfig /home/marcel/Desktop/synfig-0.61.09/src/synfig make[2]: Betrete Verzeichnis '/home/marcel/Desktop/synfig-0.61.09/src/synfig' make[3]: Betrete Verzeichnis '/home/marcel/Desktop/synfig-0.61.09/src/synfig' test -z "/usr/local/lib" || mkdir -p -- "/usr/local/lib" /bin/bash ../../libtool --mode=install /usr/bin/install -c 'libsynfig.la' '/usr/local/lib/libsynfig.la' /usr/bin/install -c .libs/libsynfig.so.0.0.0 /usr/local/lib/libsynfig.so.0.0.0 /usr/bin/install: cannot create regular file `/usr/local/lib/libsynfig.so.0.0.0': Permission denied make[3]: *** [install-libLTLIBRARIES] Fehler 1 make[3]: Verlasse Verzeichnis '/home/marcel/Desktop/synfig-0.61.09/src/synfig' make[2]: *** [install-am] Fehler 2 make[2]: Verlasse Verzeichnis '/home/marcel/Desktop/synfig-0.61.09/src/synfig' make[1]: *** [install-recursive] Fehler 1 make[1]: Verlasse Verzeichnis '/home/marcel/Desktop/synfig-0.61.09/src' make: *** [install-recursive] Fehler 1
The same problem :frowning:

Thanks for helping.


#44
/usr/bin/install: cannot create regular file `/usr/local/lib/libsynfig.so.0.0.0': Permission denied

you didn’t typed ‘sudo make install’, just typed ‘make install’.
You have to be root to write on /urs/local/lib.

-G


#45

I tried everything above to no avail, and then I found an easier way!

Add:

deb http://ppa.launchpad.net/stemp/ubuntu intrepid main

to your sources in Adept / Synaptic / a text editor, and then just install synfig.

Easy! :mrgreen:


#46

Please add this binary sources to the Download page.
synfig.org/Download#ubuntu

Thanks!
-G


#47

Yes! Thanks Synforge!

I had followed the manual build instructions and was having the same problem as others (loaded with no icons or splash) on Ubuntu Studio 8.10 Intrepid Ibex. Adding that new binary source did the trick. However, now I’m having a minor problem… how do I remove the version with the missing icons? (Sorry, I’m semi-new to Linux) The broken manually-built version’s Synfig and Synfigstudio executables ended up in usr/local/bin and the new, working ones ended up in usr/bin. For some reason, the main menu’s Synfigstudio launcher referred to the broken version, even though it only appeared there when I added the new repo to Synaptic and installed the binaries. I fixed that by redirecting the launcher, though.

So, in short, is there a way to remove manually-built programs when Synaptic doesn’t see them and without having to trudge through piles of sub-folders deleting random libraries? Any help would be appreciated.


#48

I think there isn’t. You have to remove them manually. All the stuff is installed under /usr/local. There should be a better way though, because ‘make’ can do it using same procedure as for the install process. The problem is that it is not written in the makefile.
Someone pointed in a previous post that you can install from sources using checkinstall:

That might be the better way.
-G


#49

Sucks that Ubuntu don’t simply sync the package from Debian, it has been there for almost two months now. Perhaps someone who uses Ubuntu could add some sync requests and backport requests?


#50

That might be the better way.
-G
[/quote]
Gracias, Genete.

I will give that a try when I get back home. In any case, I have a working copy of Synfig and it looks really slick in Ubuntu Studio (with Compiz and a slightly lighter version of the default theme).

Keep up the good work!


#51

Err, I think I misunderstood your last post. I’ll try CheckInstall the next time I have to manually install something, then. Ah, well. :slight_smile:


#52

Thank you very much, Genete! I’ve compiled sucessfully Synfig 0.61.09 on Ubuntu Intrepid (8.10)

I’m very happy!!

greetings from Misiones Argentine

Pablo


AMD Athlon™ 64 X2 Dual Core Processor 6000+
2014 MiB
GeForce 8600 GT


#53

I have the same problem of Sapnix:
The icons disappear! I’m running intrepid ibex (in spanish) and i followed the instructions step by step (obviously in order).

please someone just upload the “/usr/local/share/pixmaps/synfigstudio/” folder with the icons and problem solved!


#54

hi,
i’m new to Linux (Ubnutu 8.10 Intrepid on a toshiba laptop), could you please tell the steps to do that?

i can see this way is fast easier than the other, but i really still don’t get it…
i used to work with Flash in mac, but since i want to work in Linux i would be very very happy to find a vector based animation program like synfig seems to me.
thanks


#55

I just installed this way and it worked like a charm. What I did:

Open Synaptic Package Manager.
Remove all the old Synfig packages.
From the menu choose Settings > Repositories > Third Party Software
On that screen there will be an “Add” button, click it.
In the window that brings up copy the above code “deb http…” into the blank.
Unselect any other repositories in the list so you make sure you get the good one.
Hit the Reload button in the main Synaptic window (it should remind you to do that).
Find Synfigstudio and load it.
Put the repository list back the way it was.

Thanks for posting the advice, Synforge. I now have a working program. I hope memosnal gets working soon, too.


#56

yes! thank you dabug! really easy, but it was first experience with repositories…
as soon as i get some nice work with synfig i’ll post it.
happy :smiley: happy


#57

For un-installing a package built from sources, you don’t need to do it manually.

But you must keep the (configured) sources after installation. When you want to build a new version, go to old sub folders where you have the old (and configured) sources and type

sudo make uninstall.

And the old install will be removed form /usr/local/ (or from the folder where is installed). This method works almost with any package.


#58

Just to let you know my own experience:

following the instructions shonw here i couldn’t install the last part (synfigstudio). I got the following error:

Unable to set up dependent libraries (synfig >= 0.61.09, ETL >= 0.04.12)

first i had to install libsynfig0

$ sudo apt-get install libsynfig0

and then run

$ autoreconf --install --force
$ ./configure
$ make
$ sudo make install

#59

You seem to be mixing a binary install (apt-get install) with a local build (./configure, make, make install). If the ./configure step for synfigstudio cannot find the proper synfig or ETL, this frequently means that the PKG_CONFIG_PATH is not properly set (or the previous build/install steps failed).

G.


#60

I built Synfig and it starts, but I have no icons for the buttons, they are all a blank page with a red x. How do I fix this? Looking in the terminal I get a bunch of different messages like this

[code]synfig(1648) [05:21:50 PM] warning: Unable to open /usr/local/share/pixmaps/synfigstudio/synfig_icon.png

(synfigstudio:1648): Gtk-WARNING **: Error loading icon: Failed to open file ‘/usr/local/share/pixmaps/synfigstudio/bool_icon.png’: No such file or directory

(synfigstudio:1648): Gtk-WARNING **: Error loading icon: Failed to open file ‘/usr/local/share/pixmaps/synfigstudio/integer_icon.png’: No such file or directory

(synfigstudio:1648): Gtk-WARNING **: Error loading icon: Failed to open file ‘/usr/local/share/pixmaps/synfigstudio/angle_icon.png’: No such file or directory

(synfigstudio:1648): Gtk-WARNING **: Error loading icon: Failed to open file ‘/usr/local/share/pixmaps/synfigstudio/time_icon.png’: No such file or directory

(synfigstudio:1648): Gtk-WARNING **: Error loading icon: Failed to open file ‘/usr/local/share/pixmaps/synfigstudio/real_icon.png’: No such file or directory

(synfigstudio:1648): Gtk-WARNING **: Error loading icon: Failed to open file ‘/usr/local/share/pixmaps/synfigstudio/vector_icon.png’: No such file or directory

(synfigstudio:1648): Gtk-WARNING **: Error loading icon: Failed to open file ‘/usr/local/share/pixmaps/synfigstudio/color_icon.png’: No such file or directory

(synfigstudio:1648): Gtk-WARNING **: Error loading icon: Failed to open file ‘/usr/local/share/pixmaps/synfigstudio/segment_icon.png’: No such file or directory

(synfigstudio:1648): Gtk-WARNING **: Error loading icon: Failed to open file ‘/usr/local/share/pixmaps/synfigstudio/blinepoint_icon.png’: No such file or directory
[/code] There are lots of these warrnings, I conclude there is one for each button icon. So what’s the fix?