How to build Synfig in Ubuntu Intrepid 8.10


#1

UPDATE: Zelgadis provides packages with minimal dependences here.
UPDATE: There is a repository with the binaries ready to install for Ubuntu Intrepid. See this post.


Ubuntu 8.10 Intrepid has the following version installed:
0.61.08-1build1
The source code of this version was released on march 2008 and at this time it worked perfectly with the current version at that time (Ubuntu 8.04 Hardy).
We have been working on the release of synfig 0.61.09 and solved the bug you have before release it. Simplifying, the bug is due to a change at the GTK/GTKmm version from 2.12 to 2.14 that produced a crash due to a null pointer dereference after a bad instantiation of the spin button class (which deliver a bad value in other place of the code):

code: Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(synfigstudio:16935): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
Segmentation fault[/code]

Unfortunately we didn’t were so quick to introduce 0.61.09 to ubuntu 8.10. Maybe they admit a backport to 8.04 as well as 8.04 is LTS.

So the only way to have synfigstudio working on ubuntu 8.10 is to build it from your self.

SPECIFIC UBUNTU INTREPID 8.10 INSTALLATION INSTRUCTIONS

  1. MAKE UBUNTU BE ABLE TO BUILD DEBIAN PACKAGES.
    Not all the people has the needed tools to build executable binaries from source code. To be sure you have them installed run this command:
$ sudo apt-get install build-essential
  1. UNINSTALL SYNFIG AND SYNFIGSTUDIO SHIPPED BY UBNUTU:
    Be sure that you uninstall synfig and synfigstudio if they are already installed.
$sudo apt-get remove libsynfig0

This will remove libsynfig0, libsynfigapp0, synfigstudio and synfig if were installed

  1. DOWNLOAD THE TARBALLS FROM SOURCEFORGE & UNTAR THEM:
    I strongly recommend to use the shortest way if you’re not used to work with subversion:
    Visit this link and download the tarballs from sourceforge, (etl, synfig and synfigstudio) untar them,

$tar -xvzf ETL-0.04.12.tar.gz $tar -xvzf synfig-0.61.09.tar.gz $tar -xvzf synfigstudio-0.61.09.tar.gz
and do the following building instructions in the order they are shown:

  1. BUILD AND INSTALL ETL
    etl: no development package needed, just:

$ cd ETL-0.04.12 $./configure $sudo make install $ cd ..

  1. BUILD AND INSTALL SYNFIG
    Note 1: Do this before ./configure: the ‘configure.ac’ file in the synfig-core directory doesn’t work with libtool version 2, as shipped with ubuntu 8.10. To work around the problem until a proper fix is found, comment out line 622 (it says “AC_CONFIG_SUBDIRS(libltdl)”) by putting a “#” at the front of the line. The line is required for older versions of libtool, as shipped with other distributions.
    Note 2: Maybe some of the packages have a newer version in ubuntu 8.10. Just install the suggested. I’ve recently upgraded to 8.10 and the libraries were automatically updated without problems to build the code.

synfig: it needs some development libraries to be build:

$sudo apt-get install libxml++2.6-dev libsigc++-2.0-dev libltdl3-dev libtool gettext cvs libpng12-dev libmng-dev libjpeg62-dev libfreetype6-dev libfontconfig1-dev libopenexr-dev libavcodec-dev libavformat-dev libmagick++9-dev libdv-bin ffmpeg imagemagick $ cd synfig-0.61.09 $./configure $make $sudo make install $ cd ..

  1. BUILD AND INSTALL SYNFIGSTUDIO
    synfigstudio: it needs some development libraries to be build

$sudo apt-get install libgtkmm-2.4-dev libgtk2.0-dev libglibmm-2.4-dev libsigc++-2.0-dev libltdl3-dev libtool gettext cvs ttf-freefont ttf-dejavu ttf-dustin $ cd synfigstudio-0.61.09 $./configure $ make $ sudo make install $ cd ..

  1. ALLOW APPLICATION TO FIND THE LIBRARIES
$sudo ldconfig

Please let us know if you have success or not.
Greetings
-G


#2

I’ve just registered to say:

Thank you very much, Genete!
I’ve built Synfig 0.61.09 successfully on Ubuntu Intrepid (8.10).
However, I needed to run

sudo ldconfig

just after the Synfig part. Synfig didn’t find libsynfig.so.0 and the synfigstudio compiling threw an error at the icon creation phase otherwise.
checkinstall didn’t work for anything other than ETL, and I wound up make install’ing them all. So no debs for now. :confused:


#3

Well, I just registered so I could also say thank you!

I now have a working Synfig 0.61.09 on intrepid 8.10.

Genete, your clear instructions worked. Perhaps I am too much of a noob, but it took me a few attempts before I realised I needed to install G++ from the package manager.

Gaijin, I have no idea what “ldconfig” does, but that also worked. Initially I had errors with libsynfig.so.0, and using the command fixed it on my third or fourth install attempt.

I have never compiled an app. from source before, but I really needed synfig to make some projections for a play to be performed in less than 3 weeks. I am extremely pleased that I can continue my work.

Thanks again


#4

thank you a lot for the instructions.

i have ubuntu studio intrepid newly installed and i had to do these additional installs:

sudo apt-get install libgtkmm-2.4-dev

preinstalled on intrepid ubuntu studio is ETL 0.4.11
so i needed the package ETL 0.4.12 from here:
http://sf.net/project/showfiles.php?group_id=144022&package_id=198849
also

sudo ldconfig

after both installing synfig and synfig studio

now it works :smiley:


#5

Hey eyecolor! I’m glad you suscesfully installed etl, synfig and synfigstudio!
Isn’t libgtkmm-2.4-dev already listed in the 1st post? and when I say “download the packages from this link” is not obvious that you have to download all them? :unamused:
And yes, I have to add the ‘ldconfig’ thing to it.
Enjoy! :smiley:
-G


#6

Hey Gaijin and bungleman!
Thanks to you too for your clarifications and your encouragement!
Enjoy synfig! :wink:
-G


#7

:blush: true - seems i have been working in circles :wink:

thanx anyway


#8

after following the steps what should I do to run synfig studio?


#9

You’ll find it under Applications->Graphics->Synfig Studio (if you use Gnome), or you can execute synfigstudio from a terminal.


#10

I cannot open synfig by both method you mention… it seems that my installation has problem


#11

Did you notice something strange when compiling?
can you type this in a terminal?

$ type synfigstudio synfigstudio is /usr/local/bin/synfigstudio $
This would tell you where synfigstudio is located.

Did you un-install the shipped packages from ubuntu?

Try all the steps again but be sure you type this in the terminal before start doing anything:

$export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig

And run this command before you run the program (synfigstudio):

$sudo ldconfig

Last thing, paste here the console output you obtain.
Good luck
-G


#12

i too am having problems with building it, Genete! I just recently downloaded and installed Ubuntu 8.10, using Wubi installer, and attempted to build synfig on it, using your instructions, but i ran into a couple problems… :confused:

ok…first of all, after downloading etl, synfig, and synfigstudio, i ran the terminal, and tried typing in ‘cd etl’ like you said, but i got an error message in the terminal saying that there was no such file or directory. well…i finally got past that one, thanks to pixelgeek’s help (turns out the problem was i had to first go to the dir containing etl, using the terminal, before the command worked), but then i ran into another problem at the place where i’m supposed to type in ‘sudo make install’, and then type in my user’s password, but for some reason, ubuntu would not allow me to type in ANYTHING at that place! :confused: the flashing typing thing would not even move…although it would stop flashing when i typed!

not sure what the problem is…

So could you help with this, Genete?

Thanks, and much appreciation! :slight_smile:

EDIT: oh, and another thing, Genete! my version of ubuntu, using wubi installer, didn’t come with synfig pre-installed! :question: just wanted to clear that in case your wondering!


#13

wow, after giving it another attempt, it works now!!! not sure what did I do wrong.

Thanks a lot!


#14

@ Sinkestistie: I’m glad it worked for you. Enjoy!

@ Coolname007: I’ve modified the instructions to help on unpackaging the tarball files.

once you have un-compressed the tar.gz files they should produce the following folders: etl, synfig-core, synfig-studio. To test that you have unpack all the files properly you should obtain more or less the same result than me:

After download the files form sourceforge and after run the ‘ls’ command (‘ls’ = ‘dir’ in MSDOS):

After do:

tar -xvzf ETL-0.04.12.tar.gz

and run ‘ls’ again:

After do:

tar -xvzf synfig-0.61.09.tar.gz

and run ‘ls’ again:

After do:

tar -xvzf synfigstudio-0.61.09.tar.gz

and run ‘ls’ again:

once unpacked correctly you can continue with the following steps of the recipe.

Regarding the missing characters when typing your password it is just a security thing. ‘sudo’ means “super user do” what means that the following command that you type will be done by a “super user” with certain privileges. That ‘sudo’ must be used carefully because if you do a mistake in the command after it, you can eventually delete all the filesystem or damage them permanently (or very complicated to restore)… and you don’t want to do that, right?
It is possible that someone else is watching your terminal at the same time than you (even with your permit; for example you could want that someone can help you remotely to do some tasks in the computer). If you type the super user password and the letters are shown he can copy them and enter in your computer!, do you want that? I guess no. So even the number of characters are hidden.
When you use ‘sudo’ in ubuntu you should type your password when it prompts for it. Type the password carefully and without visual feedback. If you make a mistake you can repeat; it is user friendly.

Try it again and have good luck!
-G


#15

Thanks, genete, for the new instructions!!! :smiley: i’ll get on it right away, to make sure that i’ve uncompressed them correctly!

as for the bit where you suggested that someone else had access to my terminal, such as a remote user, the answer is NO! :smiling_imp:

i am the only user of ubuntu on my computer, and i have not lent out any privileges to ANYONE, nor have i allowed anyone remote access to my computer!

and about what you suggested concerning the sudo password thing…no, i don’t think that’s the case! :wink: i am QUITE sure that i typed in the correct password…its just that the terminal for some reason did not want to recognize it! it is, after all, a four-letter password… :laughing: and pixelgeek suggested the same thing, that is, that the sudo password was invisible, and maybe i wasn’t typing it correctly! but…i tried it again to make sure, and still got the message saying there was no such command…and the flashing typing thing did not even move to the right at ALL! :unamused:

Looking forward to your reply…

-Coolname007

EDIT: And oh, and just for the record, i extracted the files after downloading them using the Archive Manager…just blame it! :laughing:


#16

sorry, genete, but the FIRST command didn’t even work! i couldn’t even get past it, because i got a message saying ‘no such command’ again! :confused:

:unamused:

Do you know why it didn’t work?

-Coolname007


#17

can you paste here exactly what does the terminal says when you type:

$ls

where the ‘$’ should not be typed, just the ‘ls’.
Better just make a screenshot of the terminal window. In ubuntu is easy, just press: ALT + PrintScrn buttons. Then give a name to the image file and it will be saved tot he Desktop folder.

The ‘no such command’ message is not a string response that sounds to me.
If I type something in the terminal that is not a recognized command it would tell me something like this:

where “orden no encontrada” means “command not found”.
Notice the ‘$’ in the prompt. That’s the default end character for the terminal prompt command line.


#18

EDIT: delete (no point to this message)


#19

EDIT: delete (Reason: too much dramaticism)


#20

In the folder where you downloaded the tar files from sourceforge, can you run again the ‘ls’ command?
It is not needed that you paste a screen shot of the terminal window like I did, just select the text with the mouse in the terminal and do right click > copy. Then go to the post reply to this current one and do right click > paste. After that you select again the text in the post and press the ‘Code’ button that exists in the top of the post when you’re in editing mode (B, i, u, Quote, Code List, …) then the copied text will be formated as if it comes from a terminal…

It is weird, a screen shot is usually a png file and that’s an allowed format to upload to the forum. Please check again the type of file you’re uploading.

-G