Crashing about 20 times per hour

Moving or clicking layers and clicking on waypoints causes it mostly.

It would be useful if you provide more details like Version of Synfig, Operating System, is it occurring in a particular file or everywhere. Have you tried reinstalling Synfig ? etc.


I have experienced many crashes on clicking way points too.

Version 1.4.3 on Mac.

1 Like


Can you check 1.4.4?

Also, which version of macOS are you using?

@Wizzarael @rsrm

When reporting an issue, it is (REALLY) helpful if you provide a screencast or a reproducible step-by-step that shows the crash/freeze/bug/problem.

Synfig Studio is a large program; it has a lot of code lines and many ways users do stuff :slight_smile:

Fair point. I will try to provide a clear repro.

In the meantime I was using MacOS Monterey.

1 Like

I took videos of when it crashes 99% of the time. Where can i send them?

I tried to rotate a group and it crashed 5 times. Im about to try the sixth. But yeah i use multiple computers and both new versions.

Upload it on youtube and post the link here.

Ill get it done in a bit. I also noticed just clicking any where on the screen can make it crash pretty often.

Try opening the project in version 1.4.4 and try again

Well, it seems you’ve imported an mp4 file into synfig. Just to let you know synfig doesn’t work well with mp4 files. Convert them into png sequence files and import them as image sequence if you want to work with videos in synfig.

Ive never used an mp4 in synfig. Also i have about 50 projects that all do the same thing. I use synfig to the minimum pretty much. Just png and jpeg. But i keep seeing to try version 1.4.4 but that version has the same issues and doesnt have the nice waypoint editor.

Oh also another thing. Sometimes ill be working and saving after every change. Then synfig will crash but the weird thing is ive lost up to 10 changes. Saving throughout. That means the save file never updated

Hello, a lurker here, but I gotta join in since I have a bit of a hunch…

Does your project have anything in the sets panel, or have you added anything into some sets before? Because there’s a chance that could be why (at least I think…). But if not, then I’m not so sure what the cause is…

Ive never used sets. I can take a clean install on a random computer and just start crashing it by editing rotation, scale, anything transformation related. And layers of course. Just layers of groups. Groups of pngs or jpgs. Or created art in synfig put into a group. It happens way more if i havent touched anything yet. For example… i have a group i dodnt rotate yet. If i go to rotate it itll most likely crash. After crashing once or more itll mostly stop but can still randomly happen.

Try this build MorevnaCloud

1 Like

interesting… might have something to do with the project file then…

Usually when the errors are consistent across most versions of Synfig (including very late ones), there is a chance that the project file might have gotten ‘tangled’ somewhere within itself (as in broken).
I had somewhat similar problem, although it was for a totally different issue. Long story short, one of the sets in my project file was the culprit.

The part where you said the crash frequency drops a little bit, after one or several crashes beforehand, also piqued me a bit (I might had that same issue, but that was waayyy long ago)

Does this also happen everytime you start with a fresh file?
(Edit: Now that I read your reply again, I’m starting to think this question sounded very silly, but please answer anyway, just to make sure.

btw do you have autosave option on? I found a topic in this forum that somewhat describes your problem quite closely, and they said turning autosave off fixes it for them)