Building on OS X

Hi I am trying to build on OS X and haven’t yet had any success. I will post the details when I get a chance but I just wanted to start a thread to invite other people who are also building on OS X to post their errors and problems/solutions. Anyone else building on os x?

Hi giantspacebug!
I’m also building on OSX with X11, I followed the instructions here
all the way and including the command: “jhbuild bootstrap”
after that I jumped down the page to the “Using X11” part and continued there, it is also some hints there how to solve some errors that you might run in to, further down the page.

After that I followed the etl, synfig-core and synfig building instructions here:

I remember I had a lot of errors when running: jhbuild bootstrap, some of the parts would not compile as it should and I had to try a lot of times before it was succesful.

I’m sorry I can’t be more specific than that it was a long time since I build it from scratch, but if you run in to problems I will gladely help you if I can. :smiley:

Good luck! /ulrik

I got to jhbuild bootstrap as well the error I got:

Zarkon:~ buildah$ jhbuild bootstrap Traceback (most recent call last): File "/Users/buildah/jhbuild/jhbuild/", line 102, in __init__ execfile(filename, config) File "/Users/buildah/.jhbuildrc", line 1 <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> ^ SyntaxError: invalid syntax jhbuild: could not load config file
I’m not sure what the error is but it looks like jhbuild can’t read that document declaration. I wonder if there is a to turn off the syntax checking. I am looking into the error

OK I’m a knucklehead use this script to do the jhbuild install … structions
I must have thought I already did that. :laughing:
more later

This resource is not longer there you should use the GTK+ for OS X installer

I am running into problems with cairomm. Also is there any instructions for packaging the build into an app?

The only Mac build instructions we have are here:

If it needs updating, please add to it.

I imagine you can find out how to create a .app at the Apple developer site.

I keep getting the errror:
*** module gtkmm not built due to non buildable cairomm *** [12/12]
*** module gtkmm not built due to non buildable pangomm *** [12/12]
*** the following modules were not built *** [12/12]
cairomm pangomm gtkmm

Has anyone been getting this also?

If you post the pangomm/cairomm build errors we might be able to guess what the fix might be.

I was yesterday on the IRC channel because I tried too to build the Synfig application on Mac OS X.

The attempt fails but I think I can suppose some reasons and then someone more experienced in coding can confirm or not.

Mac PowerPC G5 1.6Ghz single, 4Gb ram, Xcode 2.5 (latest release), OS 10.4.11
Subversion pkg for mac installed

First attempt was trying to rebuild the xcode projects (declared broken). I had on the machine the prebuild framework from Actually I can manage to build an ETL framework but I fail to have 3 of the tests.

Pen test
Spline test
Stringf test

It says me that the build can be buggy. I tried then to compile the Synfig framework and in fact the error given was on a function declared in ETL called mutex.

Second attempt was to build from terminal (as suggested) and I run all from there even the jhbuild. I tried in 2 ways: with the JHB=fw-10.4 option and without. All the times the pango library collapsed. First error was on a quartz call and I managed to avoid it installing libpng, second was a generic error on a call inside the library.

Second of all even macports can’t install on my machine git-core, it calls a dependency of perl5.8 but it makes an error in compiling the package.

I made some research and then I opened a new GTK+ project and I discovered (with terror) that in the description is indicated X86 ONLY files. So I think that can be possible that on PowerPC I have no possibility to compile with GTK+ because can call just x86 functions. I can’t find any infos on it but could be a good reason. The question is if on an intel machine (I own also one but I have to try on it) I can build a xcode project and build a universal binary anyway.
The suspect is more strong because I tried to have a FreeBSD or Linux on my machine, when mactel was an idea in Jobs’ head, (I managed to install the system, I am not new to linux system) and there simply wasn’t libraries that I needed to compile Synfig for PowerPC.

I also found out a tutorial on Gimp 1.2 build on OS X. It was suggested to change some line on the code because Mac declares headers in different ways and can stop on Windows-based callings for reasons due to the compiler.

My interest in this project is to use it and give relevance to it. I want to use the software to produce films and I’d like that the software could be diffused on every system. I really think that Synfig, Gimp, Blender, Inkscape and many other software are great solutions also for professionals and they have to be simple to use and install on every system (like Blender is). Obviously the other solution I have is to install a linux x86 that can support my Mactel hardware, but it is not my task. If there will be a universal binary of the software it is better.

I am going to do this step by step
when trying to bootstrap jhbuild I get this:

Zarkon:~ buildah$ jhbuild bootstrap Traceback (most recent call last): File "/Users/buildah/Source/jhbuild/jhbuild/", line 117, in load execfile(self.filename, config) File "/Users/buildah/.jhbuildrc", line 1 <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> ^ SyntaxError: invalid syntax jhbuild: could not load config file

when I trying to build synfig-core I get this:

Zarkon:~/synfig/synfig-core/trunk keith$ autoreconf --install --force aclocal: macro `AM_PROG_MKDIR_P' required but not defined aclocal: macro `AM_PROG_MKDIR_P' required but not defined autoreconf: aclocal failed with exit status: 1

OK so I corrected this problem by updating my automake,
use these instructions:
this version is 1.6.3, you can determine yours by typing automake --version in the terminal.

Hi giant…

this line means that there is no configuration file to load, and that’s because the link to .jhbuildrc file at the synfig site is dead, so I tried this way instead and got jhbuild bootstrap command to work, go here and check this instructions:

download this file: …
open terminal, cd the file and add: chmod +x to make it an executable, then run the script and after that you’re able to jhbuild bootstrap.

Hi guys.

I just come here to give the highest dose of encouragement possible to you for try to build Synfig in Mac OS. Please, if you find any error in the instructions, don’t doubt on modify the wiki or if need any code change please ask to any of the people who has writing rights to make the proper changes in the source code.


thanks for the encouragement. ok having this problem now:
I’m configuring etl and synfigure core with

 ./configure --prefix=/opt/gtk --exec-prefix=/opt/gtk

as per the instructions but i get this

checking for ETL >= 0.04.12... configure: error:  ** You need to install the ETL (version 0.04.12 or greater).

any ideas

That message comes from the configure for synfig-core. It means that the path where the etl library is installed is:

  1. Not the path for etl 0.04.12
  2. The old path of the previous etl version.

Watch this thread for more hints: