bug synfigstudio-1.2.0-xxbit-r2.appimage


#1

Bonjour cela se confirme, j’ai donc installé synfigstudio-1.2.0-64bit-r2.appimage
sur mon pc portable, équiper de “mageia” (distribution Linux).

Bref cela crash, lors des rendus, (synfig s’éteint)
j’ai ensuite installé la version: synfigstudio-1.0.2.x86_64.rpm
(avec l’ancienne version aucun problème cela tourne comme un moulin)

La version RPM c’est ce qu’on utilise pour l’installation des logiciels sous MAGEIA
bref, je ne vais pas critiquer car il y a également des problèmes équivalents avec le logiciel “Kdenlive” version “appimage”.

Qui font qu’on ne peut carrément pas extraire une vidéo, s’il y a eu l’ajout d’un “effet”
ou une “transition”, donc là le bug provient bien de “appimage”

Pourquoi n’avoir pas laissé, le RPM pour les packages à télécharger, ou alors un “tar.bz2”
comme le fait firefox ici:
ftp.mozilla.org/pub/mozilla.org … x86_64/fr/
ftp.mozilla.org/pub/mozilla.org … x-i686/fr/

Les tar.bz2, n’ont juste qu’à être dézippés pour ensuite être lancé en cliquant sur le lien “firefox”.


Les appimage c'est pas génial !
#2

pour moi l’appimage c’estun peu un truc de touriste!
pour que le programe marches bien il faut le rapprocher des autres"officiels" et surtout pouvoir les configurer
en fonction des moyens de ta machine!(carte graphique et autres)
et pour cela il faut apprendre a compiler…
jai le meme probleme, il faut que jem’y mettes! en atendant j’utilise celui des distribs officielles


#3

C’est bien pratique quand même…
L’application devient portable toute distro, embarque sa propre version des libs (donc pas d’interférence avec le système en principe), même si ça grossit un peu l’image.
La config/compilation selon la distro peut se révéler complexe et des incompatibilités avec les libs du système peuvent introduire des bugs.
D’où un environnement de développement maîtrisé et confiné dans les dernières versions.
C’est fini le temps où on tweakait un noyau selon le matos avec compilation de 24h pour 4Mo au final :stuck_out_tongue:
Les appimage ont bien évolué et se sont pas mal stabilisés depuis les presques 2 ans du messages précédent (nécroposting, pas bien ^^)


#4

ok, mais sur mon ordi lesapplimages sont inutilisables…(1.2.2-18 et le1.3.10-testing)
le moteur du rendu me coupe mon workflow et m’pblige a attendre quandil ne crashe pas!
la version que j’utilise et celle de la distro debian et ça marches… bon ça crashe aussi quand j’undo!
mais c’est pas trop genant…pour l’instant
je suppose que ça a voir aussi avec la config de l’ordi
j’ai pas de carte graphique!


#5

Tu peux aussi essayer de compiler toi-même depuis le source, tu auras une version “à plat” directement dans un dossier.
La tâche est devenue très simple depuis quelques temps avec les outils “Nix”:

  • Tu chopes les sources sur GitHub (avec Git ou en décompressant un zip)
  • Tu vas sur la page de ReadTheDocs, il y a quelques pré-requis à taper en ligne de commande, une seule fois
  • Tu te places dans l’environnement de dev en lançant ./dev_env.sh
  • (Depuis le nouvel invite de commande) Tu lances la compilation avec ./build-debug.sh ou ./build-production.sh
    1/2h après tout est prêt à l’utilisation ^^

Note qu’il peut y avoir des problèmes de compatibilité entre les versions de Synfig qui font qu’un fichier .sif ne sera pas forcément compatible, il vaut mieux utiliser des versions récentes si possible


Compiler avec debian
#6

merci ,je vais m’y mettre!


#7