Les appimage c'est pas génial !


#1

Bon voilà j’ai ouvert 2 sujets ici:


J’ai fait des TEST pour comprendre pourquoi, j’avais des problèmes avec les APPIMAGE et les résultats sont: :cry:

Donc voilà, je suis un utilisateur de: Linux Mageia (la distribution francophone)
[je suis également celui qui demande la MAJ des paquets “synfig studio” pour notre distribution, et qui les fait remonter à notre équipe de packaging, sinon sur Mageia on en serait encore à la version 0.64]
notre distribution utilise les RPM comme paquet
chez “debian” ce sont les DEB

Jusque là tout le monde me comprend
voilà peut-être que chez “ubuntu” les “Appimages” marche super

Mais faut penser aux autres car chez moi sur Mageia 5 ou 6
si j’ouvre:
une appimage (n’importe quelle version)
que j’ouvre mon RPM la même version

Sur l’appimage: plantage, blocage, et ralentit
sur le RPM: ça marche rapide, ça ne plante pas.

Donc pourquoi les références comme BLENDER, ou FIREFOX
utilise t-il le .tar.bz2
aller sur le site de “blender” pour voir ce qu’il propose: blender.org/download/
également pour “firefox” ftp.mozilla.org/pub/firefox/rel … x86_64/fr/

C’est du TAR.BZ2

Il suffit juste de télécharger 1 fichier, de le décompresser
et de cliquer sur l’exécutable (aucun plantage).

Bon de toute façon ma distribution, met à jour le paquet, pour que je nos utilisateurs puissent l’installer directement dans le menu des programmes
nous en sommes à la 1.2.0

Bon je le demande si quelqu’un savait et qui puisse me répondre
pourquoi toutes les versions de BLENDER et FIREFOX n’utilisent pas t’il aussi le “appimage” ???

C’est un problème de puissance de la carte graphique, configuration de machine, le hasard, la distribution qui gère mal le APPIMAGE, peut-être que le appimage, n’est pas fait pour les programmes complexes, mais les simplet, je n’en sais rien,

Je ne dois pas être le seul à avoir ce problème.
sauf que pour ceux ou ça ne marche pas ils se tourne direct vers un autre programme, sans chercher plus loin.


#2

Salut,

le principe des appimage est de rendre portable une application sur un système Linux, sans avoir à se soucier du packaging, de l’architecture du système ainsi que des versions de librairies installées.
Un seul fichier, toute une palanquée de problèmes résolus.
Pas de deb/rpm ou autre.
Il arrive parfois que ne soit pris en compte correctement certaines librairies, puisées alors directement depuis le système (voir la lib pour l’affichage des icones absente de certains systèmes)

Etant moi-même sous Fedora une partie du temps, je connais ce genre de petits soucis avec les versions disponibles dans les dépôts.
Ce sont les mainteneurs de chaque distro qui sont “responsables” de la version disponible en cours.
A savoir qu’ils sont configurés et compilés spécifiquement pour chaque distro (Fedora REFUSE les applis dont ils ne disposent pas des sources à compiler eux-mêmes, et je crois que ce ne sont pas les seuls)

Synfig est une app relativement “petite” et non critique en matière de sécurité, et peut donc se permettre d’embarquer les ressources dont elle a besoin.
Blender et Firefox utilisent une quantité impressionnante de librairies et ne pourraient se permettre d’utiliser des versions obsolètes de celles-ci pour des raisons de sécurité (et des appimages de plusieurs gigas ça n’aide pas à faire les mises à jour).

Et si vraiment tu n’aimes pas le appimage, tu peux toujours télécharger les sources et les compiler directement toi-même :mrgreen:
github.com/synfig/synfig


#3

bjr, moi aucun des appimage que j’installe ne marchent, je fais toutes les commandes correspondantes, donc celle du chmod puis la ./nomdufichier.AppImage et ca m’affiche un message d’erreur :

, et je n’arrive pas a savoir d’ou ca vient, mais le probleme c’est que je dois m’en servir pour mes cours demain mdrrr,
AHHHH putain de appimage a la con, au fait pour ceux qui voudraient y jeter un oeil voici le lien des appimage, https://lelivrescolairefr.zendesk.com/hc/fr/articles/210697629-Comment-telecharger-l-application-lelivrescolaire-fr (c’est ceux de 3eme qu’il me faut) merci davance et dsl si c’est pas dans le sujet mais comme c’est un des seul topic appimage , je me permet …merci d’avace a +


#4

Bienvenue à toi :slight_smile:
Essaie d’éviter de reprendre des sujets pour une résolution de problème, crée ton propre fil de discussion plutôt.
Evite aussi les mots à consonnance marseillaise :stuck_out_tongue:

Pour ton problème, je soupçonne un problème de 32/64 bits.
J’ai essayé de choper le bouquin de Physique/Chimie 3ème qui est en x86_64, les autres le sont sûrement aussi…
Quelle version de Linux possèdes-tu ?
uname -a
et
lsb_release -a
(voir https://www.hostingadvice.com/how-to/ubuntu-show-version/)

Si tu vois 32 bits c’est cramé :stuck_out_tongue:

Dans le pire des cas, essaie d’utiliser une version .exe Windows dans Wine.
Il faudra juste changer ton UserAgent dans ton navigateur (avec une extension) pour faire croire au site que tu es sous Windows (au pire je peux te filer les liens directs en MP)


#5

j’avais créé un topic mais il n’etais pas tres actif :yum::yum:, en revanche le coup du user agent m’interesse


#6

Il faut juste que tu chopes une extension type “User-Agent Switcher” (sur opera j’ai celui-ci https://addons.opera.com/extensions/details/app_id/jikibpedldihacokaanimbcjipghbloo)
Certains sont livrées avec des chaînes de user-agent déjà toutes forgées, sinon tu peux en trouver sur des sites type http://useragent.fr/


#7

ok merci , moi j’suis sur firefox , j’vais essayer de choper un user agent windows en x32

[edit ] j’en ai trouvé un assez simple pour mozilla : https://addons.mozilla.org/fr/firefox/addon/user-agent-switcher-revived/?src=search

[re-edit] l’autre n’etait pas en X32 celui la est un peu plus fourni :wink: : https://addons.mozilla.org/fr/firefox/addon/uaswitcher/?src=search j’ai juste édité le WIN64 X64 en Win32 x86 et ca a fonctionné ,

en tout cas merci de m’avoir repondu , et maintenant , j’vais au devoirs mdrrr :smile: :wink: ,