Work in plain pixel dimensions?


#1

I want to export an animation video that is 1920x1080 pixels in size. In Canvas > Properties, I have changed Physical Width and Physical Height to 1920 and 1080 respectively.

I also noticed that importing a pixel art png at its native size introduces blurring when I scale it up. So I made a new 1920x1080 stage in GIMP, imported my pixel art character into there for a sense of scale, and scaled up the pixel art to its final size of 400x400 pixels, and exported that image.

But it does not appear on the stage at the same size it appeared in GIMP. It’s so big it fills the screen.

Here is the scale the pixel art (bunny) should be, in the 1920x1080 GIMP image;
Selection_233

And here is how it looks in Synfig when I import it, after setting the canvas to Physical Width and Height of 1920x1080

I also noticed that the unit sizes along the top and left of the canvas are in ridiculous figures (eg. 40000) and I can’t zoom out any further than 0.8%. This to me says something is wrong. The units should be 1920x1080 maximum. But in Canvas > Properties, if I set the regular “Width, Height” settings to be 1920x1080, and import the bunny, he comes out the same as the screenshot above, way too big. Plus I’m not sure if that will export to 1920x1080.


#2

good question.

this:
capi-nivel2

animation in synfig result:

mpv-shot0002

Has a lot of blur and can not do that the movements are always pixel to pixel


#3

:thinking:Mmm… Im curious now, I’ll try to see what happen.


#4

For Pixel Art it’s a good idea to change the interpolation mode from linear to next neighbor.
Go to the lowest layer of your imported image to find this setting in parameters.

Other than that in Synfig Preferences under Editing, there is an option to toggle automatic scaling of imported images.

I hope this helps out


#5

look, I have this pixelart:

ari_by_lobozamora

I export the image sequence on PNG using GIMP (the Images size still be: 43x82 Pixels) then I imported into Synfig, ok.

you can make your canvas size: 1920x1080 and Import the PNGs, To remove the Blur option eff just change this option: Interpolation from Linear to Nearest Neighbor.

I hope this can help to you.


#6

:smile:


#7

Dang it, it’s nearly a month after I posted this and I forgot to check back until I came back to my project.

lobozamora, dude, you are awesome, thank you. This worked perfectly!


#8

Thank you Estard, your description of where to find the Interpolation setting helped me.

As for the scaling setting in Preferences, actually this setting was turned off and the bitmap still scaled to fill the stage when I imported it. Not sure why. Not the worst problem, I can work around it, but still strange. Actually it was bigger than the stage. Maybe it has something to do with Synfig’s interpretation of the DPI setting of the PNG…