[Windows] Synfig not remembering window size

I feel like it is necessary to remember window size, my main monitor is pretty big in size So I use almost every app in small windows. Every app, even AIDA64 remembers the size of the window from the previous time I used it. But everytime I open synfig, it just opens in almost a full window. Which is pretty annoying if I sit in front of my monitor (which I do all the time, because my Desktop room is small). Because I have to look up each time to readjust.

Isn’t there a way for synfig to remember my window size, because that is something basic but extremely important for functionality of an app.

Just did the test with 1.4.4 and 1.5.1 (Linux).
1.5.1 saves and restore position and size.
1.4.4 can only restore, but not to save, it actually restores position and size that have been saved by 1.5.1.

Please do the test with 1.5.1 if you are using 1.4.4.

Also, please don’t report issues from a current (outdated) stable version, development versions are the ones to be used to test and report bugs.


It does for me as well, but on linux, even on mac (hackintosh) . It doesn’t do that on windows, I did try to update windows and my graphics driver, even my bios to see if something happens, but the results were nil.

To explain, it works correctly on Linux, hackintosh. But the only thing it doesn’t work in is windows, the previous size is niether saved and restored, no matter if I open synfig through app menu or open the project I was working on. I don’t know why it does that, and is super easy to reproduce on my desktop, close synfig in a different window size > Open synfig.

I am only using the development version after the freeze issue :sneezing_face: (I know stable version is not that stable :slightly_smiling_face:)

I am only using 1.5.1.

I still can’t solve my problem. Any help?

Try this trick

Resize the window screen of your required app and then hold the ‘shift key and press X’ (cross) to close the app. This will save the screen size and it will reopen in the same size next time.

1 Like

Thanks it works now for me by using this trick.

Another way of solving it, try to change resolution of your monitor through Nvidia control panel or intel control panel 1 pixel lower on both.

It solves it for me on LG 65EP5G-B 65.0 by setting the custom resolution to 3839x2159. However it works correctly with Samsung Odyssey Neo G95NC (not my machine and monitor!) at full resolution.