why cannot I get ffmpeg to work?

hi guys!

I´m guessing that some of you already seen my previous posts so you know that I had issues early on with creating my animation but I was wondering one thing… am I the only one who experience issues with rendering (ffmpeg)? I have all the scenes I need for the animation but not able to render them, which is quite frustrating.

I´ll take it from the beginning.

I installed synfig studio on my PC.
I noticed from the beginning that rendering in ffmpeg sometimes didn´t work. It was like Russian roulette. You never knew when it would work and when it wouldn´t…


I installed the application instead on my virtual PC on my MAC computer (the reason for this was that I wasn´t able to get the MAC version to work at that time) and there it worked fine. I was able to render with ffmpeg. No issues at all… until two days ago.

Then suddenly it stopped working. I thought maybe it was because I had an older version so i updated to the latest synfig studio version… but nothing. the issue persisted.

I have also managed to install the MAC version but the issue is the same there… not able to render with ffmpeg.

so now I have 2 computers, one PC and one MAC with the same issue on both.

what is causing this and how do I solve it?

Hi Chris79,

ffmpeg render uses a hardcoded command line execution of ffmpeg binary. The ffmpeg interface has changed from one version to other in more occasions that we would like so it is difficult to maintain a command line interface unless we provide a user customizable command string that it is not the case at the moment.

We have had some issues when dealing with non ascii characters with the path of the file to render or the place to render the file. Please check that you always use compatible path for your animation works.

Additionally it would help us if you paste here the result of the messages thrown to the terminal (in mac) or the console window (in windows) when the ffmpeg render fails.

You can provide the ffmpeg versions you have installed in both machines to let us compare with people that have it working.


I just get “rendering finished successfully”. but no output

I installed Synfig Studio versions: 0.63.3, 0.63.4 and 0.63.5

In Windows, there is a black window MSDOS type behind Synfig Studio, please take a look to it.
In Mac, you have to search “Terminal” in the spotlight and then open one terminal To kno window. Inside it write ‘synfigstudio’ (without quotes) and press enter. Copy the output a the console and paste it here.

To know ffmpeg version please open a MSDOS window in Windows and type ‘ffmpeg’. Similar with Mac but with a terminal window.


synfig studio windows version: FFMPEG version: SVN-r23008

I don´t have my mac with me at the moment but will take a look as soon as I get back home

And the information from the MSDOS window?

that it couldn´t recognize ffmpeg :confused:

(I just typed cmd in run and then ffmpeg on the command prompt window)

I just found a workaround for this issue.

I noticed that it works fine on both my PC and my MAC if I first open synfigstudio without any of my scenes on it. I leave the empty window open and then I open the scene that I want to render and just leave the path untouched and just change the rest that I want to change.


In Windows, we’re installing the ffmpeg binary in the same directory as the synfig.exe. Windows usually has the directory you’re in as part of the search path…

yesterday a new thing happened when I tried to render on my PC.

the rendered file suddenly stopped at 6kB. it didn´t matter which scene I tried, the rendered file was always 6kB. I tried restarting synfig as well as reinstalling synfig but the issue persisted.

haven´t tried on my MAC yet to see if I get better results.

If you want to post your sif file and ffmpeg render settings, I can try and reproduce it.


It´s not only that file.

the same thing happen if I create a new fresh sifz file as well. it just ends up at 6kb.

yuv240p ends up at 16kb som I´m guessing that something happened to the PC that I´m using…

it all started while I was rendering one of my scenes…

strange… it started to work again.