What does this error mean

New to synfig studio but I’m familiar with gimp and inkscape. Following both written tut Getting Started and the youtube video hasn’t solved my problem of no animation. I notice that the circle does not show up on the Timetrack as it does in the video. A jpg has been uploaded of the console output. Hopefully, it will pinpoint the problem.
1 cpu
synfig 0.62
I have not downloaded any other dependency.

Those console messages are not the cause of the circle not showing.
I guess that you have a tablet or have a laptop.
Please go to Toolbox->File->Device Settings… and disable all the devices that can occur there.
Try again to use the circle tool

File>Input devices reads “No extended input devices”.
Yes, its a laptop. What else could I try? Thanks.

Can you post here a screenshot of the whole screen showing the Timetrack panel, the layers panel and the Canvas window at last?


Thanks for your help, Genete.
I restarted Synfig and did get the animation to work this time. The circle still doesn’t show up on the the Timetrack though.

You missed the most important step of this tutorial:

synfig.org/wiki/Doc:Animation_Ba … g_movement

You have to change to Animation mode by pressing the Green dot in the corner of the Canvas window.

I had Animation mode turned on during the process. The animation works. I turned it off after everything was done to preview it just as the tut and video explains.
In the tutorial the circle doesn’t show on the timetrack but in the video it does. Is this even an issue?