Waypoints not saving

Hello, first time poster here. Please advise if I am posting incorrectly.

I have an animation that uses letters that I have imported. I drag and drop them into the animation as needed. The letters have a line boil effect and every few frames they move just a little. When I import them, they have three different states and then I copy the way-points for however long I want the animation.

My problem is when I save and exit the animation, any of the extra way-points are deleted, leaving only the initial three. I’ve attempted to redo the animation and save a couple times to no success. The only workaround I’ve found is to export the animation before I save, but it potentially makes things complicated down the road.

Am I misunderstanding something, or is an unintended feature? I’m using SynfigStudio-1.5.1-2021.10.21-linux64-2cb6c for Linux on ubuntu 22.04.

Sorry, I never heard such issue before :frowning:
Could you please make a screencast to help me reproduce your problem?

Thanks for the reply!

I have the group of letters selected which are individually drag, dropped and arranged as needed. The way-points you see are the ones I copy as needed for any length. The way-point changes are just moving the edges of the letters around.

As I was writing this, I discovered it may be due to me copying the way-points of the “words” group instead of copying the way-points of the individual word groups(Chill,pill,take,our). After changing one of the individual word groups, it seemed to save with no problem, but copying the larger “words” group way-points still isn’t able to save.

How are you copying the waypoints (that working method and the non-working one)?
Can you describe it step by step or screencast it ? :slight_smile:

Oh, My apologies! I thought you meant just a screenshot. Is there a specific way to do that for the forums? I’m not familiar with it.

I am click drag selecting them and the shift click duplicating them into place.

I tried to upload a Webm recording of me doing the actions, however as a new user, I am unable to upload them.

The steps I take are to select the three corresponding way-points in the “words” group by click dragging, and then I move the way-points, press shift to create duplicates, and place them down on the track. I do this for the length of the video. I then save the video, close out of it, reopen, and all the created way-points have disappeared.

I tried to test with the same appimage, and I can’t reproduce yet :frowning:
Could you upload your screencast to a file uploader host so I can see it? Google Drive, OneDrive, Dropbox, or anything better…


Here’s another video showing what’s happening.

Dropbox - 2024-01-16 21-51-25.mp4 - Simplify your life

Thank you :slight_smile:
The problem happens only with the “canvas” parameter, right?

That seems to be the case. Are there better ways to do what I’m trying to accomplish? Honestly I can edit each word individually, which would take a little more time, but that’s okay. Thanks again for taking the time to respond to me. I seriously appreciate the time you’ve taken to investigate this.

I still can’t reproduce on 1.5.0 or 1.5.1 :frowning:

I have used the same letters in a separate new animation, and the same thing occurs. It does seem to happen with only the group of words and not the group of letters. Could it have something to do with the imports themselves? The files are all located on USB storage, which may cause something too.

OK. I got the problem.
You are using timetrack to move or copy waypoints that already exist in a linked/imported canvas file.
Synfig Studio should warn you, as it does when you try to animate it from work area. Example: try to move a letter vertex in animated mode. It warns you:

The current way to make it work is:

  1. open all your files (the composition and the letters);
  2. do your changes; and then
  3. save all those open files (there is a menu item for Save all :wink: )

This issue exists since 1.0.2 at least o.O I’ll try to fix it (give the warning :P)

Ahhh I see. Thanks so much for figuring it out! I wasn’t aware that was something I was unable to do, but I will go through everything and Make sure not to use the way-points of imported material unless its done in the original.

Thanks again!

For now, what I could do without potentially break a lots of things is to give that same warning. I hope I don’t forget to try to do so :slight_smile: