variable naming question

According to … ions#Names

I joined play and pause buttons as following,

Gtk::Image *icon1 = manage(new Gtk::Image(Gtk::StockID("synfig-animate_play"), Gtk::ICON_SIZE_BUTTON));
        play_pausebutton = manage(new class Gtk::Button());

play_pause is already used in other piece of the preview.cpp, now my question is which one should I use in this case?
play_pause_button or play_pausebutton or playpausebutton ?

My suggestion is:
‘canvas_play_pause’ for the navigator framedial
‘preview_play_pause’ for the preview dialog

This way you don’t need to add the ‘button’ trailing tag.

There is already a function named play_pause() in preview.cpp as bellow. I read canvas.cpp and found there are some similar variables using names xxxbutton, stopbutton for instance.

Maybe those variable names were given before those coding rules. There are lots of places where the naming is not followed. Please use the one you consider right and feel free to change naming on existing places if they deserve to be adapted to new coding naming scheme.
Coding conventions are only for readability and maintenance but the important thing is the functionality of the code.