Update and Render Issues

Continuing the discussion from Weekly Reports (2022):

@KonstantinDmitriev I tried the new build and it still repeated itself. I am using Windows 10.

I also noticed that rendering to .avi is slow (about 3 min per frame) and to png sequence using ‘png’ takes 10 minutes per image. I am confused because it didn’t take as long before

This took 3 hours to render (50 frames)


Hi @Rhvy1!
Thank you for testing, I will keep investigating and provide new builds soon.

Sorry, I do not understand. Which version you mean here? You mentioned the new one is not starting for you, so I guess it some old version? It became slower, comparing to other version or…?

The version before the one released on 09-19
Should be 09-12 or something. It was slower compared to other previous versions

Could you please provide the source file and tell us if the problematic version is this one: Weekly Reports (2022) - #55 by KonstantinDmitriev ?

I just checked and remembered that 09-13 had the same issues that 09-19 had so I deleted it.

The version that renders slowly is 08-31 compared to 08-16

Just used the latest developmental version. It loads Synfig well but the render is even slower; about 10 minutes per frame

Couldn’t you provide us the source file?
We could investigate what would be getting slower in Windows version due to latest changes…
You could PM us if cannot be publicly available.

twirly.sifz (9.4 KB)

1 Like

OK. AFAICS the slowness is due to blur layer (that is slow indeed).
I’ll try to take a look what changed from Aug’ 16 to Aug’ 31 that could make it worse.

1 Like

I was thinking about using feather instead. Will that be OK?

@Rhvy1 We have made a new build, can you please check if it starts for you? -

I tried the .zip file on my windows 10 and I just got a blank screen. I waited for about 20 minutes and restarted but still got the same problem

I tried it on a windows 7 and it worked fine just that the blank screen still showed up but resolved itself in less than 2 minutes

Does your Windows username or path to Synfig contain non-latin characters or spaces?

It doesn’t.

This is the path name

I just tried the .exe and it worked though the blank screen was still showed up for 5 minutes or so

This build has too many zeros in the value field.

Do you use hard drive? Is it too old?
Just asking because if your hard drive is dying, it could make loading programs really painfully slow.

I dunno. I’ll check though

Just tried the .zip version on Win10, with console parameter.
First start was a lot slow and blank windows as described before, nothing at all displayed in console (but a missing icon notification)
Next starts are fast.
Maybe the first font cache scan?

1 Like