Unable to load .sifz

Hello, I’m having a problem when loading some of my works.
This mostly happens after synfig crashes, but it doesn’t seem to matter if the .sifz file was being used at that moment.

I did look around the forum,and the closest I come to an awnser is to open it with a HTML editor and change the line where Synfig says the error is located. But if it is that I have absolutly no idea what I’m supposed to write in it’s place.

Here is the error message I get when loading 1 of my works:

And here is the .sifz file in notepad++:

Thanks in advance.

Your file is difficult to fix.
You have 8 skeleton layers with a total of 21 bones. Those bones affects to 208 elements…

To fix the file you should:

  1. Create a simple file with a skeleton. Save it as sif and open it in Notepad++. Set its language as XML. Then notice that there is a section at start called where bones are defined. That section is missing in your file. You have to copy/paste that section … in your file in the same place (before layers)
  2. Then you have to identify how many bones are used in your file and where are they located. You can search for layer type=“skeleton” to find the skeleton layers. Then you’ll see something like the bone identification inside: that GUID string is one unique identification number for the bone. You should create new bones entries at the top of the file in the section you pasted. Notice that the bone definition (i.e. hierarchy, geometry, position, etc.) is fully missing and you have to create it manually. Follow the structure of the bone you pasted on step 1)

Once you have completely recreated the section you’ll be able to open the file normally.

I’m sorry but it looks that it is better to start over or rescue a previous backup of the file.

Thank you for the fast reply.

I restarted the project trying to limit the amount of bones by using a very simple graphics style.
And that worked fine.

I will however try out the solution you gave if I find the time.

Hi good day.

I have the same problem, I can reproduced the same error 4 times, In my case its happening because you have some Bones with animation and when you copy the layers with the bones to other .SIFZ file all looks OK until you try to Re-Open the file.

I try hard but I cant, when I set the Language as XML on the NOTEPAD++ and open the file all looks like this:

I lose like 5 hours of work with this, the only solution that I can find was; re-made all again from the scratch.


your .sifz file is gzipped.
Rename it as .zip and extract it.
It contains another .sifz file that you will be able to rename as .xml
Do the modifications with Notepad++
When your modification will be done, rename it as .sif
Open it under Synfig
Save it as .sifz


can u tell me how can I prevent it . It happend with me back to back 2 times be cause of the skeletal diformation . and how can I rescue the backup of the file . plz help