Unable to load .sifz file

Sorry if this was covered somewhere, but I tried searching the forum & documentation but couldn’t find anything related to this. I’ll try to not make this confusing…
The error:
Unable to load “E:\PROJECTX\CHAPTER 1\2 Drunken Pharaoh EXT\Synfig Files\C1S02.sifz”:

  • E:\PROJECTX\CHAPTER 1\2 Drunken Pharaoh EXT\Synfig Files\C1S02.sifz::3949: error: Canvas ‘in line’ has undefined ValueNode: ‘…_CHARACTERS\Pl_Gabrielle\SynFig Files\pl_Gabrielle_rig.sifz’

What I did:
I set up individual character and scene files for each scene so I could animate walk animations without overwriting keyframes. IE CharacterSc01 imported into Scene01, CharacterSc02 imported into Scene02, etc.

I’m currently working in “Scene02” and accidentally copy&pasted a layer from CharacterSc01 into the imported CharacterSc02 inside Scene02, saved it, closed it, and now when I go back to it, my scene file won’t open. I get a very long list of the above mentioned error. :cry:

What exactly does this error mean, and how does one go about fixing it when one can’t open the file? Is there any way to fix or recover this? I have a feeling I might have to start scene02 from scratch again =( but I thought I’d ask first.

Thanks kindly,

Hi!
Don’t worry it should have a solution.
First do a backup of all your files.
Second unpack the sifz file using a file archiver. Try WinRar, I think that it supports tar and bz2.
Once converted to sif, go to line 3949 and try to fix the line. If you don’t success, then paste the file here and we will try to fix it.
-G

I am having a similar issue. I created an animation with many layers and for some reason I am unable to open the sifz file. My error message says:
Unable to load “C:\Program Files (x86)\Synfig\bin\4.sifz”;
*C…:265050;
error Unexpected element
*C…:26505;
error: Bad ValueBase

I am unable to unpack the file as you suggested because it doesn’t show up anywhere except the synfig directory, which limits my options to “Show hidden files” and “Show size column” when I right click.

Prior to this error I had been using the skeleton layer to create bones by enabling experimental features. I have disabled the features now and tried everything to get this file that I have worked so hard on but nothing seems to work.

Try the following:

  1. Install WinRAR or other archiver that can extract zip files.
  2. Rename your 4.sifz file to 4.zip.
  3. Right click on the file -> Extract here.
  4. You’ll see a file without extension (4).
  5. Rename it to 4.sif
  6. Open in your favourite editor, navigate to line 26505 and try to fix the problem.
    Probably you’ll have to delete the whole layer where “” node appears.

Note: You can easily screw up the XML structure if you delete the wrong tags. If some problems appear, post your file here, someone will correct it.

P.S. Enabling experimenting features again doesn’t help? Should help, theoretically…

The problem is that I’m unable to rename my .sifz file. I have winrar installed and my .sifz file doesn’t show up there or anywhere else when I go to the directory it’s stored in. For some reason I can only find the .sifz file when I click “open” on synfig.

Oh, I see, Windows just hides the extension of files from you by default.

Go to Control panel -> View by: Small icons -> Folder Options -> View. Look for “Hide extension for known file types”, uncheck this, press OK. Now navigate to your animation folder and try again.

Still nothing :frowning:

I don’t mind starting over. To prevent this from happening again can you tell me how I can output the keyframes of my animation onto a spritesheet? I plan on creating an android application with a cartoon character that responds to the user input.

Thanks in advance,

How it can be? Works for me…

Spritesheet? Is that a big picture with some character in it with different poses? Like those available for NES, Sega and other consoles? If so, then it’s possible, but you will need some script for it, I guess.

I’ll try looking for it, but not now (I am currently working on a particle template). Sorry.

No need, I figured it out. Thanks again!