Tuning problem with animated trace

My intention was to draw an animated route on a map. It was supposed to be a running line with a black dot on the head of it.I broke down the whole route into stages. Each stage had its own dot. The lines war drawn with the tool ‘spline’, option ‘advanced’. Except for the dot and the line of the first stage all other were set to ‘opacity’ 0 in edit-mode. I then entered animation mode and linked and animated each stage, one after the other. The problem then was that the later stages came out of ‘opacity’ 0 without having explicitly changed their ‘opacity’. So I had to set them at each waypoint to 0 or 1, depending on where I was on the timeline. That was a bit tedious. I wonder whether there is a better strategy to avoid that.
I’m running version 1.5.0 under leap 15.3.
I hope this will give you an impression of what I’m talking about:
RouteTanzania.sifz (11.8 KB)

If you just use Opacity as 0 and 1, right-click on this parameter on Parameters Panel, select Interpolation > Constant.

Thanks a lot! That works.