Trying to build Synfig in an Intel Mac

this is my X11, it is developed by XQuartz and open source, it’s downloaded from :

It seems like synfig-core doesn’t find the gtk package and I don’t know why, you could try to run:
export PATH=/Users/yourname/gtk/inst:$PATH
before you execute the “glibtoolize” command

This is my folder structure:
Imagen 4.png
From this page:
Imagen 1.png
I download:

After that, I unrar the folders and change the name (eliminate the numbers)
This is the content of my folder synfig:

And this was inside (line 622):
Imagen 2.png
I changed it:
Imagen 6.png
I wait for your suggestions. Thanks again.

It seems you have done everything right, have you tried my earlier suggestion to run:
export PATH=/Users/yourname/gtk/inst:$PATH
before running glibtoolize in synfig folder?

Failed. Here is the pdf file.
last try before (13.4 KB)

Sorry: I forgot to type cd synfig. I have another result, but failed too. This is the file:
last try with (16.3 KB)

I have seen that the 0.62.00 version is released. I’ve downloaded and I’ve tried the same with it, but I have the same result: “You should update your aclocal.m4”, and when I run aclocal I have the same I had before: warning: macro AM_GNU_GETTEXT' not found in library warning: macroAM_GNU_GETTEXT_VERSION’ not found in library
Is it possible that one step has an error that we couldn’t see? May be we can to try it again from begining. What do you think about?

I have a macbook too. I’ve tried to install synfig in it. I had another problem there: PATH does not contain… I tried with the same PATH that I have in the iMac, but it didn’t work. Finally, I copied the gtk folder of my iMac to my macbook. I have arrived at the same point: glibtoolize. And it say the same that the iMac: “You should update your aclocal.m4” and when I run aclocal I have too: warning: macro AM_GNU_GETTEXT' not found in library warning: macroAM_GNU_GETTEXT_VERSION’ not found in library
I am absolutely confused. :frowning:

Rafael, ulrik,
unfortunately I cannot help so much here. I just want to ask you if you think that it would be good to split the thread into a separated one with a better thread name. I don’t want this researching to be lost in the forum once you stop working on it. It can be difficult to find if the thread name doesn’t give a clue of the discussion. What do you think?

Genete, it’s a good idea, then it will be easier to follow for others :smiley:

Rafael, sorry but I have not had the time to investigate this matter, :frowning: but I will come back to it soon. :smiley:


Genete: Ok. I think it’s a good idea too.
Ulrik: Don’t worry. Come back when you can.
Thanks again. :smiley:

I continue to trying. I searched in Internet “update aclocal.m4”. I read a lot of things, but I don’t understand anything. Any way, I found this: “Please make sure that you have the right version of libtool installed before running aclocal”, so I tried “sudo port install libtool”. After that, glibtoolize worked, but I’m not sure if it’s good. I continued the installing orders and arrived at the last make (in the folder named synfigstudio". There are a lot of messages that I don’t understand. Prehaps It can help you. Here is the pdf of the terminal.
Don’t worry if you cannot investigate it now. :smiley:
today’s (294 KB)

I think you forgot the “sudo” with the “sudo make install” call for Synfigstudio.
Since you did use it for the “sudo make install” for Synfig itself, I assume the
directories are owned by root?


Yes, I forgot the “sudo”. I have done it now but it doesn’t work. Here is the pdf file of the terminal.

Excuse me, Gerco, my english is not very good :confused: . I don’t understand your question. Can you repeat it differently? Thanks.
with “sudo” make (24.3 KB)

Can you try to execute “/opt/synfig/bin/synfigstudio”, and tell us what happens?


Of course: Here is the screen:
Imagen 3.png
As you can see, there aren’t any icons. Here is the pdf.
after trying gerco’s (23.7 KB)

Your file “today’s [294.23 KiB]” shows that the “./configure” script cannot find the development library for PNG support:

checking for png_write_row in -lpng... no checking for png_write_row in -lpng12... no *** PNG Output target disabled ... PNG output target support --------> no

Therefore, the Synfig tool cannot make the PNG icons of Synfigstudio:

synfig -q installer_logo.sif -o installer_logo.png --time 0 ... Unknown target for installer_logo.sif: png Throwing out job... Nothing to do!

And therefore you don’t see any icons!

Have you installed the software development files for PNG support?


I don’t know. How can I know it?

Maybe you have them installed but are not found. … _libraries

In unix system you have to install the libpng-dev library (source code).
Maybe here?


Rafael: Can you perform the following command:

sudo find / -iname '*png*.h' -print

And post the output here?