Touch Screen crash dev only

I’ve been playing with my new touch screen computer and it works pretty nicely for me in the recently released Linux 5.1… version (Windows too), as I can grab a duck or curve and drag it around, but if I run the one I build in synfig.git, it crashes as soon as my finger hits the screen.

Doesn’t Synfig support canvas input only from either mouse and/or drawing tablets? Or is touch input registered the same as mouse cursor?

Did you build on/for Windows or Linux?

Thanks, Sorry, I lost track. It was a Linux build. Since it’s been a month, Let me do a fresh build and make sure it’s still happening to me, then get back to this thread.

It still crashes. To summarize, the released Linux 1.5.1 appimage “2021.10.21 2cb6c” works* with my new touch-screen HP, but when I run my one built from GitHub on freshly installed Ubuntu 21.10 system … Touch screen works okay for menus and things, but as soon as I touch the main screen to place or move an vertex or something, blammo!

Gdk-WARNING **: 13:05:07.189: Tried to map a popup with a non-top most parent
and segment fault, I shall build a debug version and try again.

*I wouldn’t say it’s fully functional wrt clicking menuing etc, and it acts different between Linux and Windows, but even the partial functionality is kind of fun to be able to grab and fingerpaint points and curves.

--------------------------debug version outputs:----------------------------
synfigstudio: /home/woody/synfig.git/ETL/ETL/_handle.h:266: T* etl::handle::operator->() const [with T = synfigapp::InputDevice; etl::handle::pointer = synfigapp::InputDevice*]: Assertion `obj’ failed.
Aborted (core dumped)

Ping. I have been updating the previous edit for a few days, and I finally realized that that nobody is getting a ping.

The currently released synfig seems to enjoy a pleasing default touch-pad compatibility on the 1.5.1 release of both windows and Linux, but what I can build on my system consistently crashes when I click in the graphics window.