Text tool crashes


#1

Hi!
The text tool causes a crash every time I use it. The crash happens every time after entering my text and clicking the OK button.
I’m running Synfig 0.63.03 on my win7 laptop. I 'm new with Synfig Studio, just learning to use it thru tutorials.
I tried to prevent the crash by setting my computer to use only one CPU, but that didn’t help. (I found this stability advice at the FAQ)


#2

Please take a look to this thread to see if it can help you.
viewtopic.php?f=12&t=1026
-G


#3

Thanks for your advice, Genete.
I browsed the ‘viewtopic.php?f=12&t=1026’ but didn’t find a solution. Synfig still hangs every time when I try to use the text tool. It also hangs if I try to load a .sifz file containing a text layer, like ‘sampletext.sifz’. I started the program also from the command prompt. Same result; it seemed to me that no error message was produced.

Here is the result of my test with ‘sampletext.sifz’

[code]C:\Program Files (x86)\Synfig\bin>synfig.exe sampletext.sifz -o sampletext.png
synfig(4192) [11:53:54] info: Loading modules from …/etc/synfig_modules.cfg
synfig.exe: warning: Unable to find module “example” (can’t open the module)

C:\Program Files (x86)\Synfig\bin>[/code]

Any ideas?


#4

One more thing:
Synfig crashes also when I click ‘Cancel’ on ‘Text Entry’ dialog box and even when I try to close the dialog box by clicking the ‘X’ on the upper right corner. I can’t find any error message. When loading a file with text layer a text box ‘One moment, Please…’ appears and then the program crashes.


#5

Masa, when you click on the Text Tool in the toolbox what font is displayed in the “Family” field in the Tool Options panel?

I’m wondering whether a broken or missing font could be causing the crash.


#6

Hello DaveJ,

My Text Tool options are:
Size X: 15,00pt Y:15,00pt
Orientation: X: 0,50 Y: 0,50
Family: Sans Serif

I have tried also with other Font Families like ‘Serif’ and ‘Monospace’, but the result is always a crash.


#7

Getting closer
I installed Synfig Studio on an other win7 computer, and the text tool is OK.
The difference is the CPU. Mine is powered by AMD and this new one by Intel Pentium.
What’s wrong with AMD?


#8

There aren’t any compile options (that I know of) that are specific to AMD or Intel. I would suspect that there is something else different in the two setups, apart from the CPU. I don’t have any AMD systems to try it on. :frowning:


#9

I have an AMD processor in my computer now - my children have got my old dual-core Intel computer (which I was very fond of!). I have an AMD A8, and the text tool works fine for me on Fedora 16 64-bit with GNOME 3.2 and Synfig 0.63.04 (synfigstudio-0.63.04-x86_64.rpm).


#10

The user who has the Text Tool problem is under MS windows.
-G


#11

Sorry :blush:


#12

Hello masa,
I had the same problem. I recently repaired like this:
I found in the font directory of Windows a font that was not the same type as the others. I deleted it, and now the text is ok in Synfig.
But I can’t remember what was this font, or what was his type …
I hope it can help you :slight_smile:


#13

Hello mad0,
I have been for a while wondering that there is something in my computers font system which causes the text layer crashes. I would be very grateful if you could remember what font(s) you removed to fix the problem on your computer.
Thanks for your help anyway.
Masa


#14

Yes,
The text tool started to function. I removed one of my 386 font files. The removed ‘Tamburo’ was a font containing not letters but music notation markings. The origin of this font is ‘Finale’ music notation program. The font contained quite a few characters and there were gaps (empty characters) in between.
-Masa


#15

I’m really glad that you’ve got the Text Tool working now, and thanks for letting us all know what the problem was.


#16

same problem and same solition here.
I hadn’t the tamburo font, but I removed all fonts that were not either Latin or Greek and restarted the computer, and then the text tool works well.


#17

Hello lily and welcome here!

Thank’s for let us know this problem (and solution!) is still present in the corners… Do you use a quite recent synfig version ? (like 1.0.x ?)

If the case, could you please, open a ticket (issue) on the bugtracker with the bug and the solution ?

see’ya!


#18

Same here in the year 2018 with the stable and the new version of Synfig, same solution. I hade this issue with intel, but it’s because i installed once a special non latin foreign language font pack, so nothing to do with the prozessor.
I fixed it by searching ( and deleting ) with more details the last installed fronts on my windows 10 system and this fixed it. Would be good if you guys find a way to fix this in a newer version, to make the text tool not react in a wrong way on special fonts which are installed on windows 10. I don’t understand much about coding so that’s all i have to say about this for now and i had to tell you this because Synfig seems to be really good free alternative for many cool usualy paid flash like animation software.