text problems

I am a brand new Synfig user. I only wish to make very simple animations and the program seems to be what I need. But, the text won’t work. Is there a trick.
Select the text tool
Box appears, I write my text.
Little boxes appear on the canvas where the text should be.
But there is no text in them


Vista Home Premium
Synfig 0.62.00


What kind of colors have you used for the text (and what is the background)?
And what is the composition mode of the text layer?


Also, check out the text size (x and y) in the Tool options panel. I have same issue sometimes. It seems that the options are not properly saved/loaded but never can repeat the same problem two times.


Thanks for the quick response.

Text colour is black.
Background; have tried both white and none (yes, I checked that the text layer was above the background).
Composition mode is composite.
Text size 70 pt

All suggestions hapily accepted.


Could you save your example in a .sifz file and post it to this forum?


Here is an example. Two coloured balls with numbers in them. I have tried the number 1 with a balck fill and a white stoke and also the opposite. There is no animation here yet, I just can’t get past stting the scene.


Synfig Animation 1.sifz (789 Bytes)

When I open your .sifz, I see a black and a white “1” in the canvas window. I changed the background rectangle to red to actually see them. It all seems to be in order. Could you make a screenshot and post it?

This is what my canvas windows shows:


Well that’s wierd. It looks like everything is working (more or less) otherwise you wouldn’t see the numbers. I have a screenshot here. The only change I have made is to turn the backgound red as you did. The boxes turn up where your numbers are. Something is definately not right. Am I missing something in setting up the program or the file?


This is a font - language problem. Can you give details on which is your installed languages and fonts?

How do I find out that information, I installed Synfig with an all inclusive windows exe installer. I don’t recall any choice as to fonts and langugaes.


Genete’s asking if you have Windows set up for something other than US/English language.

Synfig has some default mappings built-in. You’re using San Serif in your composition, which Synfig should be mapping to Arial font. But if there is no path to Arial (i.e. it’s not on your PC or not in the usual location for fonts) then you get the square blocks instead.

If you know the location of the font you want to use, you can enter it explicitly in the Font Family value dialog box - e.g. c:\windows\fonts\arial.ttf


Thanks to all of you for the patient help.

My Windows is set to English (United Kingdom).

Typing Arial into the Font Family dialog box (just that with no specific path) worked.

Thanks again and you will probably hear from me when I get to the next hurdle.