Synfigstudio hangs on startup at - init DeviceTracker -fixed

I have installed 0.61.08 on Ubuntu Hardy.

I used the source code for

ETL 0.04.11
synfig 0.61.08
synfigstudio 0.61.08

After many tries for each step, searching on the internet and downloading various extra software I finally got everything to: configure, make, make install, with no apparent error messages.

But on start up it hangs at the startup icon and the words “Init DeviceTracker”

I tried starting SynfigStudio from console but it gives no information apart from " synfig studio – starting up application"

Has anyone encountered this and solved the cause of the problem?

Fixed the problem - Ubuntu solved it - not me.

After all that I got a message from the GUI package program that there was a broken package. It suggested that I run “apt-get update” and “apt-get install -f”

I did that and it started correcting dependencies and installed “perlmagick” and set up many “lib” files and processed “the triggers for libc” and set up “ldconfig”

And now, it works.