Synfig's older versions are faster


#1

is there a way to move a file back into an older version?

Reason:
when I first downloaded synfig like 3ish years ago?, it was functionally very similar to the newer versions I can see now. however, the newer versions have the entire program as one window, which makes it harder to position, run much more slowly, and crash more often.
recently, after not updating synfig since i first downloaded it, I had a small amount of trouble with an issue in an animation, and heard from somewhere that the newer versions had a marginally useful feature (turned out the feature I was thinking of worked differently). so, I opened the animation in a newer version of synfig and started working on it.
the newer version was much slower. I was going to go back to the old version, but i miss-clicked and saved it, and now it seems like i’ll have to use the new version, but it’s slower and such so I’d rather not.
Is there a way to move “newer” files into older versions, assuming they don’t use any features added after said old version? Also, why is synfig so much slower in its newer versions?


#2

Hi and welcome here :slight_smile:

There is a possibility to move a file back to an older version:

  • Load it in your current synfig (new one)
  • Save as, select the format down-right, then the version down-left
  • Load it in your old, out-dated Synfig

Be aware that Synfig’s File Format has evoluated: structure, new layer types, it is not at all guaranted such a file would be even able to load in an older version nor be fully functional after load if it uses any new feature.

About one-window UI or multi floating windows, you can still drag out each section holding left-mouse down on the tab header and drag/drop it on the main application bar. Then the window will be detached.

About speed which version do you use ? The recommended one is currently 1.3.8 dev .


#3

thanks for the help on the first two things! I use version 0.64.2 mostly and the one i said is slow is 1.2.1

… I’ve tried to do what you said for moving to older versions at least 9 times. it “worked” once, but the resulting file wouldn’t open. the other 8 times, synfig froze, then crashed. It’s not a particularly big file or anything, but it crashes just from opening the file.
Then, it froze and crashed my computer. after that, i worked at it for ~ an hour, and had the great idea of checking what was keeping the file from opening. there where 9 problems, so i looked for layer types I had 9 of, and ended up with groups. groups definitely already exist in 0.64.2, but regardless, i got everything out of the groups, deleted them, and Now it works, i think.

so thanks for the help, and out of curiosity, any idea why groups don’t load?