Synfig won't render video


Ubuntu 11.10, Synfig 0.63.03
Linux Mint Debian 32 bit, Synfig 0.63.03, 0.63.00

I’m an animator looking to start a full company using open source linux programs, including Synfig, but I can’t seem to get it it to render to video. Under Ubuntu 11.10, I made a small test video, (the knight rider tutorial), made it 2 minutes long, 24fps (default), right clicked, went to file - render, target: ffmpeg, named the file BasicKnightRider1.mpg, set video bit rate to 8000 (also tried the default 200) in parameters, and clicked Render. Every time it crashes, and Synfig quits.

I should point out I’m new to Synfig and Linux in general…

I also switched to Linux Mint Debian, thinking gnome 3 in Ubuntu 11.10 might be the problem, but the same thing is happening.

Are there some other settings I need to configure? If someone could provide me with a step by step on how to fix this, I’ll appreciate it.

I had it crash like that too. Try to render as an .avi at 2000 bps. ffmpeg. Seems to work great for me.

After many failed attempts I gave up trying to make Synfig render video - I always render out PNG sequences instead. For me it’s a very good solution as almost everything understands PNG sequences and I can compress them with whatever video compressor I want to use.

As I have to add audio to the animations I create anyway, I usually import PNG sequences from Synfig into Kdenlive, add audio and effects and then render out the finished video from Kdenlive.

Hi omar1,

To help us to debug this trouble you can try to run Synfig Studio from the command line. Please open a terminal (usually under Accessories in Ubuntu) and run this:

$ synfigstudio

If there is a crash, probably there will be a message at the terminal that you can paste here to try to understand what’s happening.

The second thing you can check is that you have downloaded properly the provided package from our site. Go here and download and re-install the package for the correct architecture. To do this you should go to Software Centrer and un-install any previous version of Synfig Studio.

After download and reinstall do one thing before to try to export using ffmpeg target:

  1. Preview the animation. It is to see if the render of the animation is the cause of the problem.
  2. Export the animation to png sequence. Caret Menu->File-> Render and select location to the files to render, a png extension and the png target. Check that it doesn’t crash.

Before rendering using ffmpeg please dot his at a terminal:

$ which ffmpeg

This will tell you where is ffmpeg found. Paste the result here. May be you have in your binary path another ffmpeg and it is the cause of the crash.

Finally, when rendering to ffmpeg target please be sure that you have chosen the path to the file to render, that the file extension is avi, that the path is writeable and that you have user rights to do that. Also that the path doesn’t contain any non ascii character (it shouldn’t happen but maybe it is the reason). Then once selected the ffmpeg target, click on the Parameters button and at the parameters dialogue choose xvid as video codec and a video bitrate of 2000.

Good luck.


EDIT: I have Linux Mint 12 running on my computer and Synfig Studio 0.63.03 runs without problems. I’ll double check the ffmpeg render success again.

I’ve just tried to render from Synfig in Fedora 16 Gnome 3.2 in order to create some error output for Genete, and for the first time it works perfectly. :blush:

I’m very sorry for suggesting that video rendering doesn’t work - it didn’t work for me whatever I did when I first started to use Synfig, but now it works absolutely perfectly.

I’ve re-tested the ffmpeg target (Linux Mint 64 bits, Synfig Studio 0.63.03) and I’ve found one issue (not a crash): if the locale settings uses semi-colon for decimal point, the ffmpeg command fails. I’ve sent a patch to current master branch to fix this issue. It should be available on next release. Meanwhile it is fixed running Synfig Studio by:

$ LANG=C synfigstudio

But I’ve not found any crash.

Thanks everyone for all the replies.

I switched back to Ubuntu 11.10, downloaded the dog head turn animation to test rendering.

Tried .avi at 2000 bps. ffmpeg, same problem. (crashes, exits)

Also, tried the other avi checks mentioned. I’m thinking it might be one thing…if I’m using Ubuntu 11.10, and I’m not running Synfig under the root account, (I’m using another account) would that prevent it from rending? So to render I have to be using the root account at the time, otherwise it won’t work?

Have you tried the suggestions I made in my previous post from 29 Dec 2011, 10:03?

Don`t render in AVI, here what i have:

zurba@zurba-laptop:~/SYNFIG$ synfigstudio

Synfig Studio — запускается приложение…

synfig(7142) [20:17:46] info: Loading modules from /usr/local/etc/synfig_modules.cfg

(synfigstudio:7142): GLib-GObject-CRITICAL **: Object class gtkmm__CustomObject_N6studio15ValueBase_EntryE doesn’t implement property ‘editing-canceled’ from interface ‘GtkCellEditable’
synfig(7142) [20:18:35] info: render target filename: ‘/home/zurba/SYNFIG/tosha/plant.avi’; extension: ‘avi’
synfig(7142) [20:18:35] info: ‘avi’ is a known extension - using target ‘ffmpeg’
ffmpeg version 0.7.2-4:0.7.2-1ubuntu1, Copyright © 2000-2011 the Libav developers
built on Oct 2 2011 17:41:08 with gcc 4.6.1
configuration: --extra-version=‘4:0.7.2-1ubuntu1’ --arch=arm --prefix=/usr --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx --enable-runtime-cpudetect --extra-cflags=’-marm -fPIC -DPIC’ --enable-vaapi --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
WARNING: library configuration mismatch
avutil configuration: --extra-version=‘4:’ --arch=arm --prefix=/usr --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx --enable-runtime-cpudetect --extra-cflags=’-marm -fPIC -DPIC’ --enable-vaapi --enable-libopenjpeg --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdirac --enable-libmp3lame --enable-librtmp --enable-libx264 --enable-libxvid --enable-libvo-aacenc --enable-version3 --enable-libvo-amrwbenc --enable-version3 --enable-libdc1394 --enable-shared --disable-static
avcodec configuration: --extra-version=‘4:’ --arch=arm --prefix=/usr --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx --enable-runtime-cpudetect --extra-cflags=’-marm -fPIC -DPIC’ --enable-vaapi --enable-libopenjpeg --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdirac --enable-libmp3lame --enable-librtmp --enable-libx264 --enable-libxvid --enable-libvo-aacenc --enable-version3 --enable-libvo-amrwbenc --enable-version3 --enable-libdc1394 --enable-shared --disable-static
libavutil 51. 7. 0 / 51. 7. 0
libavcodec 53. 5. 0 / 53. 5. 0
libavformat 53. 2. 0 / 53. 2. 0
libavdevice 53. 0. 0 / 53. 0. 0
libavfilter 2. 4. 0 / 2. 4. 0
libswscale 2. 0. 0 / 2. 0. 0
libpostproc 52. 0. 0 / 52. 0. 0
[Eval @ 0xbedbefe8] Invalid chars ‘,000000’ at the end of expression ‘24,000000’
Incorrect value for r: 24,000000 :unamused:

What can i do?

P.S. I have no Synfig in repos because i have machine on ARM architecture, and i build it from source

It is fixed in the current unstable branch. Please update your git repo:
$ git pull
and then be sure that your master branch is up to date to the remote one. Then rebuild.
Here is the commit of the fix, if it is of your interest: … 34959c5c26

So I’m back to trying synfig, and I think I’ll go with exporting to png images and converting to video using a video editor. My question is, what is the best video editor to use if import pngs? I tried Openshot, which seems to be pretty good. Any others I should try?

Also, what settings are best for getting 720p, 24fps video that will be uploaded to Youtube?


If you’re only going to import the image sequence and export the video you can use Avidemux. For more complex non linear video edition you can try Kdenlive or Blender. … er=1722171