Synfig Studio 1.2.2 (Stable) Keeps Crashing, is it not compatible with Win10?

122
crash
win10

#1

One persistent problem I have had is that Synfig keeps crashing. It has crashed when I am in the middle of working on my animation, and it quit working twice today, and all my work for that session was lost, even though it was easy to re-create. I am using the Win10 operating system. When I click on the properties box, it offers to test the compatibility of the Synfig program. When I try to run the troubleshooter, it only offers to run it in “compatibility mode” for Win8, Vista, and older versions. There is no box to toggle for running it in Wiin10 compatibility mode. I have noticed that many different apps seem to be more compatible with Android O.S. than it is with P.C. I would really hate to try to build a video with my smart phone or mini-tablet, I much prefer to use a P.C. with my big screen t.v. as my monitor. I am very near-sighted and I need a big monitor to see detail. So, my question is, is it possible that Synfig is not compatible with the Windows10 operating system? Thanks.


#2

1.2.2 is full of bugs (stability, usability, non-latin chars in filenames, rendering size…) and it is well-known, not because of Windows
Try the last 1.3.11, you will be surprised :wink:


#3

Thanks for the advice. I downloaded a new copy of Studio 1.2. and it has the same erratic problems as the first download. I considered downloading 1.3, but since it was in development mode, I thought the 1.2 stable version would give me fewer problems. Looks like I was wrong. I like the program, but I was about ready to give up on it. I’ll try downloading 1.3. Thanks again.


#4

You can activate auto backup in the system preferences, I keep it set to 30 seconds when I’m drawing and a minute when I’m animating. Also I clear the history stack all the time and this keep Synfig working, for whatever the reason, a longest time. I still don’t find myself surprised by the development version so, I’m still working with the official 1.2.2.


#5

History stack gets filled quick when you change colorsfrom the selevtor for example.
1.2.2 also suffers from the bug where you can’t change some parameters’ values.


#6

I understand that exist a lot of improvement and new features in the development version but I can’t draw there, the handles disappear and Synfig crash without reason the same way or more often even. I reported this since August 2018 and the behavior is the same until today.


#7

I still have a persistent problem with Synfig crashing while I work on it. I downloaded Synfig 1.3 a few days ago, and it crashed within about 15 minutes, when I opened an animation that I originally built in Synfig Studio 1.2. So then I opened up a copy I had made of the basic layout and saved with a different file name, before I had tried to animate anything, That basic file worked well when i began to animate my character, and after 20 minutes or so, I had finally finished about the first 15 seconds of my animation, when that file crashed on me as well. I don’t know if it’s a coincidence that it crashed after I began animating it, since this other file would crash, even when I wasn’t using animation mode. The last thing I remember doing, was to change the position of my character in my background, and I also changed the size of the character’s head, while I was not in animation mode. Then I ran the preview to see if the animation would work. The animation worked in preview mode, with the changes I had made in non-animated mode. Then the file crashed when I started working on it again. Could these things have caused the crash? Now this file crashes within a few minutes of opening it. Any help is appreciated. After two months of working on this in 2-4 hour sessions, I have 15 seconds of video produced. I have learned a lot, but I still don’t understand why these animations keep crashing.