Synfig Studio 0.62.01RC2 binaries and sources available

Please checkout them here: … /binaries/ … 2/sources/
Select your architecture and your package system.

We still needing you to test them in your linux distribution to polish it before release.

To all translators: you still on time to send translation patches. Please check


Tested on Ubuntu 10.04 x64, it works nice!

PS: Can you please think about adding authors of newly added icons in the “Graphisme” tab of the Credits ?! :wink:

Ha-ha! I like the extra splash more than any of challenge splashes! :laughing:
It gave me decent SUR-feeling when I tried to figure out did I saw stars or circles on the splash. ^___^

Binaries work fine here on Fedora 12 (x86_64).

I forgot to precise I tried it by building from source.

And I agree with Zelgadis : the included splash is cute ! :laughing:

Ubuntu Studio 10.4, “i386 build” working fine at the moment, still there might be some things left for testing

@Animtim: Of course. Next commit will be fix those credits. Thanks for test build it from binaries. Did you use the tarballs or the git repo?
@Zelgadis: :laughing: :laughing: This was my nostalgic goodbye to my Synfig Dragon :wink:
@H13N.H3N: I have it installed on my laptop (ubuntu 10.04) and I still having problems to reset initial window configuration. It seems that panels are lazy and need to restart Synfig Studio to be really positioned. H13N.H3N can you please confirm if it works fine for you? For example move the docakble windows, alter panel disposition, size and so and try to reset them back. I guess I did something on the metacity configuration that makes it work weirdly.
@All: Please try to use the Transform tool as well as all the other tools. Let me know if you find problems with the key combination and with the cursor behavior. Also, as Animtim did, any mistake you can find on the credits or anywhere let me know.

Thank you very much guys!

H13N.H3N: Can you see the new icons in the menus? I can’t see them in a ubuntu 10.04 virtual machine.

I used the tarballs from your link above.

I confirm the missing icons in menus on Lucid, it’s a system setting matter, use gconf-editor to activate them
(see this thread : )

Also I don’t have problems with “reset initial window config”, it works as it should here.

A little --OFF TOPIC-- but I can report here my dual-screen/wacom config troubles I’ve just had on Lucid, if someone is interested in doing the same:
First if you have monitors with different resolutions/ratio (I’m not sure if this happens with two same monitors) it’s a pain to find the good values to assign to Top/BottomXY in xsetwacom config
to get a correct ratio between the tablet and each screen … Good luck with it if you try ! (I’ve succed in the end but with a lot of calculs and values adjustments)
Then with Xinerama mode I have a bad offset bug between my cursor and where it actually draws with synfig, mypaint and gimp (but strangely not with tvpaint beta where it is ok …) although clicking on something is “aligned”, this offset happens only when drawing.
Then hopefully switching to Twinview mode (Nvidia cards) it works, no more offset !

I tested Synfig in Gnome, moved the panels, undocked and docked several ways, resized also and closed to save settings, after open again Synfig and have back the last configuration, i set back windows and docks positions to default as well the configuration:

No problems with metacity and everything can be configured back and will be saved for a next session. Menu icons working (including those from the layers, tool options and canvas’s menu).

I made another test inside XFCE4, same as GNOME, every window seem to fit according to the screen’s boundaries.

I’m able to save and use default layout as well as customize it an have it back in future sessions, on a side note, you might notice a little variation between XFCE and Gnome, this is for the window decoration, that’s why Gnome’s decoration are a little bit bigger. I’m also using a Laptop, display of 1280 x 800

@H13N.H3N and Animtim: Thanks for the deep reports. That makes me feel better :wink:
@Animtim: I’ve dual screen and haven’t noticed what you say. Maybe it is because I always use one monitor only for each application or that I use so few my Wacom Graphire. Will test that issue one of those days.
BTW, H13N.H3N, nice desktop wallpapers!

I’ve created a specific topic to discuss about dualscreen+wacom on linux here :

@Genete: I’m curious to know your config :exclamation:

Sorry Genete, but i bring news not too good, i was working on Synfig, and testing some basic animation functions i found that hotkeys with the three-tool option is still a mayor issue for working, if i select with ctrl something out of canvas the cursor is also set to ctrl, but it does not toggle but is set to rotate and so, when i end my selection of layers from Layer panel, i find myself with ‘rotation’ enabled, this sometimes can be a threat, because make your current selection act weird if you don’t notice the actual change in manipulation tool (the three tool combined), i say so because Synfig crashed few times randomly but mostly because i rotated carelessly my selection of ducks thinking i would actually be moving them, i wanted to obtain the same bug that made Synfig crash with terminal open, but for some reason i had no more problems, you agree this is actually bad because whatever the reason is, Synfig keeps closing randomly, this bug seems to occur more when a duck is being manipulated in some way (including tangents). I’m sure that hotkey-ing for the three-tool fused can wait a little more, in my opinion, is good enough for now to leave it just with checkboxes to select the type of transforming, i’m sure you will be able to fix that anyway =).
btw, i made this XD, perhaps there’s a chance you’ll recognize her:


Here’s a bigger version, actually, the original resolution

Great. I’ll see what’s my configuration once I arrive home. I don’t remember to do anything special besides configure the twinview in the nvidia configurtion panel. Anyway, I would reply on the other thread.

@H13N.H3N: Nikitakit has commited a code change to alter the behavior of the keys during usage of the tools. Let’s see how does it work. I am interested on any kind of reproducible crash you can find. If there is a written recipe the better. If it is a random issue it will be harder to fix. With a recipe we can first confirm if it happens in previous versions and if so, narrow the problematic commit. If there is a always existing bug we need the recipe to trigger the problem when using the debugger. Crashes are nasty but not as hard to solve as other kind of bugs.

Errr… I have not idea, but she looks so cute!

i’ll keep working with terminal open, also check my log files to see what can i find, and yeah, at least in Synfig a random crash can surprise you, but is not as frustrating as GIMP for example (it lacks of backup support!) let’s say hurray for the backup option, it saved me from the frustration lot’s of times!

Got it!
I had no idea that this cartoon was Spanish! Although it has taken my attention several times. I like its saturated palette. :wink:
-G … e/download

Windows RC2 posted

FFMPEG updated to something more modern. (but still need to include the licenses)
Text box fixed so that default fonts work without explicit reference to the fonts dir.
Dialog boxes are looking good, but I’m still waiting for the dual random splashscreens.
When using the mirror tool the ‘toggle horizontal/vertical’ by pressing the shift button doesn’t ‘stick’. It will switch back once the shift is released. Or if the shift key is held down, will toggle back and forth rapidly.


Hey pixelgeek,
it is great the fixes for ffmpeg and text font. Regarding to Text fonts, have you done any change to the source code (including configuration files) or is it just a pre configuration issue?
I confirm the bug with the Mirror tool and also I add a bug with the Width tool: when you click and drag it doesn’t work. In windows it works when you click and release click so it is not the same behaviour than in linux.
Reset windows to original configuration doesn’t take account the bottom application bar but this is an issue of the windows manager. In Gnome (I assume the same in KDE and others desktop managers in linux) the window manager moves the window to a place where it is completely visible. Commands are the same for both linux and windows versions and behavior is different because of the windows manager behavior.
There is a weird bug too regarding to dual splash screen. I think it is the same problem than the windows position and sizes. for some reason the [0-1) float interval conversion to integer always gives 0 in windows. I’ll do some modifications for that code but I can only make work it in linux, so, please rebuild the windows binaries again when I release the final candidate this wednesday.
PS: ah! and I still seeing the “rendering in the same thread” console message. I thought I commited that change :blush: Need to re-verify.

Really? i tested both and they do work, is this a bug exclusive of Windows’s build?

In the previous post I was talking just about windows build. (tested on Windows XP)

Been testing 0.62.01rc2 a bit but haven’t found anything disturbingly wrong. Will test more indepth over this week and report anything I’ll come across.

Ubuntu 9.04, 64bit.