Synfig icon's problem


#1

I downloaded the latest version (stable) of synfig studio on my ubuntu 12.04 system, and when opening the .appimage, the gui has red icons with “xes” as shown in the attachment, i tried to look this problem in FAQ, but i didn’t understand how to solve the problem, so now i want to know how to solve this problem (in detailed steps if possible), any idea ?


#2

Maybe the download was corrupt? Have you tried downloading it again? I am on 16.04.02 but if it is available you could try installing it with a .deb file. If nothing works you could try with the latest dev build (which afaik contains some fixes). You might want to look into compatibility issues between stable and dev build, before you start using one of the two though.


#3

Firstly, thank you for replying. I have already tried downloading it again and it didn’t work “by the way it is available only in AppImage format” , and i have even tried older versions but all come with the same problem.
A question please, What do you mean by “dev” build ?


#4

You are welcome :slight_smile: Community is a big factor in free software, without it the development doesnt really flourish (look at Blender how big its community is!). I think they decided to switch to appimage because it was less work than having to make different packages for different distros.

By “dev” version I meant this one: morevnaproject.org/2017/05/22/s … velopment/ you can download it and try if it fixes the problem. (The download button takes you to gumroad website where you can make a small donation and download it or if you don’t want to donate just go at the bottom of the page and click the “anonymous download” button). As I said before just be sure you don’t start a project with a dev version and then switch back to an older because I am not sure if they are compatible.

If nothing works maybe it is just a bug and you may want to open a bug ticket on github github.com/synfig/synfig if you don’t have an account (and don’t want to create one) just let me know and I can add one and put a reference to this thread.


#5

Firstly, Thanks a lot

If you don’t mind, i hope you help me out with the thread , because i have tried the “dev” but nothing changed.

And thanks again.


#6

You said you are on ubuntu 12.04, can you tell us more about what system you have?what desktop environment you use and if you use a custom theme/icon pack not shipped by default? (In that case try to use the default them). I will open a ticket on github for you once we have a bit more details to add :wink:


#7

(Before anything sorry for the very late reply, i had a lot of things going on, so i left anything related to 2D-animation for a long period of time, sorry again.)

Okay, so since i am a total newbie when it comes to ubuntu, i don’t know if i can give you the right answers, but i will try, and i hope i don’t lose your attention.

Firstly my system is : ubuntu 12.04.5 LTS
Desktop Environment is : ubuntu (that what it is written in hardinfo)
and custom theme : i didn’t change anything since the OS came with my Laptop.

Thank you


#8

Please use the last (dev) .appimage (link in my signature) :slight_smile:


#9

I just did that, and nothing changed


#10

Hey,

I found out the solution
Used for test: VirtualBox + Ubuntu 12.04.5 LTS i386 and Synfig 32 1.3.4 32bit

With --appimage-extract as parameter, an error for PNG files appear: “Bad parameter to zlib”
With a little search, you have to install zlib1g package (according your version)
packages.ubuntu.com/trusty/i386/zlib1g/download
packages.ubuntu.com/trusty/amd6 … g/download

then dpkg -i zlib1g_1.2.8.dfsg-1ubuntu1_i386.deb (or zlib1g_1.2.8.dfsg-1ubuntu1_amd64.deb)

Restart Synfig, it should work like for me :wink:


#11

Thank you very much, i tried it and it worked, that is really helpful, so thank you

and this is the result :