synfig hates me

Have you experienced this problem?

  • Yes (once)
  • Yes (more than once)

0 voters

I am using Synfig Studio on a Windows XP machine. My first impression of it was very good. However, a first impression was all I got. Here’s why:

At first, Synfig ran relatively well. The first time I clicked on the “New” button, it crashed, but the next time I started it up, everything worked fine. I worked through a few tutorials without trouble.

The next time I started up my computer, I started Synfig Studio. The splash screen popped up, Synfig loaded happily, and then…nothing. I got the Synfig Studio command window and nothing else, no windows at all. See below screenshots: “splash.bmp” (screenshot of loading screen), “start.bmp” (screenshot of what I saw afterward). When I clicked the “X” button to close the command window, I got an error (see screenshot “exit.bmp”).

So next I thought maybe the windows were there, just out of view or too small to see or something, so I right-clicked on one of the Synfig windows in the taskbar and clicked “move”. I got the move cursor (four arrows) at the very top-left of the screen, but clicking and dragging produced nothing. Then I tried right-click: resize with the same result. The whole time, identical error messages piled up in the command window (see attached screenshot “errors.bmp”).

Next, I opened up the Synfig\examples folder and opened up a few examples, all with similar results. I got the example but no supplementary windows (i.e. toolbox, keyframes/timeline/other stuff, tool options, etc.). See screenshots “eye1.bmp” and “eye2.bmp” for what I got, plus what the command window said. When I closed Synfig after viewing these examples, I did not get an error message.

I tried restarting the computer. This did not solve the issue.

I have the latest version of GTK+, gtkmm, Synfig core, and Synfig Studio. I tried uninstalling and reinstalling all of them and nothing fixed the problem. I also tried changing the GTK+ theme a few times, with no change.

All of the exact same things happened on another similar Windows XP computer I tried Synfig Studio on. Included in the download are the dxdiag files from both computers. I regularly run a virus scan on both computers and they are clean. Neither computer has an internet connection.

I hope someone can solve the problem so I can start using Synfig Studio again. Being a programmer myself, I’ve included as much information as possible because I know every little bit helps, but if there is any more information I can provide, let me know and I will post it ASAP.

[later] I just found out that, strangely enough, Synfig Studio works fine on my brother’s account on the computer. Obviously, I can’t have him around all the time to log me in to his account and monitor what I’m doing, so that doesn’t solve the issue by any means…but still, more information.

[later] I just deleted the Synfig folder in Documents and Settings\floodbud. Synfig Studio then worked fine once again…so this is no longer a life-and-death situation, just a frustrating functionality issue (same with other computer). I’ve created a Windows batch file to handle deleting the Documents and Settings\floodbud\Synfig folder, so it doesn’t bug me so much…but I think other Windows users less computer-savvy than me must be having problems too. I’ve attached the batch file I’m using.

thanks!

attachments

1 Like

As you have read in the FAQ’s that bug is partially solved since revision 1167. To avoid that on windows just update to a higher revision or wait up to the next release. Visit the Download section of the wiki for the most non official recent svn revisions for windows.

THE PROBLEM REMAIN SAME IN 2021 :laughing: :rofl: :rofl:
PLEASE SOLVE THAT ISSUE

Hi, Haroon.
Several crashes and bugs were fixed along those years, and a lot of features were implemented or improved.

Some more crashes will be prevented in the next 1.4.1 version (it’s just around the corner!) and the Synfig not showing on Windows will be fixed too.
This bug could happen when you close Synfig:

  • In a multiple monitor layout and you later run Synfig with only one monitor; or
  • when Synfig was minimized.

When quitting, Synfig stores the last window size/position in a settings text file.
Differently on Linux, MS Windows tries to display the Synfig window in no longer valid screen coordinates.

If you were talking about other bug, please clarify.

@HAROON
Please be more constructive, don’t use CAPS and don’t do necroposting.
If you are not a bot, open your own thread or report on GitHub.