Synfig crashing whenever I click any node on a bone (Windows 10)

Hi there, I’ve been having this problem for a few days now where Synfig crashes instantly with no error message, looked through previous threads and tried a few things and am no closer to solving it. So my Synfig crashes every time I click on any node on any bone on the character I have. Previously everything was working normally and I have a few waypoints and keyframes for the animation where I was rotating the bones normally. A few things I’ve noticed from my experiements so far:

  1. I save my files incrementally (there are 15 of them so far) and the bug now happens no matter which one I load
  2. I’ve tried the public stable version and the experimental version, 32 bit and 64 bit, portable and installed, and I always run as Administrator
  3. This happened once before and I tried to find a solution for a few hours and seemingly failed. Upon one of my many random starts of Synfig (it happened to be experimental 32 bit, installed, debug mode) the problem seemed to randomly go away for the rest of the day until today, where it’s happened consistently about 30 times in a row whenever I click on a bone node, seemingly no matter what I do beforehand (animation mode on or off, create a shape, whatever)

Now what is the next step? How do I find the crash logs? Should I post a copy of my save file?

Thanks for your assistance! I’d hate to just have to give up on Synfig and scrap the whole project. But if this continues it seems I’ll have no choice.

Edit: I also get these warnings in Debug mode when I start up Synfig 1.5.1, not sure if they’re relevant:

(synfigstudio.exe:13844): Gtk-←[1;33mWARNING←[0m **: Could not find the icon ‘missing-image-ltr’. The ‘hicolor’ theme
was not found either, perhaps you need to install it.
You can get a copy from:
Index of /releases

(synfigstudio.exe:13844): Gtk-←[1;33mWARNING←[0m **: Allocating size to gtkmm__GtkWindow 05B572C0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

Sadly there aren’t crash logs.

As you described the problem suddenly appeared with all versions and releases, please post your save file.
If you can’t upload it here yet (for spamming prevention), you can upload somewhere else and provide a link here.
If you can’t let it publicly available, please PM me.

1 Like

Before anything you should try backup/remove the config files in your profile (C:\Users\YourName\Synfig).
Maybe there is a setting that has been messed up.

1 Like

I didn’t want to jinx it but I’ve been working a couple days and the issue seems to be fixed! Must have been some kind of weird setting or something going on. I was wondering if there was some kind of user data that persists through all versions so that makes sense. If it happens again I’ll open a new topic. Thanks guys!

1 Like