Synfig crashes while starting


#1

Hi,
I’ve downloaded the version ‘SynfigStudio-1.2.2-18.09.14-win64-286f1’ and installed it. I’m running Windows 8 64bit.
After I start synfig it crashes. When I start synfig (debug console), I got the following error message:
‘synfig(5304) Cannot open ./synfig_modules.cfg’
I’ve found the ‘synfig_modules.cfg’ file in the folder ‘etc’ and it’s size is 1kB. Maybe it’s in the wrong psoition or it is corrupted?

I’ve tried new installations and even downloaded synfig again, but I kept the same error.

I hope,you can help me
Scribble


#2

Hi and welcome here :grinning:
You can ignore this message
Did you install Synfig as admin?
Did yiu install in a folder where your user has write access?
Normally you should have a folder for Synfig in your profile, you could try to delete it.
Anyway, you should better try 1.3.11, as portable (zip) and unpack it in one of your own folder (desktop for example)


#3

Hi,
thank you for the answer, but I still have the same problem.

I’ve installed the ‘SynfigStudio-1.2.2-18.09.14-win64-286f1’ version as administrator and run it as administrator
=> it crashes.
I’ve installed the ‘SynfigStudio-1.3.11-testing-19.02.09-win64-9583a’ version as administrator and run it as administrator
=> it crashes. This time the debug window closes automatically.
I’ve downloaded the ’ ‘SynfigStudio-1.3.11-testing-19.02.09-win64-9583a’ version as a zip file. Unfolded it, startet as administrator.
=> it crashes

Funny thing is: all folders of the Synfig installation are write protected. I can’t change it. But all users of the system have access to the Synfig folder. So, I should be able to change the write protection :thinking:

There is no Synfig folder in my profile.


#4

Normaly you don’t have to use Administrator power.
Just extract the archive on your desktop (in a folder maybe) and launch the .bat file inside.
If it is not working, try to disable your antivirus during download and install, some may consider it infected (see https://github.com/synfig/synfig/issues/827)


#5

Hi,
I tried your solution, but it doesn’t worked. I’ve even tried it with the 32bit version. :disappointed:


#6

Try to check your GFX drivers.
It is hard to guess why it crashes on a specific system (and for different versions) without log output.
For the others it works, so it comes surely from your install.

In the worst case, you could install a Linux in a Virtualbox :wink:


#7

Hi again,
I’ve never had problems with GFX driver and other programs before.But I had a look in the driver section:

  • nvidia gtx 770 is ok
  • driver section shows no problems
    To be on the safe site I updated the driver to version 23.21.13.9135.
    => I’m sorry to say it, but synfig 1.3.11 crahes and crashes and crashes at the start.

where can I find the log output?