Synfig crashes upon render on a mac

hi guys!

I´m trying to render a scene in ffmpeg, 1920 x 1080, video bit rate 20 000, quality 9 on a mac mini.

the quality of the images are… well… quite high…

everything works fine… preview works without any issues as well as anything else but when I try to render, it crashes.
the error log is attached.

can the quality of the images be to “powerful” for my computer to handle or is the issue something else?
error (15.5 KB)

As a work around, when I get rendering problems to ffmpeg, I find that a png sequence always works.

I´ve been thinking about that myself…
…but how do I merge them into a avi or mov afterwards?

I use ffmpeg or Kdenlive, depending on what I want to do with the resulting file.

FFMPEG is a cross platform command line tool that you use from the terminal window - it’s at

For instance, if I wanted to turn a 50 frames per second png sequence numbered diam0000.png to diam0250.png into a lossless 50fps HuffYUV video file I’d type:

ffmpeg -f image2 -i diam%04d.png -vcodec huffyuv -r 50 output.avi -r 50

Sorry, but I´m still a beginner with this…

So if I want to render in ffmpeg (parameters 20 000), Quality 9, 1920 x1080, image001 to image250, avi. 4 seconds as it shows is synfig. how do I do then?

Just a couple of quick questions before I can answer you - which video codec do you want to use (h264, xvid) and how many frames per second are in your Synfig animation?

xvid. I want to use 24

ffmpeg -f image2 -i image%03d.png -b 12000 -s 1920x1280 -vcodec xvid final_video.avi

That will take:
image001.png onwards, at
12000 kb/s bitrate at
1920 x 1280 resolution with the
xvid videocodec

24fps should be the default but you can specify it with -r as I did in my first example above if you want to.

Obviously you can add the path to you image files so that would be -i C:\temp\pngs\image%03d.png but I haven’t got Microsoft Windows so I can’t check this.

I hope I got that right! Let me know if not.

still one question before I try…

ehm… this is kind of embarrassing.

i checked out and downloaded the FFmpeg Mac OS X Builds but I don´t know how to use it…
…do I need to run it from the same folder as the png files or what? :S

Don’t be embarassed - no one’s born knowing this stuff, we all have to learn sometime. I’ve asked some really, really simple questions on this forum!

In Linux what I do is change the directory to the directory I put my pngs in, so for me I get a Terminal window open and type:

cd Videos/sequencer

This changes the current director to the one I exported my pngs in.

I tried with the one I downloaded from but it said “process ended” before I even had a chance to try it out.

I tried then the terminal in MAC and I was able to go all the way to the folder where I had the images but when I ran the sequence you told me to run, it said “-bash: ffmpeg: command not found”

what am I doing wrong?

For Mac try to use Macports. It is like using a package installer in linux.
In Macports on internet there is information to install properly ffmpeg. Once installed. It will be in the executable path in a terminal.
In any case you can check where is the executable by writing in a terminal:
$which ffmpef
that should return the path to the binary.

I hope this helps.

Thanks! I´ll try it out and get back to you.
the thing that is bother me though, is why synfig crashes upon rendering when the images are high def. on my mac. I tried on a pc as well and the same issue there. the images are 2000x2246 and around 700kB, but that shouldn´t be any problem right?

I’ve rendered images of 18000x18000 in my mac before it crashed. It is just a question of architecture and dimension of the RAM.
just do the numbers:
Width x Height x 4 channels x 4 bytes per channel


I´ve tried on both my mac mini and on a
HP elitebook as well as on a Dell latitude… so I´m guessing all of these computer are not good of rendering large images … I´ll try to make the images smaller I guess.thanks :slight_smile:

Remember that the 32 bits architecture only can address 4 GB of RAM