Synfig cant read files from list in some machines

Several students in my class reported they couldnt import a list correctly. The “.lst” file is imported successfully but the images dont show. I cant reproduce this in my computer and other four windows machines (win 10 and 7). One student put the image files inside the “program files” folder end it worked!

Whats is happening!?

It is probably an issue with one (or several) of the following origins:

  • admin rights on the machine (or run as) - if he can place files in “program files”, he is admin
  • regular install or portable? if portable, the files have to be placed in a folder with user access rights
  • non-latin chars/spaces in the path or the name of the user…
  • in the .lst, path are relative or absolute? (access rights also again)

It happened on old versions (1.2.2) and should be fixed by now

Hi, BobSynfig!

He tested running synfig as Administrator but it didn’t load the imagens files. If it was a matter of admin rights, this wouldn’t solve the problem?

Again, running synfig as Admin would do the trick, right?

I’ll check that

Relative. Loading files didn’t worked in Papagayo and image sequence list I had created in my computer and worked on the computers at my place and my school.

If i’m not abusing your patience, could you test the following file? Its the offending “.lst” and its repective image files. Its just Criswell from “plan 9 from outer space” speaking a piece from his monologue. :joy:

https://drive.google.com/file/d/114c81JZAAR3bsm6i_rcYRgHpNgfo7ECF/view?usp=sharing

Thank you!

No problem under 1.4.0 (Ubuntu).
The .lst is fine with import, with the png and lst in the same folder
On 1.2.2 I had a problem of display (old png bug when using transparency)
Which version do you use?

I couldn’t reproduce the problem too. The file works fine on my machine in 1.3.16 and 1.4.0 but doesn’t work on several students in using both versions. I believe they are using the installed version but tests with portable builds lead to the very same effect: “.lst” file loaded with success and no images displayed.

But they can reproduce it?
If they run Synfig Studio with console open, maybe a helpful message could appear (helpful at least for us developers :wink: )

Edit the .bat file and change the following line (the last one):
start “” “%~dp0\bin\synfigstudio.exe”
to:
start “” “%~dp0\bin\synfigstudio.exe” --console

You can edit it by right-clicking on it and choosing “Edit”: it will open the .bat file via regular NotePad.

Report here any message that appears when they import .lst or when they change the current time on workarea (that’s when synfig actually looks for image files reference by .lst).

As BobSynfig pointed, check if:

  • non-latin chars/spaces in the path or the name of the user… (We still had/have some problems with that, but as you/we are Brazilians, the possible trouble nay be spaces, not characters)
  • in the .lst, paths are relative or absolute.
    Absolute means the image file path contains all folders to locate file since root. Example: C:\Users\xxx\yyy\zzzz\blablabla.lst
    Relative means that they are referred to current working path or another file folder. Example: zzz\blablabla.lst or ..\blablabla.lst (you can see that, on Windows, it doesn’t have C:\ or D:\

Please open the .lst in Notepad (Bloco de notas) to check it. It is probably one of those two potential problems: folders or files with space on their names or absolute/relative path issue, as you said the problem happens on both installed and portable situations.