Synfig 0.63 Release Started!


#21

yes, that works, indeed it was the first thing i did even before report it in the forums, i think it was or is an issue because the installer didn’t asked for it’s installation, now the only thing left is a good test to see what it works and how it works, greetings1!

Edit, btw, you all did an amazing work, just look at the smooth looking of ducks, this is great!


#22

Genete: Yes I’m gonna finish the core translation too! I’ve sent you a PM at Transifex with my name for the credits :wink:

Zelgadis: Thanx man for the tip. And so I’m waiting for next release with full advanced outline support. Very cool feature by the way, I already like very much the smooth and precision it gives to outlines… This on a good pencil-drawing tool will be a killer feature !


#23

All this thanks to efforts of Genete! ^___^


#24

Zelgadis, can we add the missing library to the building script?
I think it is available for debian stable:
packages.debian.org/squeeze/libx … -util0-dev
I wonder why did it work fine in older versions of Ubuntu (i.e. 9.10)
-G


#25

Give all thanks to Nikitakit who implemented the cairo renderer! :slight_smile:
-G


#26

There’s no need to do that - it is redundant dependency. I already fixed build script. Will commit as soon as I will get to my PC. ^___^


#27

Damn… Linux packages are quite unstable.
For example: select width tool, click on the canvas -> crash. This not happens when built from source manually. I need to find better combination of library versions…


#28

.


#29

Strange, this doesn’t happen to me . I installed .deb package on Ubuntu 10.10 64bit, it works nice as far as I’ve tested.


#30

I have tested on Ubuntu 9.10 (32bit) and it was crashing every time.
Now testing on Fedora 13 (32bit) - works fine.
Looks like the problem with my OS configuration. Good. Not touching the build script.


#31

Genete,
Can you take a look at this and give suggestions? I ran into problems compiling synfigstudio-cellrenderer_timetrack

pastebin.ca/2050752

Thanks,
Chris


#32

The offending line (duckmatic.h:355) was added by Nikitakit for beizer dragging implementation but it is just using a structure that is being declared later (duckmatic.h:484). Seems that your compiler doesn’t solve properly forward declarations for templates… Or it is possible that you are using an old duckmatic library (without new implementations) and then you’re not compiling duckmatic again, using the old version, messing it up all.

First of all try to clean all the local git repository and start over again.
If that fails, move to an earlier commit than the one that is modifiying duckmatic.h and try again.
If that success, then move forward to see why is it not compiling properly.

I hope that just clean can solve that problem.
-G


#33

No such luck. Clean install - same problem :frowning:

Is it just as simple as reordering the declarations in the file?


#34

You cannot reorder the declaration. When you have a class inside a class you need to do a forward declaration of one of then first in any case.

Did duckmatic.cpp compile fine? Are you using multicore compiling (more than one make thread)? which gcc are you using? Did you rewind to Synfig 0.62.02 and tested the compilation?
-G


#35

Reproduced width tool crash for packaged synfig again… This time on Fedora 11 32bit. And it gives me more output: pastebin.com/nJpe0U2V


#36

Installing Fedora 11 32 bits on VMware.
-G


#37

Synfig Studio 0.63.00 RC1 running on Fedora 14 32 bits over VMware doesn’t reproduce the Width Tool crash.
Still downloading Fedora 11.
-G


#38

$ gcc --ver Reading specs from c:/mingw/bin/../lib/gcc/mingw32/3.4.5/specs Configured with: ../gcc-3.4.5/configure --with-gcc --with-gnu-ld --with-gnu-as --host=mingw32 --target=mingw32 --prefix=/mingw --enable-threads --disable-nls --enable-languages=c,c++,f77,ada,objc,java --disable-win32-registry --disable-shared --enable-sjlj-exceptions --enable-libgcj --disable-java-awt --without-x --enable-java-gc=boehm --disable-libgcj-debug --enable-interpreter --enable-hash-synchronization --enable-libstdcxx-debug Thread model: win32 gcc version 3.4.5 (mingw special)
How do I tell if it’s multi-threading the compilation? I don’t think it’s that clever, but who knows?
Did duckmatic.cpp compile fine? I don’t see it listed in the output, but I can search for it more tonight. Can I just compile it standalone? How do I do that?
I’ll rewind to 0.62.02 tonight, but I’m very confident that it will work. (That’s where I started from)

Chris


#39

Installed Fedora 11 32 bits from this link: ftp.udl.es/pub/fedora/linux/rele … 6-Live.iso
Installed Synfig Studio 0.63.00 RC1 32 bits rpm package from sourceforge. On a VMware
Installed xcb-util-0.3.4.fc11 asked by synfigstudio.
After run synfigstudio from commandline and use the Width Tool, nothing strange happened. Not crash.

-G


#40

Probably it is not multithreaded on compilation (make -j4 for 4 threads) if you are asking it.

carlos@pcnuevo:~$ gcc --ver Using built-in specs. Target: x86_64-linux-gnu Configured with: ../src/configure -v --with-pkgversion='Ubuntu 4.4.3-4ubuntu5' --with-bugurl=file:///usr/share/doc/gcc-4.4/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --enable-shared --enable-multiarch --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.4 --program-suffix=-4.4 --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-plugin --enable-objc-gc --disable-werror --with-arch-32=i486 --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu Thread model: posix gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5)

maybe the compiler is too old? I don’t know.
Can you use this one instead?
cygwin.com/packages/gcc4
-G