Synfig 0.63.01 RC2 binaries available

After some months of work, finally it is ready the first candidate release for 0.63.01. Initially there is only the linux binaries.
Please checkout your preferred version and feed back about any bug or missing functionality for the new additions we have included:

  • Some build scripts improvements: zelgadis
  • Canvas Window icons redesign and layout: jcome
  • Guides undo capability, zoom level dependent and bux fixing: nikitakit
  • Advanced Outline Layer: better interpolation procedure, widthoints positions length based selectable, dashed outlines optional: genete
  • BLine Link convert type now offers homogeneous option for length based positioning (allows constant speed traveling along the bline): genete

Also it is worth to feed back the new Inkscape plugging script to export from Inkscape to Synfig format made by nikitakit. Hopefully it will be included in the next Inkscape release. Details here.

Download Synfig Studio binaries here: … -binaries/
Please choose 0.63.01.rc1 and your system binary (32 or 64 bits)

32 bits binaries (rpm and deb) has a bug when interpolated width point position is negative: Synfig Studio hangs. I hope we can fix it in the next candidate release. 64 bits binaries doesn’t have that problem.


EDIT: Release Candidate #2 has been release. See below.

I’ve fixed some mistakes from the previous Release Candidate:
-As requested, by default, Linked to BLine values are homogeneous (position is bline length based)
-Fixed some render artifacts due to not consider properly the loop option of the Width Point List.
-Fixed hang/crash bug for 32 bit binaries that happened when interpolated width point position is negative.

Please report whether those fixes are true and/or any other bug/mistake you might find.

Download files here:
Debian like packages (deb):
64 bits: … b/download
32 bits: … b/download

Red Hat like packages (rpm):
64 bits: … m/download
32 bits: … m/download

Universal binaries:
64 bits: … 2/download
32 bits: … 2/download


It seems the patch for sif version issue is not applied. i will check it later on while i have time.

Fixed. Will be included on RC3

Getting this error on Ubuntu:

“The package is of bad quality
The installation of a package which violates the quality standards isn’t allowed. This could cause serious problems on your computer. Please contact the person or organisation who provided this package file and include the details beneath.”

Lintian check results for /home/chu/Downloads/synfigstudio_0.63.01-20110910.rc2.8_i386.deb: E: synfigstudio: maintainer-address-malformed root <root@>

Windows release is posted

The shortcut accelerators in the blend method and interpolation drop downs from the toolbox are showing up as underscores preceding the letters rather than under the letters. They also don’t seem to work.

Also, I notice the zoom indicator % doesn’t show up until the zoom level is changed on the navigator panel. I can’t remember if this is a regression or not.


That will be (hopefully) solved in next candidate release.

Downloaded and installed into a Windows XP machine without any issue. Great!

It is a known issue. The usage of the old widget (Gtk::OptionMenu) is deprecated and the new one (Gtk::ComboBox) doesn’t use keyboard acellerators. Do anyone use keyboard acellerators to change the default blend method?
It also happen with the default interpolation method. Apart of remove the underscores, does anyone suggest to recover the old and deprecated widget (Gtk::OptionMenu)?

Can’t reproduce it here. Do you mean the zoom indicator of the navigator panel? I see it updated when zoom is changed. Does it happen under a particular file?


Everything seems to be working fine here!

Linux mint 11, 64-bit, Gnome.

Yes, it shows up once you change the zoom, but not when you first open a new file. May be working as designed.


Latest RC2 binary, Ubuntu Natty Narwhal, 32 bit.

While animating in Animate Mode (some linked blines), while everything else works, the Timetrack scrubbing occasionally slows down or hangs up. =/

EDIT: Also, the TCB interpolation looks extremely stiff. It isn’t as smooth as it was before. :frowning:

Can you paste one file that shows that behavior? we can open it with older Synfig Studio versions to see why is TCB so stiff now.

Hmm, weird. Either the error isn’t reproducible or it was just a human error. I tried the older file (my current project) and while animating in TCB the motion was stiff, but creating the new file and trying the same seems normal. o_O

Yeah, most likely human error, I’ll take a look. Sorry about this. :blush:

while doing translation, I found that advanced outline has an issue on param panel see attachment. When double click DashItem001, the value of it will becomes “Unknown Datatype”

Ahhh, good catch!
that’s because the composite value nodes shouldn’t be editable using double click and I think I forgot to give that behavior as the other composite value nodes. (The thing now is to remember where in the code does it happen… :unamused: )

I take a few minutes to try to figure it out. but failure .

Question: When is the next release scheduled? Is there a PPA? Has the “quality check” error via Ubuntu Software Center been fixed?





You mean the next stable, right? XD Thanks! I’ll keep my eyes out then. Got something planned.