Synchronising an animated curve and a symbol

Probably a frequent problem: I’m using ‘Synfig studio 1.4.0’ on opensuse Leap 15.3. I want to trace on a map a route. The leader is a circle that is leaving the track behind. So at the end you see the whole track on the map. Using the advanced spline tool I traced the track. When I had some 30 verteces ‘Synfig studio’ crashed.
So I decided to break down the whole track into shorter stages. Each stage is represented by a group combining the circle and the spline. The centre of the circle is linked to the spline curve which is animated by defining the second widthpoint with a peaked header. And the circle is animated in animation mode to go from tail to the head of the spline.
The whole thing works in principle. However, the circle and the spline header are not always synchronously moving, at times one is ahead of the other and vice versa.
Is there a way to link the circle not just to the spline but specifically to the head of the moving spline?
Is it possible to add more widthpoints and when yes when would that be usefull?
Is there possibly a better strategy to achieve what my intention is?
In edit mode I define all the stages and set their opacity to 0. In animation mode I then start with the animation of the first stage. However I noticed that the later stages now also appear slowly. So I have to set each later stage manually back to opacity 0 on all the waypoints of the previous stages. What did I do wrong?
Thanks for any help ind advance!

Hello again gm40,

For the spline desyncing, make sure your spline’s Homogenous parameter is checked. Also set the waypoints for your width points and circle motion to be the same type (clamped, TCB, Ease In/Out, or Linear). Delete any waypoints that are between the start and end of your motion.

You can add more width points by right clicking on your width point and selecting Insert Item.

The unwanted fade-in animations probably happened because you had active keyframes after the frame you animated. Synfig automatically adds waypoints on adjacent active keyframes which will tween back to the base state set in edit mode. You can just delete the extra waypoints to remove the animation or deactivate the keyframes in the keyframe panel to keep extra waypoints from being created while animating.

Synfig really should be able to handle a spline with 30 vertices without problems. If your file is crashing consistently then we should submit a bug report.

Curiosity: any reason for not using 1.4.2?

Curiosity: any reason for not using 1.4.2?

Complacency, I suppose and satisfaction with the current version. But I promise to kick myself!
Thanks for the tip: Homogeneous - I wondered what it meant, so I unticked it. Now it works like a charm.
Thanks for the help. I shall get back to creating many vertices and see whether it crashes again. Maybe I do need the update to the latest version after all.

1 Like

Another question in this context: If an image is heading the crawling track on a spline curve its orientation follows the course of the spline curve. Is it also possible to keep the orientation of the image always constant (disconnected from the orientation of the spline curve), i.e. let’s say horizontal?


  1. Select the image.
  2. Click on it Blue Handle (rotation)
  3. On Parameter Panel, the “Angle” parameter of Transformation should be selected (due to step 2).
  4. Right click on this “Angle” item (on Parameter Panel, not the blue handle) and choose “Disconnect”.

Thanks for the quick response. If I do what you suggest I disconnect the image completely from the spline, not just the angle. However, I want the image to follow the spline but in a constant position as the angle is concerned. Btw, I’m now on 1.5.0!
I also had a crash when manipulating the spline at one of the vertices. Can’t repeat it, though.
My test case: ImageOnSpline.sifz (2.8 KB)

You should right-click on “Angle” in Parameter Panel, not the blue handle.


I just wanted to say 1.4.2 tends to be (way) more stable than 1.4.0.

You should right-click on “Angle” in Parameter Panel, not the blue handle.

Thanks, that solved the problem and thanks for all the help!

1 Like