Strange export problem

When I save my files I can only find their .sifz format, although it’s supposed to be auto-saved in a form usable outside synfig. First time I saved my work, the exported file was there all right, but wouldn’t open (I had an error message). I re-saved in another location, all exports disappeared, and aren’t even found by file search. Only .sifz files are there, working properly.

I have to ask for your kind help once more… :frowning:

Synfig’s native file format is sifz (or the uncompressed version sif). It stores all the vector information of the animation. When you export the animation (render it to a movie or a image sequence) all the vector information is lost and it is applied to the raster world (bipmap or video)
At the moment, there is no way to export the Synfig’s animation in “vector format” in other format that is not the native one (sif(z)).

Waitasec, then how can you all upload your vids in youtube?
(And I actually saw it appearing in another form too, .avi I think. No kidding. O_o)

Youtube needs movies (avi, mov, flv) to be broadcast. Synfig can produce movies. When render the animation, just select the proper name and extension (mymovie.avi) and use the ffmpeg renderer.

So I go to file -> render and then what? putting .avi in the end of the file name does nothing and when I choose .gif from the list below I get no result when I save, either…
Where is ffmpeg renderer?

HI you can take a look at this page

btw, the page is not updated with the version 0.62.01, but you can get some usage of render option i am sure.

enjoy your creation with synfig :slight_smile:

Thanks, but I already tried. Seriously. Downloaded ffmpeg, then rendered my video to png, but neither zConvert nor Super c frontend seem willing to convert the png files to proper video. With the first one the supposedly ready video simply disappears, in the second I get error message.

This is getting really frustrating… Just how do you guys do it ???
Hell, it can’t be that difficult…

maybe we should start from the beggining…
0) Synfig Studio version: 0.61.09, 0.62.00, or 0.62.01?? If 0.62.01 go to 5)

  1. Windows or linux?
  2. If windows, did you installed the latest version? here
  3. If linux did you installed the latest version? here Be sure to uninstall any other version you may have installed before.
  4. If linux, which version?
  5. Go to Caret Menu->File->Render and in the dialog give a name to your animation (with extension .avi) and select form the combo drop box “Ffpmeg renderer”. It should work.
  6. If eveything fails then select “png” from the drop box and give .png extension to your render output. Then you need Avidemuxor any decent video editor to complete the movie creation. Ask more if you reached this point.

Thanks again for the reply :smiley:
I have windows XP, version 0.62.01. Already tried #5, but I thought I did something wrong as the .avi doesn’t show my animation (it plays a video with white screen).
I’m currently trying #6. I hope that works. :slight_smile:

Weird, windows version 0.62.01 comes with its own ffmpeg renderer included.
Maybe pixelgeek (our hero windows maintainer) can have other idea

Hi Nimue,
When you render a file with an .avi extension and ffmeg as a target then make sure that you set the parameters to a codec that your system is able to play. Try windows media video 8. That worked for me untill I updated all the codecs of my media player.

not sure if there is bug in windows version.

Some times synfig can not render files with ffmpeg option, but some times it works.
With the first cause, you will be shown “File rendered successfully” in the status bar of canvas window, but actually the size of the result file is zero. and take a loot at the cmd window, you will get the message as attached.

maybe I should post this in “debugging” sub-forum instead.

Seems to be a bug. Maybe it loose the “.exe” in the executable. Please confirm the behavior and open a bug tracker. I need to run Synfig Studio in my virtual Windows 7 to check it out.
Be sure that you selected all the options in the windows installer. Maybe it failed or the option was unchecked and ffmpeg was not installed.
Good luck and sorry for the inconvenience.

I never encountered that rendering problem with the latest windows version of synfig and I already did a fair amount of render tests. I use XP sp3. I just had problems with the codecs which were solved after installing K-lite.

On my computer, windows xp sp3, sometimes ffmpeg works, sometimes not. I dont know why.
When it dont work, I use png render, and I make video in Virtual Dub.

Thanks, Mad0! :smiley:
Virtual Dub proved to do the job very easily! (It didn’t work any other way for me, but no need to try anymore)
At last I can use this awesome program!!! :smiley: :smiley: :smiley:
(Okay, I could already use it, but now I can show off too :p)