[SOLVED] Synfig 1.2.0 - .lst files cause Synfig to crash


#1

So, long story short, I was messing with two .lst files in Synfig, and for some reason, the preview window would stop at a certain frame. I drag the timeline bar to that frame to see what’s going on, and I get this:


Then Synfig crashed.

Several days later, after reinstalling Synfig to try and fix another issue, I decided to see if reinstalling it fixed this problem as well. I added two .lst files and went over the timeline. When it reached 2f, Synfig gave me the same messages and crashed. Interestingly, the “synfigstudio.exe:5884” seen in the first image keeps changing the number every time it crashes. Plus, it is very consistent on what frame it crashes on. For example, if I just import two .lst files and leave them alone, Synfig will crash as soon as I go over 2f on the timeline.

Anybody else encountering this problem? :confused:


#2

Did you consider the possibility that something is wrong with your .lst files? Do they refer to files in the same directory, do those files actually exist, etc. You can try uploading your sif(z) with all dependencies if you really think the problem is with synfig itself. Otherwise there’s not much we can do about it.


#3

Figured out what was wrong. It’s a bit embarrassing but I’ll detail it out just in case someone else runs into the same problem. :blush:

So after a bit of checking and testing, I noticed that my images were numbered 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 11, 12 (noticed how I skipped 10).

My .lst files were like this:
0.png
1.png
2.png
3.png
4.png
5.png
6.png
7.png
8.png
9.png
10.png
11.png
12.png

It turns out that I had a 10.png in the .lst file when none existed, causing it to crash whenever I used the .lst file. I had to edit the image sequence a lot, so I guess it just slipped by me. :blush:


#4

Well, the crash itself would still be a bug. However i can’t reproduce it - for me synfig refuses to import incorrect .lst and opening existing file with incorrect .lst leads to “layer rejected filename parameter” and ignoring .lst layer.


#5

Interesting. I decided to purposely make some faulty .lst files and try to import them. These .lst files referenced all the images in the folder (0 through 11), but also referenced a non-existent “12.png” in different spots:

  • When “12.png” was put at the beginning of the sequence, Synfig would immediately close upon importing the file.
  • When “12.png” was put at the end of the sequence, Synfig simply prevented me from importing the file.
  • When “12.png” was put somewhere in the middle of the sequence, Synfig would crash the same way I described in my first post.

From what I can tell, it seems that Synfig can be tricked into thinking a .lst file is valid if most of the image references in the file are also valid (unless an invalid reference is put at the end of the sequence, then Synfig will catch it).


#6

Yeah, i haven’t tried playing with incorrect filename placement - now that i did, i caught the crash.